Show Posts

You can view here all posts made by this member. Note that you can only see posts made in areas to which you currently have access.


Messages - vga256

Pages: [1]
1
Engine Development / Re: AGS engine Mac OS X port
« on: 30 Nov 2018, 23:40 »
It's still a bit of a mess, but I got a working build of a game project (not a real game) running on OS X High Sierra with Steam achievements.

I cloned Janet's osx-nick branch and reused the WEG Xcode workspace files (and the Shivah project files). I tried to figure out how to embed a binary version of AGSteam into the app, but I kept getting an error that the library didn't exist in the final executable. So instead I followed the approach that was already partially implemented by WEG (judging by the project files and the lack of an existing port of AGSteam to Mac), and built the AGSteam source directly as part of the project files. Took a bit of knackering about as I've never used Xcode (or even OS X) before, but it definitely is working.

I will try to make a more detailed post of what I did after I try to abstract it out of the WEG files. ;)

Just want to pass along word that I figured out how to build AGSteam as a dynamic library in Xcode, and link it to my AGS project... just as monkey0506 did. I'll be posting instructions here soon, for anyone interested.

2
Engine Development / Re: AGS engine Mac OS X port
« on: 30 Nov 2018, 21:57 »
Yeah I know that the 32/64 bit issue for the buildlibs was going to become a problem at some point. Looks like Xcode10 is the first to enforce 64-bit only. Glad you got it figured out.

3
Engine Development / Re: AGS engine Mac OS X port
« on: 30 Nov 2018, 04:45 »
Just to confirm - today I successfully compiled the buildlibs from the latest osx-nick branch without problems. Are you running Xcode 10? I suspect it's a clang10 issue.

I'm running 10.13.5 and compiling with clang9 on Xcode 9.3 without problems.

4
Engine Development / Re: AGS engine Mac OS X port
« on: 25 Jan 2018, 22:44 »
Quick update: I have AGS 3.4.1.11 working successfully. I had to modify a few of Edmundo's steps to get it working on my machine. There are many issues with getting it working, thankfully there are workarounds.

5
Engine Development / Re: AGS engine Mac OS X port
« on: 02 Jan 2018, 22:35 »
Gah, sorry. Back at my workstation now.

To clarify, I meant that I needed to build the libraries properly in the /buildlibs folder, and I had to do it from within the Terminal.
In the osx-nick branch, the /ags/OSX/buildlibs folder has a README.md file that details how to build the libraries from scratch:
1. install homebrew
2. brew install pkg-config autoconf automake libtool cmake curl
3. install xcode *and* the command line tools
4. sudo xcode-select --reset
5. build the libraries with: make install

I initially missed those steps the first time I checked out the osx-nick branch and could not build.. hence why I meant 'using Terminal properly' ;)

6
Engine Development / Re: AGS engine Mac OS X port
« on: 02 Jan 2018, 02:38 »
@Radiant: I'm away from my workstation right now, but have you tried to build Janet's 'osx-nick' branch? It built fine for me on Sierra with the latest Xcode. The trick for me was building the libraries using Terminal properly. If you can get it to build, it might help narrow down your header/search path issues.

7
Engine Development / Re: AGS engine Mac OS X port
« on: 04 Dec 2017, 14:55 »
Thanks so much for the build instructions - I'm going to try these out today and see how far I get. The Xcode branch has always been extremely fragile and difficult to patch/build plugins for - I'll let you know what my results are.

Update: Ah, I had forgotten to 'make install' the buildlib folder. Again, I'm using the osx-nick branch, so 99% of the work was already done for me.

8
Engine Development / Re: AGS engine Mac OS X port
« on: 02 Dec 2017, 20:47 »
Edmundito,

Did you have any luck building a Mac port? Which version of Xcode are you using?

I'm running 9.1 and it's complaining about a lot of missing frameworks (CoreVideo, Cocoa, etc) from the osx-nick branch. Could use some help getting this off the ground.

Thanks!

9
Engine Development / Re: AGS engine iOS port
« on: 09 Dec 2014, 17:15 »
Sorry for the delay everyone. I realized that I need to make some changes to the port to make it useful for general use.

10
Engine Development / Re: AGS engine iOS port
« on: 21 Nov 2014, 20:58 »
which do you need - the xcode project or a pre-compiled IPA?

11
Engine Development / Re: AGS engine iOS port
« on: 19 Nov 2014, 20:53 »
i've got a working build of AGS 3.3.0 using patches written by JanetC and JJS if anyone needs it. not sure if people are looking for the ipa or the xcode project though. let me know.

Pages: [1]