AGS Editor

Further development of AGS Editor

Bug Issue: Inappropriate default value limitation

Pages: [1]

Crimson Wizard

  • AGSer
  • Posts: 8,525
« on: 19 Aug 2015, 20:46 »
The function default values are being explicitly limited to range -32000 to 32000.
Note: compiler stores default values in a signed int.

Proposed solution: make sure there are no intermediate shorts used anywhere in the code to pass this value, and change the limits to INT_MIN to INT_MAX.
« Last Edit: 20 Aug 2015, 01:45 by Crimson Wizard »

sonneveld

  • AGSer
  • Posts: 72
« Reply #1 on: 05 Sep 2015, 07:41 »
« Last Edit: 09 Sep 2015, 00:27 by sonneveld »

Issue updated by Crimson Wizard
« Reply #2 on: 19 Aug 2015, 20:47 »
  • Status changed from New to Confirmed

Issue updated by Crimson Wizard
« Reply #3 on: 20 Aug 2015, 09:35 »
  • Category changed from Scripts to Script Compiler

Issue updated by Crimson Wizard
« Reply #4 on: 22 Mar 2016, 12:39 »
  • Status changed from Confirmed to Resolved

Issue updated by Crimson Wizard
« Reply #5 on: 21 Jan 2018, 07:23 »
  • Status changed from Resolved to Closed

Pages: [1]

Issue Details

  • Reported
    19 Aug 2015, 20:46
  • Updated
    21 Jan 2018, 07:23
  • View Status
    Public
  • Type
    Bug
  • Status
    Closed
  • Priority
    Normal
  • Version
    AGS 3.3.5
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Script Compiler

Tags



Powered by: SMF Project Tools 0.5.4 © Niko Pahajoki 2007-2011