Author Topic: Bug reports  (Read 49555 times)

Gurok

  • Rottwheelers
  • When life hands you lemons, combine them with the mop
    • I can help with AGS tutoring
    •  
    • Best Innovation Award Winner 2016, for improving and extending the AGS scripting language
    •  
    • I can help with proof reading
    •  
    • I can help with scripting
    •  
    • Gurok worked on a game that was nominated for an AGS Award!
      Gurok worked on a game that won an AGS Award!
Re: Bug reports
« Reply #460 on: 01 Feb 2018, 03:08 »
Unticking all of the checkboxes under one of the first four headings on the game search page and performing a search gives you an SQL error:

Couldn't connect to database: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND (committeeRating >= 2) AND (isCommercial = 0) AND (dl_url_broken = 0)' at line 1

Unticking all checkboxes under two headings will give you "AND AND (committeeRating...", three, "AND AND AND..." and four, "AND AND AND AND...".

AGA

  • Adventure Game Aficionado
  • Administrator
  • Mittens Deity
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    •  
    • AGA worked on a game that was nominated for an AGS Award!
Re: Bug reports
« Reply #461 on: 01 Feb 2018, 17:51 »
Unticking all of the checkboxes under one of the first four headings on the game search page and performing a search gives you an SQL error:

Couldn't connect to database: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND (committeeRating >= 2) AND (isCommercial = 0) AND (dl_url_broken = 0)' at line 1

Unticking all checkboxes under two headings will give you "AND AND (committeeRating...", three, "AND AND AND..." and four, "AND AND AND AND...".

Interesting!  I've already completely rewritten the search page, which will be released soonish.  Thanks for the report though.

Tabata

  • mouse-fetishist & smiley-maniac
Re: Bug reports - modify your profile
« Reply #462 on: 18 Mar 2018, 14:49 »
in short: personal text, sig and all the other stuff that was saved earlier is to be seen correct when opening the site to modify your profile, just not the last saved avatar-link :sad:

a bit longer:As we already noticed for some time the forum doesn't like https format and we need to use http for avatars.
Mine had and has a http-adress but when saving a change in the profile (just the sig in my case) after the saving my avatar was gone.
It seems to me that opening the site is done without the link of the current avatar that you saved earlier and that way saving your changed sig (in my case)  I kicked out my avatar and changed to no avatar.
I needed to search for the old link to change it back and save it again but I thought it might be worth mentioning here because I haven't had such behavior some month ago.

Have a nice day

Crimson Wizard

  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
    • Crimson Wizard worked on a game that was nominated for an AGS Award!
      Crimson Wizard worked on a game that won an AGS Award!
Re: Bug reports
« Reply #463 on: 02 May 2018, 15:52 »
Not sure if intended, but youtube video embedding does not work if put in spoiler, e.g. compare: