Author Topic: AGS 3.4.1 - Beta 4 -- new unstable version  (Read 1605 times)  Share 

Crimson Wizard

  • Local Moderator
  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
Re: AGS 3.4.1 - Beta 3 -- new unstable version
« Reply #20 on: 19 May 2017, 19:33 »
I've met a curious bug in 3.4.0 today, which is not happening in 3.4.1. I've never heard about such problem before; either it is too rare, or nobody reported.

The situation was that there is a room with a wall, which is also walkbehind, and there is a painting on that wall, which is an object with baseline = walkbehind's baseline + 1.
This painting is visible all time, because its baseline is higher than the one of the wall's, but when certain other unrelated object gets its visibility changed the painting suddenly drops through the walkbehind and appears behind it (although baseline is supposed to stay the same, it is never changed in scripts).

Setting baseline to (walkbehind's baseline + 5) fixed this, but why was it happening at first place? I was breaking my head, until I checked same game with 3.4.1 and the bug was not recurring there.

Then I remembered that for 3.4.1 I changed the code that was sorting room elements by their Z order, from C-style sorting (using qsort) to C++ STL sorting (using std::sort). Can that be that some ancient bug was fixed along this change?
« Last Edit: 19 May 2017, 19:35 by Crimson Wizard »

Crimson Wizard

  • Local Moderator
  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #21 on: 22 May 2017, 15:27 »
AGS 3.4.1 Beta 4
http://www.adventuregamestudio.co.uk/releases/betas/AGS-3.4.1-Beta4/AGS-3.4.1-beta-4.zip
(also updated first post)

Changes since Beta 3:

Common features:
 - Removed limit on the script names of Inventory Items, GUI and GUI Controls, as well as GUI event function names.

BTW, something I forgot to mention prior, Dialog script names are also not limited to like 20 letters since previous Beta.

Editor:
 - Made Editor correctly detect modern versions of MS Windows for display on About dialog and when sending anonymous statistics.
 - New application icon to comply with 3.4.0 splash screen.
 - Fixed #ifver and #ifnver not working properly if version number had only one component (major version).

Script API:
 - DynamicSprite.CreateFromFile and SaveToFile now support path tokens and comply to the new file path rules (no writing files to the game's installation directory).

Engine
 - Added OpenGL renderer to Windows version.
 - Implemented separate config option for game's shared data path, to keep it distinct from user-defined saves path. (You can set it up separately in the Default Setup page in your game project)
 - Fixed Game.TranslationFilename returning "default" instead of empty string if no translation is set.
 - Support Right Alt for Alt+Enter (switch fullscreen/windowed) and  Alt+Ctrl (lock/unlock mouse in window) combinations.
 - Fixed screen not getting repainted in software (DirectDraw 5) mode when switching from fullscreen to windowed (or vice versa).
 - Fixed FLIC playback. (Was broken after update to Allegro 4.4)

WinSetup:
 - Fixed display mode selection was missing certain items.
« Last Edit: 22 May 2017, 15:35 by Crimson Wizard »

NicolaGs

  • Going nowhere fast
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #22 on: 22 May 2017, 17:00 »
I tested the resolution fix in WinSetup... and it seems OK ! Thanks...

But I noticed another problem... To be able to test the previous issue, I had to fix errors in my script (e.g : change "default" to "" for Game.TranslationFilename).
But to detect them, I had to use the latest stable Editor version with the latest beta ACWin.exe...

If using editor + acwin 3.4.1.4 : I only get a generic error message, without the error line number (the error says about this : object reference not defined by an object instance).
If using editor 3.4.0.16 + acwin 3.4.1.4 : I get a more detailed error message, with the error line number (the error says : null pointer referenced).

So, the 3.4.1.4 Editor is less verbose and it's very difficult to find the error source...



Crimson Wizard

  • Local Moderator
  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #23 on: 22 May 2017, 17:35 »
If using editor + acwin 3.4.1.4 : I only get a generic error message, without the error line number (the error says about this : object reference not defined by an object instance).
If using editor 3.4.0.16 + acwin 3.4.1.4 : I get a more detailed error message, with the error line number (the error says : null pointer referenced).

Do you mean compilation errors or runtime errors you get during debugging?
Can you give an example of script line that you were dealing with?

NicolaGs

  • Going nowhere fast
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #24 on: 22 May 2017, 18:37 »
Do you mean compilation errors or runtime errors you get during debugging?
Can you give an example of script line that you were dealing with?

I'm embarassed because I can't find the source of the error message I get in the beta version.
The 3.4.0.16 editor gives me errors... but I don't know for sure if it's the same errors the errors that cause the beta not to run the game...

In order to troubleshoot this, I can't do better than proceeding chronologically. So it will be a long post, sorry :-D

1) my project runs fine with version 3.4.0.16
2) I tried 3.4.1.4 editor : compiling and running both failed, with getting a "generic" error message, without any more informations.
3) I tried 3.4.0.16 editor alongside acwin 3.4.1.4 : compiling and running work ; I got a "documented" error only when the faulty line was reached (null pointer referenced, with line number).
My code was :
Global script :
Code: Adventure Game Studio
  1. GUI *gStart_Screen;
  2. export gStart_Screen;
  3. ...
  4. function game_start()
  5. {
  6.         if (Game.TranslationFilename == "default")
  7.         {
  8.                 gStart_Screen = gStart_Screen_FR;
  9.         }
  10. }

Room script :
Code: Adventure Game Studio
  1. function room_Load()
  2. {
  3.         gStart_Screen.Visible = true;
  4.         acMusic_start = aMenu.Play();
  5. }
The error pointed to line 3 : gStart_Screen.Visible = true; of course, since Game.TranslationFilename == "default" was impossible. Error fixed.

4) Still with 3.4.0.16 editor + 3.4.1.4 acwin, the game compiles and F5 runs OK... and then, a new error ("Null pointer referenced"). Here is the code:

This is the first room (welcome screen):
Code: Adventure Game Studio
  1. AudioChannel *acMusic_start;
  2.  
  3.  
  4. function room_Load()
  5. {
  6.         gStart_Screen.Visible = true;
  7.         acMusic_start = aMenu.Play();
  8. }
  9.  
  10.  
  11. function room_Leave()
  12. {
  13.         FadeOut(3);
  14.        
  15.         int Volume_fading_speed = 1;
  16.        
  17.         while (acMusic_start.Volume > 0) <- THIS LINE CAUSES THE ERROR
  18.         {
  19.                 if (acMusic_start.Volume - Volume_fading_speed >= 0  )
  20.                 {
  21.                         acMusic_start.Volume = acMusic_start.Volume - Volume_fading_speed;
  22.                 }
  23.                 else
  24.                 {
  25.                         acMusic_start.Volume = 0;
  26.                 }
  27.                 Wait(1);
  28.         }
  29.         if (acMusic_start.IsPlaying != true)
  30.         {
  31.                 acMusic_start.Stop();
  32.         }
  33.        
  34.  
  35.         gStart_Screen.Visible = false;
  36. }
The error is at line 17.


At this point, I'm lost:  the compiled game (step 4) runs fine (the affected script creates a music fade out) while when run inside the editor with F5, it causes the error...


5) Trying 3.4.1.4 editor and acwin : game does not compile, does not run / generic error message



To know more about the error with the beta version, I must fix this new error but I do not find its cause (since acMusic_start was defined at the top of the script and did not cause any problem prior in the script - but there are many chances the error is my fault).


Crimson Wizard

  • Local Moderator
  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #25 on: 22 May 2017, 18:47 »
One thing I can tell at this point, you cannot use 3.4.1 acwin.exe with 3.4.0 Editor, because 3.4.1 engine cannot find audio files in debug mode without additional parameters passed from 3.4.1 Editor. This was probably the reason you were getting null pointer errors with acMusic_start, since no music played and channel pointer remained unassigned.

5) Trying 3.4.1.4 editor and acwin : game does not compile, does not run / generic error message

What is this "generic error message"?
« Last Edit: 22 May 2017, 18:49 by Crimson Wizard »

NicolaGs

  • Going nowhere fast
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #26 on: 22 May 2017, 20:20 »
the error says about this : object reference not defined by an object instance
The message appears in french (OS language...). It's a rough translation... (tbh, the sentence in french is not entirely intellegible...)

Quote from: Crimson Wizard
This was probably the reason you were getting null pointer errors with acMusic_start
So, for the moment, I'm stuck, as I cannot know the origin of the error...
« Last Edit: 22 May 2017, 20:47 by NicolaGs »

Crimson Wizard

  • Local Moderator
  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #27 on: 22 May 2017, 20:57 »
There is too little information. Can you just copy whole error message, or post screenshot whatever is easier for you?

NicolaGs

  • Going nowhere fast
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #28 on: 22 May 2017, 22:19 »
There is too little information
Yes, I know... that's the problem : I don't know where to start !
Here's a screen cap (be prepared to be disappointed) :



I've got nothing more than that. When I hit F5, when I "Build EXE", when I "Rebuild all files"...
By double clicking on the error in the message list, it doesn't do anything.


I re-tested beta 3 :
- this behaviour does not happens.
- There is still the issue with the "acMusic_start"... But : when I first "Rebuild all files", it works fine...

edit : I'll try to investigate further by disabling this audiochanel reference when I'll have time... It's very possible there's a flaw in my script.
edit 2 : I deleted all reference to audiochanel. It's the same.
edit 3 : My translation of the message may be wrong. I try again : "The object reference is not defined/referenced for one object". I'll search all those references...
« Last Edit: 22 May 2017, 22:33 by NicolaGs »

Crimson Wizard

  • Local Moderator
  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #29 on: 22 May 2017, 22:38 »
This is not script error, this is program error, which occurs during creation of game files. Therefore there is no line number.
This kinds of errors are not very informative in AGS Editor.

Is it possible for you to send me the failing game project? That would be fastest way to find out what's wrong.
Alternatively, I will change the way such error messages are printed to see more details.
« Last Edit: 22 May 2017, 22:41 by Crimson Wizard »

Crimson Wizard

  • Local Moderator
  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #30 on: 22 May 2017, 23:33 »
I fixed couple of errors, please try this build:
http://www.mediafire.com/file/b64dl48vvvqk3kl/AGSEditor_3.4.1.4--fix.zip

E: Reuploaded beta version.
« Last Edit: 23 May 2017, 00:08 by Crimson Wizard »

NicolaGs

  • Going nowhere fast
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #31 on: 22 May 2017, 23:42 »
Yes, it works, now !

On my way, I just saw another thing (why would I stop to bug you... ? (laugh)) : alt-enter sometimes restart the game (like F9 does) instead of switching between fullscreen / windowed modes.

Crimson Wizard

  • Local Moderator
  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #32 on: 22 May 2017, 23:50 »
On my way, I just saw another thing (why would I stop to bug you... ? (laugh)) : alt-enter sometimes restart the game (like F9 does) instead of switching between fullscreen / windowed modes.

LeftAlt + Enter gives same key code as F9. I thought I made it not go into scripts, but probably it still does.

Problem is that I cannot reproduce this anymore.
« Last Edit: 22 May 2017, 23:58 by Crimson Wizard »

Mehrdad

    • I can help with animation
    •  
    • I can help with characters
    •  
    • I can help with story design
    •  
    • I can help with web design
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #33 on: 23 May 2017, 15:45 »
Hi CW . I can't open my game :


My official website and 2D artworks 

Mehrdad

    • I can help with animation
    •  
    • I can help with characters
    •  
    • I can help with story design
    •  
    • I can help with web design
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #34 on: 25 May 2017, 12:20 »
Anyone have this error too? Is it possibleI fix it ?
My official website and 2D artworks 

Crimson Wizard

  • Local Moderator
  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #35 on: 25 May 2017, 16:02 »
This error happens when compiling the speech file. I usually test with games without speech, so I could miss it.

I will test this today, but if I won't be able to reproduce the error, then there are two options left:

1) Option 1. If you send me your FULL project, then I will be able to catch the error under debugger. This is ideal for me, but if I remember right you do not like to upload big data because your internet connection is not good enough?
2) Option 2. I can make editor to write a log of its progress during speech.vox compilation, and see at which point it breaks. Maybe that will give some hint.

Mehrdad

    • I can help with animation
    •  
    • I can help with characters
    •  
    • I can help with story design
    •  
    • I can help with web design
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #36 on: 25 May 2017, 16:12 »
Hi CW

Problem solved . I had a .wav speech in Speech folder that I didn't used into the game . I removed it and works fine.  Thanks a lot  ;)
My official website and 2D artworks 

Crimson Wizard

  • Local Moderator
  • AGS Project Tracker Admins
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    •  
    • Lifetime Achievement Award Winner
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #37 on: 25 May 2017, 16:43 »
Problem solved . I had a .wav speech in Speech folder that I didn't used into the game . I removed it and works fine.  Thanks a lot  ;)

Wait! It is not solved!
There is clearly and error inside the Editor, and I need to find out what it is. What if it happens again to someone else?!
Can you send me that wav file just in case? How was it named at least?

arj0n

  • Mittens Vassal
  • why do meteors always land in craters?
  • arj0n worked on a game that was nominated for an AGS Award!
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #38 on: 25 May 2017, 20:08 »
The generated acsetup.cfg in Compiled>Windows contains wrong/old content, for example the driver is set to DX5.

Reproduction scenario:
Open the project with AGS Build 3.4.0.16:
In General settings set Default graphics driver to DirectDraw 5 (default)
Save game and close editor

Backup the project
Delete folder 'Compiled'
Delete any content of the savefolder in C:\Users\<user>\Saved Games\)

Open the project with AGS Build 3.4.1.4 ** BETA VERSION **
in Default setup set Graphics driver to 'Software driver'
Save and compile game

* The file acsetup.cfg in Compiled>Windows (and Compiled>Data) shows 'driver = DX5' (this is incorrect, DX5 is not an option)
* When running winsetup.exe, the selected Driver is 'Direct3D 9'

Change Driver to OpenGL and save
* The file acsetup.cfg in the savefolder shows 'driver = OpenGL' (correct)

So the editor creates the 'old' acsetup.cfg, but the winsetup creates the correct cfg.

Content of generated acsetup.cfg in compiled/windows folder:
Code: Adventure Game Studio
  1. [sound]
  2. digiid=-1
  3. midiid=-1
  4. digiwin=-1
  5. midiwin=-1
  6. digiindx=0
  7. midiindx=0
  8. digiwinindx=0
  9. midiwinindx=0
  10. [misc]
  11. game_width=320
  12. game_height=200
  13. gamecolordepth=16
  14. antialias=0
  15. notruecolor=0
  16. cachemax=128
  17. user_data_dir=
  18. shared_data_dir=
  19. titletext=SRAM 2 - CINOMEH'S REVENGE (demo) Setup
  20. [graphics]
  21. driver=DX5
  22. windowed=0
  23. game_scale=max_round
  24. filter=stdscale
  25. vsync=0
  26. render_at_screenres=0
  27. [language]
  28. translation=
  29. [mouse]
  30. auto_lock=0
  31. speed=1
  32.  

Content of acsetup.cfg in savegame folder after saving via winsetup.exe:
Code: Adventure Game Studio
  1. [graphics]
  2. driver=OGL
  3. filter=StdScale
  4. game_scale=max_round
  5. refresh=0
  6. render_at_screenres=0
  7. screen_def=explicit
  8. screen_height=1080
  9. screen_width=1920
  10. vsync=0
  11. windowed=0
  12. [language]
  13. translation=
  14. [misc]
  15. antialias=0
  16. cachemax=131072
  17. notruecolor=0
  18. user_data_dir=
  19. [mouse]
  20. auto_lock=0
  21. speed=1.0
  22. [sound]
  23. digiwinindx=0
  24. midiwinindx=0
  25. usespeech=1
  26.  

Mehrdad

    • I can help with animation
    •  
    • I can help with characters
    •  
    • I can help with story design
    •  
    • I can help with web design
    •  
Re: AGS 3.4.1 - Beta 4 -- new unstable version
« Reply #39 on: 26 May 2017, 12:55 »
Wait! It is not solved!
There is clearly and error inside the Editor, and I need to find out what it is. What if it happens again to someone else?!
Can you send me that wav file just in case? How was it named at least?

Sorry I'm late for answer
OK. Name of sound is 'EGO1.wav'  . It was in Speech folder . When I put it again I have same error and when I remove it works fine . My code is:

Code: Adventure Game Studio
  1. cEgo.Say("&1 nd,hv");  // I use Persian font

Where is my wrong?

My official website and 2D artworks