1213 by Yahtzee - Stuck on episode 2 due to a bug?

Started by DrMaxKurt, Fri 07/05/2021 16:02:04

Previous topic - Next topic



I've played many AGS games over the years.
However I'v never used the engine myself, though I have created an adventure game using different tools.

Recently, a bit of nostalgia made me want to play again to 1213,
Ben "Yahtzee" Croshaw 3-episodes AGS game from 2005, inspired by Prince of Persia & Flashback:

I had really nice memories from playing it, and I really enjoyed playing episode 1 again!
(the download link for this episode is broken, but I found it on another website).

Sadly, while playing episode 2, I got stuck.
I checked a game walkthrough on IGN
and realized that the game was not behaving as it should.

Hence I'm posting here, looking for some help to beat 1213 episode 2.
Through cunning, reverse engineering, or any other way!

The potential bug
Quickly at the start of the episode, we can reach a lower level with a terminal that can be activated,
seemingly just "switching" some green light on:

From the walkthrough I learned that this switch should open the level 7 elevator doors,
so that 1213 (the main character) can reach this level.

The following screenshot show the screen just right of the previous image.
We can see that the elevators doors are open.

Now, to get to the elevator conduit, the player has to progress on a few more screens.
After entering the elevator conduit (by pressing the UP key in the corridor), this is the screen that I see:

Hence my suspicion for a bug.

What I tried so far

Retrieving the AGS version used to build the game

Being a programmer myself (❤️ open-source),
I downloaded AGS source code from GitHub, and compiled it on a (screen-less) Linux environment.

Using some CLI parameters, I was able to extract some information from the game:

Code: ags
./ags --log-stdout=all:debug --tell 1213_ep2.exe

Resulting in this: ags.log

Seems like the game was compiled with AGS v2.62

Launching the game with the latest AGS version

I also tried to launch the game with AGS v3.5.0.31-P9 Windows binaries:

Code: ags
acwin.exe 1213_ep2.exe

But the game did not start, and I just got this error:

Launching the game with AGS v2.7.2

Code: ags
acwin.exe 1213_ep2.exe

The error is a bit different this time:

This is strange because I used the same "acsetup.cfg", and "1213_ep2.exe" launches fine when run it directly...

What next?

QuoteAGS Community, you are my only hope!

I'm a bit out of ideas right now...

Even if I manage to launch the game using an old version of AGS 2,
how could I debug this strange bug?

Would you have any idea on what could be causing it?

Do you see another way to beat the game?

Any suggestion is welcome!  :smiley:



ScummVM recently added AGS compatibility, for now it's not much different from the compatibility of AGS itself but they seem focused on getting really old games running, so maybe try to use it and see what happens.

Crimson Wizard

AGS 3.5.* still supposed to be backward compatible, so this "memory" bug should be fixed if possible. I may look into this soon if I have the time.

EDIT: I tried using both 3.5.0 and 3.5.1 Beta engines, and the game starts well with both..... To clarify, you get this error exactly at launching the game, or sometime later? Do you run on Windows natively or using a Wine?
Have you tried running the game using Linux port that you've built?

ScummVM AGS port shares much of our codebase, which means there's a high chance same bug(s) will reproduce. So far we were sharing fixes for old games though, so a fix may go into both programs.

AGS 2.72 fails simply because it uses old renderers that may be no longer compatible with contemporary systems. Maybe it reinterprets config differently, or there were some changes to graphic modes, cannot tell.
Perhaps you could double check that you run it in the windowed mode? Sometimes it can run while fullscreen fails.
Note that you can run "acwin.exe <gamename> --setup" to launch its winsetup and configure correctly (same for the latest engine).

I cannot speak for the game bug itself, it's been years since I played the game. But I definitely completed all 3 episodes.

PS. There's something wrong in how you post the links, I had to fix them removing double quotes and adding ":" after "http"


Ah, @DrMaxKurt, if you are running the Linux engine just for the command line, on Windows command prompt, you can get (I think since 3.5.1) the command line output if you use --console-attach

Code: cmd
acwin.exe --console-attach --help

Crimson Wizard

Hm, if that were the problem one could also do

Code: ags
acwin.exe > 1.log

routing output to the file

Above should work in any AGS 3.*, I think.


Hi, DrMaxKurt.

It looks from your screenshot inside the elevator shaft that there may be two passages open to the left. The numbers are somewhat counter-intuitive, as 7 is the one below 6 (where you emerge, if I remember correctly). You can access these by jumping and/or climbing. The one on the top is for later in the game.

The other thing I did, was that I did not use the terminal in the bottom right corner of your first screenshot (under the sign saying "Platform Control"). If you use this, there is an animation like opening the door into the next room, but you can walk there without using this terminal, so this part probably isn't working as intended. If there is a bug, I'm pretty sure that's where it's at, as I can progress further into the game, accessing those other floor levels. Hope this helps.

EDIT: In case I'm not making myself clear: You can stop the bug hunting. The game is playable through to the end.


Ahaha, yessss!
I'm stuck no more!

Thank you heltonjon!
I was indeed quite dumb, and expected the doors visible at the bottom of the elevator to open,
whereas I just had to exit on the left...

Thanks also to you eri0o and Crimson Wizard for your kind help and suggestions.

SMF spam blocked by CleanTalk