Adventure Game Studio | Forums

AGS Support => Beginners' Technical Questions => Topic started by: Mandle on 07 Nov 2021, 07:53

Title: Trying To Use AGS Latest Build On Windows 7 BUT...(SOLVED)
Post by: Mandle on 07 Nov 2021, 07:53
Sorry, but can anyone help me? I am trying to install the most recent build of AGS on a Windows 7 computer. I have installed the NET thingy but when I try to start AGS it still says

---------------------------
Error
---------------------------
An unexpected error occurred trying to start up the AGS Editor. Please consult the details below and post the error to the AGS Technical Forum.

System.IO.FileNotFoundException: Could not load file or assembly 'AGS.Native.dll' or one of its dependencies. The specified module could not be found.

File name: 'AGS.Native.dll'

   at AGS.Editor.NativeProxy..ctor()

   at AGS.Editor.NativeProxy.get_Instance()

   at AGS.Editor.ApplicationController..ctor()

   at AGS.Editor.Program.startupTimer_Tick(Object sender, EventArgs e)

   at System.Windows.Forms.Timer.OnTick(EventArgs e)

   at System.Windows.Forms.Timer.TimerNativeW indow.WndProc(Message& m)

   at System.Windows.Forms.NativeWindow.Callb ack(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)




---------------------------
OK   
---------------------------

I have been bashing my head against these problems for a few days now. I tried updating to Windows 10 and AGS worked then but many other things on the computer are unusable.

Can anyone offer any advice?
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Crimson Wizard on 07 Nov 2021, 10:16
Please clarify what is the build version exactly are you trying to install ("most recent" could be 3.5.1, or 3.6.0).

AGS.Native.dll requires VC Redistributable 2015 (https://download.microsoft.com/download/6/A/A/6AA4EDFF-645B-48C5-81CC-ED5963AEAD48/vc_redist.x86.exe).
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Mandle on 07 Nov 2021, 13:14
I have tried with both versions and still get the same error message when I try to launch AGS.

I have the VC Redistributable 2015 thingy installed as far as I know...

Wow, I am really bad at this stuff... been trying for two days to get AGS just to open on this computer on a Windows 7 system.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Crimson Wizard on 07 Nov 2021, 13:17
The only other thing that comes to mind is that some protection software prevents ags from launching, like antivirus or windows defender. If you're using one, perhaps try to add AGS into exceptions.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Danvzare on 07 Nov 2021, 13:37
The only other thing that comes to mind is that some protection software prevents ags from launching, like antivirus or windows defender. If you're using one, perhaps try to add AGS into exceptions.
To add to this, there's the chance that your Antivirus has quarantined "AGS.Native.dll", so maybe check for that in your quarantined or removed lists, just in case.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Mandle on 07 Nov 2021, 13:55
The only other thing that comes to mind is that some protection software prevents ags from launching, like antivirus or windows defender. If you're using one, perhaps try to add AGS into exceptions.
To add to this, there's the chance that your Antivirus has quarantined "AGS.Native.dll", so maybe check for that in your quarantined or removed lists, just in case.

Cheers, Crimson Wizard and Danvzare...

Now where do I check such lists?

I'm really bad at computers.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: arj0n on 07 Nov 2021, 18:06
Open your antivirus software and add the folder where AGS is installed as an exclusion.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: vga256 on 08 Nov 2021, 16:17
Edit:
I remember running into this problem a few months ago on a new install of Windows 7. It is very possible you have the incorrect version of MSVC redistributable installed for Win7. Download this zip file (https://www.majorgeeks.com/mg/getmirror/microsoft_visual_c_2010_redistributable,1.html), unpack it, and install vcredist_x86.exe.

If that fails... you can check if AGS has been quarantined here:
If you use Windows Defender (built into Win7)...

Start -> Type "defender" into the search box.
Click on "Windows Defender" in the search results.
The Windows Defender window will open up. At the top click "Tools".
A new window will open. Click on the "Quarantined Items" link.
If something with AGS in the name is in that list, click on it, click "View" and then "Restore" to remove the program from Quarantine.

Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Mandle on 09 Nov 2021, 04:55
I tried the download but no difference. Same error message on launch.

Then I tried adjusting Defender as you described but the Tools option is greyed out and it says I need to update, but when I try to do that the update ends with an error.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Khris on 09 Nov 2021, 09:02
I have a pretty fresh Win7 VM and gave this a try using the 3.5.1 patch 4 zip archive; I could reproduce the error, then installed the redistributable linked to by CW and AGS would run fine afterwards.
Defender isn't active though; I'm using the free Kaspersky AV.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Mandle on 09 Nov 2021, 09:06
I have a pretty fresh Win7 VM and gave this a try using the 3.5.1 patch 4 zip archive; I could reproduce the error, then installed the redistributable linked to by CW and AGS would run fine afterwards.
Defender isn't active though; I'm using the free Kaspersky AV.

Thanks Khris for pointing me back to a link I overlooked.

I tried installing that and got the following error report, which is way beyond me, but which I will paste below:

Spoiler: ShowHide
[0900:16B0][2021-11-09T18:03:17]i001: Burn v3.7.3813.0, Windows v6.1 (Build 7600: Service Pack 0), path: C:\Users\ross\Downloads\vc_redist.x86(2).exe, cmdline: ''
[0900:16B0][2021-11-09T18:03:17]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\ross\AppData\Local\Temp\dd_vcredist_x86_20211109180317.log'
[0900:16B0][2021-11-09T18:03:17]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\ross\Downloads\vc_redist.x86(2).exe'
[0900:16B0][2021-11-09T18:03:17]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'C:\Users\ross\Downloads\'
[0900:16B0][2021-11-09T18:03:18]i100: Detect begin, 10 packages
[0900:16B0][2021-11-09T18:03:18]i000: File search: windows_uCRT_DetectKey, did not find path: C:\Windows\system32\ucrtbase.dll
[0900:16B0][2021-11-09T18:03:18]i000: File search: windows_uCRT_DetectKeyExists, did not find path: C:\Windows\system32\ucrtbase.dll
[0900:16B0][2021-11-09T18:03:18]i000: Setting numeric variable 'windows_uCRT_DetectKeyExists' to value 0
[0900:16B0][2021-11-09T18:03:18]i052: Condition '(VersionNT = v6.3 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0900:16B0][2021-11-09T18:03:18]i052: Condition '(VersionNT = v6.3 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0900:16B0][2021-11-09T18:03:18]i052: Condition '(VersionNT = v6.2 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0900:16B0][2021-11-09T18:03:18]i052: Condition '(VersionNT = v6.2 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0900:16B0][2021-11-09T18:03:18]i052: Condition '(VersionNT = v6.1 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0900:16B0][2021-11-09T18:03:18]i052: Condition '(VersionNT = v6.1 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0900:16B0][2021-11-09T18:03:18]i052: Condition '(VersionNT = v6.0 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0900:16B0][2021-11-09T18:03:18]i052: Condition '(VersionNT = v6.0 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0900:16B0][2021-11-09T18:03:18]i101: Detected package: vcRuntimeMinimum_x86, state: Present, cached: Complete
[0900:16B0][2021-11-09T18:03:18]i101: Detected package: vcRuntimeAdditional_x86, state: Present, cached: Complete
[0900:16B0][2021-11-09T18:03:18]i101: Detected package: Windows81_x86, state: Absent, cached: None
[0900:16B0][2021-11-09T18:03:18]i101: Detected package: Windows81_x64, state: Absent, cached: None
[0900:16B0][2021-11-09T18:03:18]i101: Detected package: Windows8_x86, state: Absent, cached: None
[0900:16B0][2021-11-09T18:03:18]i101: Detected package: Windows8_x64, state: Absent, cached: None
[0900:16B0][2021-11-09T18:03:18]i101: Detected package: Windows7_MSU_x86, state: Absent, cached: None
[0900:16B0][2021-11-09T18:03:18]i101: Detected package: Windows7_MSU_x64, state: Absent, cached: Complete
[0900:16B0][2021-11-09T18:03:18]i101: Detected package: WindowsVista_MSU_x86, state: Absent, cached: None
[0900:16B0][2021-11-09T18:03:18]i101: Detected package: WindowsVista_MSU_x64, state: Absent, cached: None
[0900:16B0][2021-11-09T18:03:18]i052: Condition 'VersionNT >= v6.0 OR (VersionNT = v5.1 AND ServicePackLevel >= 2) OR (VersionNT = v5.2 AND ServicePackLevel >= 1)' evaluates to true.
[0900:16B0][2021-11-09T18:03:18]i199: Detect complete, result: 0x0
[0900:16B0][2021-11-09T18:03:22]i200: Plan begin, 10 packages, action: Repair
[0900:16B0][2021-11-09T18:03:22]i000: Setting string variable 'WixBundleLog_vcRuntimeMinimum_x86' to value 'C:\Users\ross\AppData\Local\Temp\dd_vcredist_x86_20211109180317_000_vcRuntimeMinimum_x86.log'
[0900:16B0][2021-11-09T18:03:22]i000: Setting string variable 'WixBundleLog_vcRuntimeAdditional_x86' to value 'C:\Users\ross\AppData\Local\Temp\dd_vcredist_x86_20211109180317_001_vcRuntimeAdditional_x86.log'
[0900:16B0][2021-11-09T18:03:22]i052: Condition 'VersionNT = v6.3 AND NOT VersionNT64' evaluates to false.
[0900:16B0][2021-11-09T18:03:22]w321: Skipping dependency registration on package with no dependency providers: Windows81_x86
[0900:16B0][2021-11-09T18:03:22]i052: Condition 'VersionNT = v6.3 AND VersionNT64' evaluates to false.
[0900:16B0][2021-11-09T18:03:22]w321: Skipping dependency registration on package with no dependency providers: Windows81_x64
[0900:16B0][2021-11-09T18:03:22]i052: Condition 'VersionNT = v6.2 AND NOT VersionNT64' evaluates to false.
[0900:16B0][2021-11-09T18:03:22]w321: Skipping dependency registration on package with no dependency providers: Windows8_x86
[0900:16B0][2021-11-09T18:03:22]i052: Condition 'VersionNT = v6.2 AND VersionNT64' evaluates to false.
[0900:16B0][2021-11-09T18:03:22]w321: Skipping dependency registration on package with no dependency providers: Windows8_x64
[0900:16B0][2021-11-09T18:03:22]i052: Condition 'VersionNT = v6.1 AND NOT VersionNT64' evaluates to false.
[0900:16B0][2021-11-09T18:03:22]w321: Skipping dependency registration on package with no dependency providers: Windows7_MSU_x86
[0900:16B0][2021-11-09T18:03:22]i052: Condition 'VersionNT = v6.1 AND VersionNT64' evaluates to true.
[0900:16B0][2021-11-09T18:03:22]w321: Skipping dependency registration on package with no dependency providers: Windows7_MSU_x64
[0900:16B0][2021-11-09T18:03:22]i052: Condition 'VersionNT = v6.0 AND NOT VersionNT64' evaluates to false.
[0900:16B0][2021-11-09T18:03:22]w321: Skipping dependency registration on package with no dependency providers: WindowsVista_MSU_x86
[0900:16B0][2021-11-09T18:03:22]i052: Condition 'VersionNT = v6.0 AND VersionNT64' evaluates to false.
[0900:16B0][2021-11-09T18:03:22]w321: Skipping dependency registration on package with no dependency providers: WindowsVista_MSU_x64
[0900:16B0][2021-11-09T18:03:22]i201: Planned package: vcRuntimeMinimum_x86, state: Present, default requested: Repair, ba requested: Repair, execute: Repair, rollback: None, cache: No, uncache: No, dependency: Register
[0900:16B0][2021-11-09T18:03:22]i201: Planned package: vcRuntimeAdditional_x86, state: Present, default requested: Repair, ba requested: Repair, execute: Repair, rollback: None, cache: No, uncache: No, dependency: Register
[0900:16B0][2021-11-09T18:03:22]i201: Planned package: Windows81_x86, state: Absent, default requested: Absent, ba requested: Absent, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[0900:16B0][2021-11-09T18:03:22]i201: Planned package: Windows81_x64, state: Absent, default requested: Absent, ba requested: Absent, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[0900:16B0][2021-11-09T18:03:22]i201: Planned package: Windows8_x86, state: Absent, default requested: Absent, ba requested: Absent, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[0900:16B0][2021-11-09T18:03:22]i201: Planned package: Windows8_x64, state: Absent, default requested: Absent, ba requested: Absent, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[0900:16B0][2021-11-09T18:03:22]i201: Planned package: Windows7_MSU_x86, state: Absent, default requested: Absent, ba requested: Absent, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[0900:16B0][2021-11-09T18:03:22]i201: Planned package: Windows7_MSU_x64, state: Absent, default requested: Repair, ba requested: Repair, execute: Install, rollback: Uninstall, cache: No, uncache: No, dependency: None
[0900:16B0][2021-11-09T18:03:22]i201: Planned package: WindowsVista_MSU_x86, state: Absent, default requested: Absent, ba requested: Absent, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[0900:16B0][2021-11-09T18:03:22]i201: Planned package: WindowsVista_MSU_x64, state: Absent, default requested: Absent, ba requested: Absent, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[0900:16B0][2021-11-09T18:03:22]i299: Plan complete, result: 0x0
[0900:16B0][2021-11-09T18:03:22]i300: Apply begin
[0F44:1798][2021-11-09T18:03:26]i360: Creating a system restore point.
[0F44:1798][2021-11-09T18:03:37]i361: Created a system restore point.
[0F44:1798][2021-11-09T18:03:37]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{e2803110-78b3-4664-a479-3611a381656a}, resume: Active, restart initiated: No, disable resume: No
[0F44:14F0][2021-11-09T18:03:37]i304: Verified existing payload: vcRuntimeMinimum_x86 at path: C:\ProgramData\Package Cache\{BBF2AC74-720C-3CB3-8291-5E34039232FA}v14.0.24215\packages\vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi.
[0F44:14F0][2021-11-09T18:03:37]i304: Verified existing payload: cab54A5CABBE7274D8A22EB58060AAB7623 at path: C:\ProgramData\Package Cache\{BBF2AC74-720C-3CB3-8291-5E34039232FA}v14.0.24215\packages\vcRuntimeMinimum_x86\cab1.cab.
[0F44:14F0][2021-11-09T18:03:37]i304: Verified existing payload: vcRuntimeAdditional_x86 at path: C:\ProgramData\Package Cache\{69BCE4AC-9572-3271-A2FB-9423BDA36A43}v14.0.24215\packages\vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi.
[0F44:14F0][2021-11-09T18:03:37]i304: Verified existing payload: cabB3E1576D1FEFBB979E13B1A5379E0B16 at path: C:\ProgramData\Package Cache\{69BCE4AC-9572-3271-A2FB-9423BDA36A43}v14.0.24215\packages\vcRuntimeAdditional_x86\cab1.cab.
[0F44:14F0][2021-11-09T18:03:38]i304: Verified existing payload: Windows7_MSU_x64 at path: C:\ProgramData\Package Cache\54050A5F8AE7F0C56E553F0090146C17A1D2BF8D\packages\Patch\x64\Windows6.1-KB2999226-x64.msu.
[0F44:1798][2021-11-09T18:03:38]i301: Applying execute package: vcRuntimeMinimum_x86, action: Repair, path: C:\ProgramData\Package Cache\{BBF2AC74-720C-3CB3-8291-5E34039232FA}v14.0.24215\packages\vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi, arguments: ' MSIFASTINSTALL="7" NOVSUI="1"'
[0900:16B0][2021-11-09T18:03:41]i319: Applied execute package: vcRuntimeMinimum_x86, result: 0x0, restart: None
[0F44:1798][2021-11-09T18:03:41]i325: Registering dependency: {e2803110-78b3-4664-a479-3611a381656a} on package provider: Microsoft.VS.VC_RuntimeMinimumVSU_x86,v14, package: vcRuntimeMinimum_x86
[0F44:1798][2021-11-09T18:03:41]i301: Applying execute package: vcRuntimeAdditional_x86, action: Repair, path: C:\ProgramData\Package Cache\{69BCE4AC-9572-3271-A2FB-9423BDA36A43}v14.0.24215\packages\vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi, arguments: ' MSIFASTINSTALL="7" NOVSUI="1"'
[0900:16B0][2021-11-09T18:03:43]i319: Applied execute package: vcRuntimeAdditional_x86, result: 0x0, restart: None
[0F44:1798][2021-11-09T18:03:43]i325: Registering dependency: {e2803110-78b3-4664-a479-3611a381656a} on package provider: Microsoft.VS.VC_RuntimeAdditionalVSU_x8 6,v14, package: vcRuntimeAdditional_x86
[0F44:1798][2021-11-09T18:03:43]i301: Applying execute package: Windows7_MSU_x64, action: Install, path: C:\ProgramData\Package Cache\54050A5F8AE7F0C56E553F0090146C17A1D2BF8D\packages\Patch\x64\Windows6.1-KB2999226-x64.msu, arguments: '"C:\Windows\SysNative\wusa.exe" "C:\ProgramData\Package Cache\54050A5F8AE7F0C56E553F0090146C17A1D2BF8D\packages\Patch\x64\Windows6.1-KB2999226-x64.msu" /quiet /norestart'
[0F44:1798][2021-11-09T18:03:48]e000: Error 0x80240017: Failed to execute MSU package.
[0900:16B0][2021-11-09T18:03:48]e000: Error 0x80240017: Failed to configure per-machine MSU package.
[0900:16B0][2021-11-09T18:03:48]i319: Applied execute package: Windows7_MSU_x64, result: 0x80240017, restart: None
[0900:16B0][2021-11-09T18:03:48]e000: Error 0x80240017: Failed to execute MSU package.
[0F44:1798][2021-11-09T18:03:48]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{e2803110-78b3-4664-a479-3611a381656a}, resume: ARP, restart: None, disable resume: No
[0F44:1798][2021-11-09T18:03:48]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{e2803110-78b3-4664-a479-3611a381656a}, resume: ARP, restart initiated: No, disable resume: No
[0900:16B0][2021-11-09T18:03:49]i399: Apply complete, result: 0x80240017, restart: None, ba requested restart:  No


I hope this helps me sort this issue out, and for others in the future.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Khris on 09 Nov 2021, 09:23
Did you run Windows Update yet? I have Service Pack 1, build 7601
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Mandle on 09 Nov 2021, 09:58
Did you run Windows Update yet? I have Service Pack 1, build 7601

Thanks again for your attention on my issue.

When I try to run an update I get this error:

Error: 80072EFE
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Khris on 09 Nov 2021, 13:05
I believe I had the same issue and solved it by installing a big pack of updates put together by a German support site.
You can try the update packages found here: https://www.lifewire.com/latest-windows-service-packs-updates-2624595 (the links lead to the microsoft site).
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Mandle on 09 Nov 2021, 14:56
I believe I had the same issue and solved it by installing a big pack of updates put together by a German support site.
You can try the update packages found here: https://www.lifewire.com/latest-windows-service-packs-updates-2624595 (the links lead to the microsoft site).

Currently downloading the one I think I need for 64-bit thingy for Windows 7.

Trying this link's download now and saving it here just in case it works:

https://www.catalog.update.microsoft.com/Search.aspx?q=KB3138612
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Mandle on 09 Nov 2021, 15:59
Nope, didn't work, nor did the last link that Khris provided... unless I installed the wrong patch on that site.

My startup now says "Windows 7 Ultimate", which I never noticed before, but it may have said that and I just never noticed before.

Still getting the exact same error message as posted above when trying to launch AGS 3.5.1 and AGS 3.6.0.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Mandle on 09 Nov 2021, 16:01
Defender isn't active though; I'm using the free Kaspersky AV.

I will try disabling Defender completely and try again tomorrow. This is a really frustrating problem.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: vga256 on 09 Nov 2021, 16:41
It sounds to me like you're using a fresh install of Windows 7 that is very old, and does not have a working copy of Windows Update. Windows Update must be able to run and patch your system up to a much more current version of Win7. This is not an AGS problem - it is an old/unpatched operating system issue.

If you are running a 64 bit version of Windows 7, download and install Service Pack 1 first (https://www.majorgeeks.com/files/details/windows_7_service_pack_1.html). A 32-bit version of SP1 is available here (https://m.majorgeeks.com/files/details/windows_7_sp2.html).

Once SP1 has been installed, then you can start running Windows Update to patch your OS up to the most recent version.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Khris on 09 Nov 2021, 23:59
I meant this: https://www.catalog.update.microsoft.com/Search.aspx?q=KB976932 (2nd link for 64bit Windows, 3rd for 32bit)
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...
Post by: Mandle on 10 Nov 2021, 08:24
Yeah, sorry everyone, I feel like the village idiot that just won the "Best Falling Off The Wall Backwards" prize at the yearly fair.

I clicked on the little flag telling me I needed an update on Windows and that completely cured everything.

After all the headaches trying to get Windows to update and getting error messages every time, this felt very anticlimactic and also very welcome.

Sorry for all this trouble.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...(SOLVED)
Post by: Khris on 10 Nov 2021, 09:29
But you tried to update windows before and got error 80072EFE (a very common one). As far as I can tell, if Windows 7 is too old, it will refuse to update via the built-in mechanism and you have to manually install a sufficient update first to get Windows Update to work again.
So I don't think merely clicking the flag is what completely fixed it, that's just a notification about outstanding updates but trying to install them will still fail with a fresh (and therefore severely outdated) Win7 installation.

I'm fairly certain that one of the updates you downloaded was what fixed it, since it was the exact same for me (only I used a different pack of updates).
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...(SOLVED)
Post by: Mandle on 10 Nov 2021, 11:22
But you tried to update windows before and got error 80072EFE (a very common one). As far as I can tell, if Windows 7 is too old, it will refuse to update via the built-in mechanism and you have to manually install a sufficient update first to get Windows Update to work again.
So I don't think merely clicking the flag is what completely fixed it, that's just a notification about outstanding updates but trying to install them will still fail with a fresh (and therefore severely outdated) Win7 installation.

I'm fairly certain that one of the updates you downloaded was what fixed it, since it was the exact same for me (only I used a different pack of updates).

I had tried opening AGS just before the flag notice. But it failed.

When I clicked the flag and did the update I expected it to fail as usual but it succeeded. Then AGS would open properly without the errors. All I know.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...(SOLVED)
Post by: Khris on 10 Nov 2021, 13:13
Right, but you did install some update before clicking the flag, right?

The key issue here isn't really whether AGS worked but why the update worked when it wouldn't before. If you did install SP1 that would explain it. I don't know what exactly you installed though, the one link you posted is for a very minor update and not found on the site I liked to afaik.

Anyway, I'll do a quick test now with a fresh installation and will report which update is required.
Title: Re: Trying To Use AGS Latest Build On Windows 7 BUT...(SOLVED)
Post by: vga256 on 15 Nov 2021, 19:54
Glad you figured it out.