Jibble

Author Topic: LucasArts GUI Help Thread (NEW Scumm GUI Available!)  (Read 198873 times)

Scummbuddy

  • Mittens Knight
  • Give Stylish Confetti to BoZo - Wheee!
    • I can help with AGS tutoring
    • I can help with animation
    • I can help with backgrounds
    • I can help with characters
    • I can help with proof reading
    • I can help with scripting
    • I can help with story design
    • I can help with voice acting
    • Scummbuddy worked on one or more games that won an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #60 on: 12 Feb 2004, 07:45 »
Next to File, there is Game. Use that selection, and move down to the second from the bottom.  There is the "make template" selection.
- Oh great, I'm stuck in colonial times, tentacles are taking over the world, and now the toilets backing up.
- No, I mean it's really STUCK. Like adventure-game stuck.
-Hoagie from DOTT

the_dragon

  • Guest
Re:The LucasArts GUI Help Thread
« Reply #61 on: 12 Feb 2004, 20:15 »
lol Thanks scummbuddy, I must be blind.
:D

IntentInsane

  • II Interactive
Re:The LucasArts GUI Help Thread
« Reply #62 on: 14 Feb 2004, 15:42 »
How do you make your inventory display acroos the botom?(Is this the Lucasarts style?) If you culd give me a step by step guide/faq I would much apreciate it!
Intentionally Insane!
http://www.pauladmin.tk

Kinoko

  • Cartoonist/Illustrator/Great Lover
    • Kinoko worked on one or more games that was nominated for an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #63 on: 16 Feb 2004, 15:49 »
I'm using the MI template, but I'd like to stop characters turning to face the player character when I look at them. Is this a part of the MI template or a general AGS function? If it's the template, how do I turn it off?

Thanks

Re:The LucasArts GUI Help Thread
« Reply #64 on: 16 Feb 2004, 17:36 »
in the 'GoTo' function, look for this line:
/**/  if (locationtype==2) arrived = GoToCharacter(GetCharacterAt(mouse.x,mouse.y),0,1,blocking);
and change it to
/**/  if (locationtype==2) arrived = GoToCharacter(GetCharacterAt(mouse.x,mouse.y),0,0,blocking);
and see if it works

Kinoko

  • Cartoonist/Illustrator/Great Lover
    • Kinoko worked on one or more games that was nominated for an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #65 on: 17 Feb 2004, 02:04 »
It worked, thanks dude! ^_^

monkey0506

  • SEND PIZZA.
    • Best Innovation Award Winner 2017, for his work to help AGS games reach the widest possible audience - through popular distribution platforms (Steam, Galaxy) as well as other operating systems (Android, Linux)
    • monkey0506 worked on one or more games that won an AGS Award!
    •  
    • monkey0506 worked on one or more games that was nominated for an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #66 on: 20 Feb 2004, 00:57 »
I'm new to AGS and I downloaded a Monkey Island 2 gui @ http://www.juncmodule.com/juncSource.html, and now, when I try to test my game, or save it, I get an error saying that:

There was an error compiling your script the problem was in 'Main script':

Error (line 65): Undefined token 'SetMode'


I'm new to this type of scripting, and as I didn't write any of it, I have no idea what to do.

here's lines 64 - 74, like I said, I have no clue what I'm doing, but I hope this is enough for some help...
Code: [Select]
/**/  if (interface == MAINGUI) {
    if (button == 0)  SetMode("give");
    if (button == 1)  SetMode("pick up");
    if (button == 2)  SetMode("use");
    if (button == 3)  SetMode("open");
    if (button == 4)  SetMode("look at");
    if (button == 5)  SetMode("push");
    if (button == 6)  SetMode("close");
    if (button == 7)  SetMode("talk to");
    if (button == 8)  SetMode("pull");
/**/    if ((button == 10) && (game.top_inv_item < game.num_inv_items - (game.num_inv_displayed-1)))




EDIT: I checked the site, and according to that site, the gui I'm using IS Proskrito's, however, I still have NO idea what's causing the error. I'm going through the tutorial, and playing around with AGS itself, but unless I can find a scripting tutorial, I don't think I'm going to get anywhere anytime soon...
« Last Edit: 22 Feb 2004, 05:43 by monkey_05_06 »

Re:The LucasArts GUI Help Thread
« Reply #67 on: 22 Feb 2004, 12:25 »
did you export the gui from the template and imported it into your game? or deleted something? you need the functions that come with the template for it to work.

monkey0506

  • SEND PIZZA.
    • Best Innovation Award Winner 2017, for his work to help AGS games reach the widest possible audience - through popular distribution platforms (Steam, Galaxy) as well as other operating systems (Android, Linux)
    • monkey0506 worked on one or more games that won an AGS Award!
    •  
    • monkey0506 worked on one or more games that was nominated for an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #68 on: 22 Feb 2004, 13:30 »
I did export the gui...  :-[


EDIT: Where can I download the Beta version so I can do anything? I started a new game with the template, and now when I go to test the game, it loads, but I can't walk around or anything like that because I don't have the beta version or whatever, and the Downloads page doesn't have a link for that...  >:(


EDIT: Well, I finally got a program that can open "rar" files, so I now have a copy of the template that works with my version of AGS. However, I have a problem. in my game, if I left click on "Look At" and then on a hotspot, then nothing happens, but if I right click the hotspot it completes the sequence of events. Did I mess something up, or is it the template?


EDIT: Maybe I should go back and look at the old posts. according to some of the previous posts, this is a new problem, however I'm pretty sure I have the newest version of the MI2 template, and it doesn't see to have corrected the problem...
« Last Edit: 22 Feb 2004, 20:44 by monkey_05_06 »

spud

  • I'll just reverse the polarity of the neutron flow
Re:The LucasArts GUI Help Thread
« Reply #69 on: 22 Feb 2004, 20:40 »
ive started making my game ive downloaded the monkey island 1 gui by inquisitor but and it is great but ineed help with one thing and i cant seem to find it here

in monkey island when you click on use,talk,look e.t.c the text at the top of the bar says talk to look at object or person
but on my game it just says walk to object all the time

is there a way to get it to work like the original and if there is i would be happy

p.s try and type it as simple as you can because i am still getting to grips with the lingo

cheers spud

monkey0506

  • SEND PIZZA.
    • Best Innovation Award Winner 2017, for his work to help AGS games reach the widest possible audience - through popular distribution platforms (Steam, Galaxy) as well as other operating systems (Android, Linux)
    • monkey0506 worked on one or more games that won an AGS Award!
    •  
    • monkey0506 worked on one or more games that was nominated for an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #70 on: 22 Feb 2004, 20:52 »
well, although it's not exactly complete, Proskrito's template is excellent:


http://galeon.com/golfa/otros/nuevos/MI2_template_v13.rar


That's the most recent release. there's a few errors here and there, see previous posts, but as I too am a newbie, that's the best advice I can give.  ;D

Kinoko

  • Cartoonist/Illustrator/Great Lover
    • Kinoko worked on one or more games that was nominated for an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #71 on: 24 Feb 2004, 05:13 »
I had that exact problem with the "look at" function not working when used with the left mouse button, and working but ignoring walk-to points when used with the right mouse trigger.

As soon as I got v1.3 of the template and transferred my game over, the "look" function worked fine except for a group of about 5 hotspots in one room. I don't know if that's related and absolutely noone has been able to come up with any ideas or solutions for that problem.

Right now, for seemingly no reason at all, my walk-to points have all decided to stop working completely. I also don't know if this is related to the template or not but I thought I'd just throw it out here in case someone else comes across the problem.

Re:The LucasArts GUI Help Thread
« Reply #72 on: 24 Feb 2004, 15:32 »
yes, its because the actions that are able to be cancelled with a mouse click. they dont work properly with hotspots that have a walk to point set.
Dont use them, and it should be ok, just like ags default.
kinoko, with the template, there is a doc file, read it, because i think there are answers to some of the questions you have been posting lately : ) (if you can understand my english ;) )

about the 'look at' problem, i dont know, cos several people have reported that, but it always works fine for me  ???
« Last Edit: 24 Feb 2004, 15:33 by Proskrito »

Kinoko

  • Cartoonist/Illustrator/Great Lover
    • Kinoko worked on one or more games that was nominated for an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #73 on: 25 Feb 2004, 01:21 »
I've made so many changes lately, it's hard for me to remember exactly what fixed what, but I've essentially fixed all these problems in the last couple of days.

Proskrito - I had been reading the doc file but since I could never remember every problem addressed in it, when a new problem arose, I would often think "Hmm, didn't see that in the doc" and didn't think to check.

My walk-to points had stopped being recognised because of a REALLY simple thing: I had at some point accidentally unchecked the box regarding them in the general settings tab. Easily fixed.

As I said before, the "look at" problem was fine as soon as I got the new template (so I highly reccommend it!).

The 5 or so hotspots that weren't working REALLY baffled me. I did a few tests with moving them around and taking them off one by one and, although I don't understand WHY this was a problem, I figured out what the problem was. One of my hotspots reached all the way to the top pixel of the background. It was, for some reason, stopping not only itself from working properly, but all the hotspots directly below it. All I did was keep one pixel length line free at the top of the screen and everything works like a charm. If keeping the top line of pixels free is written in the manual somewhere, I never came across it... but it completely baffled me.

The only other fundamental problem I had was the character, after being told to look at something, moving to the object's closest point on his own, and THEN moving to the hotspot. I fixed that by changing the 1 to a 0 in the line: AlwaysGoToHotspots=0;

Easy ^_^ I hope that helps anyone who comes across similar stupid problems!

monkey0506

  • SEND PIZZA.
    • Best Innovation Award Winner 2017, for his work to help AGS games reach the widest possible audience - through popular distribution platforms (Steam, Galaxy) as well as other operating systems (Android, Linux)
    • monkey0506 worked on one or more games that won an AGS Award!
    •  
    • monkey0506 worked on one or more games that was nominated for an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #74 on: 25 Feb 2004, 19:14 »
I re-downloaded it, and upon testing your rooms, it worked. I also added a room of my own, and it still worked. however, I have a question now. I connected the rooms, but when I go from one room to the other, Guybrush always starts at the same co-ordinates in EVERY room. how can I change it so I can set up the co-ordinates depending on where he came from?

EDIT: I imported a character of my own, and set him as the player character. I tested the game, and it stopped working. the lookat button not the game. I set the original character back to the player, but now it still won't work. I did this before, imported the character. Is there something wrong with my new character?
« Last Edit: 25 Feb 2004, 19:37 by monkey_05_06 »

Scummbuddy

  • Mittens Knight
  • Give Stylish Confetti to BoZo - Wheee!
    • I can help with AGS tutoring
    • I can help with animation
    • I can help with backgrounds
    • I can help with characters
    • I can help with proof reading
    • I can help with scripting
    • I can help with story design
    • I can help with voice acting
    • Scummbuddy worked on one or more games that won an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #75 on: 25 Feb 2004, 20:25 »
Use the scripting of NewRoomEx, read up on it in the helpfile/manual

but i also believe its available in just the interactions window, for you to just set up there the location of where they should enter the new room.
- Oh great, I'm stuck in colonial times, tentacles are taking over the world, and now the toilets backing up.
- No, I mean it's really STUCK. Like adventure-game stuck.
-Hoagie from DOTT

monkey0506

  • SEND PIZZA.
    • Best Innovation Award Winner 2017, for his work to help AGS games reach the widest possible audience - through popular distribution platforms (Steam, Galaxy) as well as other operating systems (Android, Linux)
    • monkey0506 worked on one or more games that won an AGS Award!
    •  
    • monkey0506 worked on one or more games that was nominated for an AGS Award!
Re:The LucasArts GUI Help Thread
« Reply #76 on: 01 Mar 2004, 02:17 »
Well, I got it figured out, but I have two problems:

1. the character doesn't walk to the hotspot before exiting the room

2. I still can't get the buttons to work with my imported character. If I download a fresh copy of the template, and use the provided character, it works, however, if I import my own character it stops working. I will try to just re-import the sprites to a new copy of the template, but I don't know if it will work...

EDIT: Just importing over the previous sprites didn't help. perhaps it's not the character's fault, and I'm doing something else wrong, however, I have no idea what...
« Last Edit: 01 Mar 2004, 02:39 by monkey_05_06 »

Cisco

  • Guest
Re:The LucasArts GUI Help Thread
« Reply #77 on: 02 Mar 2004, 23:15 »
how can i use the "give" command?
where and what, i have to write in the script for
"give the beer to Cisco" and then run a dialog or another script?

thx

Cisco

Re:The LucasArts GUI Help Thread
« Reply #78 on: 03 Mar 2004, 22:07 »
where and what, i have to write in the script for
"give the beer to Cisco" and then run a dialog or another script?
in the 'use inventory item on character' interaction, and you should check if the mode used was 'give', something like:
Code: [Select]
function character_x(){
//use inv on character
if (UsedMode("give")){//if mode was 'give'
  if (character[GetPlayerCharacter()].activeinv==X){ //if beer was used (X -> beer item number)
    LoseInventory(X); // lose the beer
    RunDialog(5);// start dialog #5
  }
}
}
« Last Edit: 03 Mar 2004, 22:08 by Proskrito »

Mr Flibble

  • In There Like SwimWear!
Re:The LucasArts GUI Help Thread
« Reply #79 on: 06 Mar 2004, 14:19 »
I've got a problem with the rooms. I know this may be a prob for the general but hear me out. ( I using P's template).

Could you tell me;
1) How to make 'open' and 'close' (a door)do just that, not change room?
I had a few goes. He just goes through anyway. I didn't even write script for it. Must be part of the template....
I have a rough idea but I'm sure there's an easier way.
Thanks.
« Last Edit: 08 Mar 2004, 18:46 by Mr Flibble »
Ah! There is no emoticon for what I'm feeling!