Author Topic: A Tale Of Two Kingdoms (Deluxe Edition)  (Read 59417 times)

Re: A Tale Of Two Kingdoms
« Reply #80 on: 25 Jul 2007, 14:27 »
if there are different endings, which one uses my animation  hehe? downloading it soon to play, been a little busy recently


  • Future Teller
Re: A Tale Of Two Kingdoms
« Reply #81 on: 25 Jul 2007, 21:23 »
Hmmm, many bugs still being reported. So in continuation with my previous post, should I stop playing and wait for a version 1.2?  cos I'm already at chapter 3 in version 1.0 and I'd hate to progress and then have to start over again for version 1.2

Re: A Tale Of Two Kingdoms
« Reply #82 on: 25 Jul 2007, 22:21 »

almost all endings have your animation.

Nostradamus, none of the bugs are show stoppers in version 1.1. I just finished the game without encountering a single bug.


  • Future Teller
Re: A Tale Of Two Kingdoms
« Reply #83 on: 26 Jul 2007, 08:55 »
Yeah but I'm in version 1.0. Can the game be finished in v1.0?
Should I wait till 1.2 (if there will be such version)?
I just don't want to progress in the game any further before I know because starting over is a bitch

Re: A Tale Of Two Kingdoms
« Reply #84 on: 26 Jul 2007, 17:26 »
Nostradamus -

Spoiler: ShowHide
You can still finish the game in 1.0 provided that you don't find out the assassin's identity.  If you do, you will later encounter a crash during a non-optional cutscene, and you won't be able to forward the plot or get the happy endings.
« Last Edit: 26 Jul 2007, 17:29 by Lyaer »


  • Future Teller
Re: A Tale Of Two Kingdoms
« Reply #85 on: 26 Jul 2007, 17:59 »
meh, but it sounds like an important part of the game that I don't wanna miss, so I'm stopping playing it for now.

Radiant, will there be a v1.2?


  • We're so far away
    • I can help with backgrounds
    • I can help with play testing
    • I can help with proof reading
    • I can help with scripting
    • I can help with translating
    • I can help with web design
Re: A Tale Of Two Kingdoms
« Reply #86 on: 26 Jul 2007, 22:25 »
Another game crash:
Spoiler: ShowHide
I was trying to talk to the unseelie and prove to him that I defeated the giant so I can get the onyx orb and right after he says "unbelievable" the game crashes and a message pops up saying:

An error has occured. Please contact the game author for support as this is likely to be a scripting error and not a bug in AGS.
(ACI Version 2.72.920

in Room 87 Script (line 308)

Error: Face character: characters are in different rooms

Re: A Tale Of Two Kingdoms
« Reply #87 on: 27 Jul 2007, 03:52 »
I dunno if this has already been reported or not, but there's a set of very severe bugs in Chapter 7 with regard to the "fox and rabbit" stuff...

Spoiler: ShowHide

The first time I encountered the fox, he killed me.  So, I decided to bypass him completely the second time around.  Instead of going south and then west from the castle, I just went south twice and then headed west.  I got the message saying "the fox is scared of the bridge and runs away" (paraphrased a lot).  This was kind of weird because there was no fox chasing me this time around, but the more serious problem was that when I clicked to get rid of the message, it just popped up again.  It kept doing that no matter what I did, so that there was no way to progress or even quit the game--I had to hit Alt-F4.  I tested this again with the same results.

Resigning myself to being chased by the fox, I went to where you meet it southwest of the castle, then went back east, then south, then west to the bridge scene.  Once again I get the message that the fox is scared of the bridge and runs away, but this time the message doesn't stay.  Whew.  I cross the bridge, go talk to Amairgen, etc. etc.

Before I had a chance to turn back into a human I had to leave, so I quit the game and forgot to save.  When I loaded it up again, I figured, no big deal, I'll just repeat what I did last time.

It doesn't work anymore.

I have no idea why.  Now, though, when I go to the bridge, the fox still runs away but it won't let me cross.  It keeps saying "For some reason you are loathe to cross the water" (paraphrased), in spite of the fact that I'm NOT trying to cross the water, I'm trying to cross the BRIDGE like I did before.  I've tried several times with the same results.

This bug has caused me so much frustration that I've basically given up.  The few other bugs were not major problems, but this one has impeded my progress completely--I cannot progress any farther with this stupid bug in the way.  Just letting you know, this needs fixing--because this is one of the best AGS games I've ever seen, and it'd be a shame to have it stay ruined by something like this.

EDIT: I've just checked the walkthru for this game and found an alternative way to escape the fox, so I was able to win the game after all.  I did discover one other story-contradiction at the end, which I thought the author should know about...

Spoiler: ShowHide

This contradiction happens if you finish the game (i.e. defeat the sorceror) but you failed to find the Princess AND you failed to discover the assassin.  Taliesin first says that the princess is dead, having been mauled by an unknown magical beast--and this confirms what Paradur has already said, so she's definitely dead.  But then when the characters talk about how the assassin is still at large, Branwyn says "So Rhiannon is now a possible target?" and Taliesin says yes, the assassin may try to kill her now.  That would be rather difficult since she's already dead, don't you think? :)

Excellent excellent game btw! Definitely needs some fixes, but I am still absolutely blown away by what you've done here--one of the best AGS games I've ever seen!  My hat off to you!
« Last Edit: 27 Jul 2007, 04:33 by Storygamer »

Re: A Tale Of Two Kingdoms
« Reply #88 on: 27 Jul 2007, 19:10 »
Yeah, I had that problem with the fox when I played through it, too.

EDIT: Was reading through the walkthrough, and I just found out that
Spoiler: ShowHide
you could go into the Tailer's shop once you've escaped from the town. I was never able to do that, as everytime I clicked on his door, I'd just walk up to it but never go in. And he was open, because this was before he runs away. Possible glitch?
« Last Edit: 27 Jul 2007, 19:17 by Balin »


Re: A Tale Of Two Kingdoms
« Reply #89 on: 28 Jul 2007, 00:12 »
I reviewed the game in the AGS Ezine.

Hope you guys like the review.

Re: A Tale Of Two Kingdoms
« Reply #90 on: 28 Jul 2007, 01:28 »
Balin--I think it is a glitch, yes, but you can circumnavigate it by
Spoiler: ShowHide
Just WALKing into the shop instead of USEing it

Radiant & others who made this game (and anyone else interested):
Just you'd like to know about it :).


  • Return once more to the Two Kingdoms!
    • I can help with publishing
    • I can help with story design
    • Radiant worked on a game that won an AGS Award!
    • Radiant worked on a game that was nominated for an AGS Award!
Re: A Tale Of Two Kingdoms
« Reply #91 on: 29 Jul 2007, 12:14 »
if there are different endings, which one uses my animation  hehe?
The two good endings.

you could go into the Tailer's shop once you've escaped from the town. I was never able to do that, as everytime I clicked on his door
Use the walk cursor. This should be fixed in v1.1.

The game can be completed in v1.0, and you can get 100% score and cutscenes in v1.1. Nevertheless I'll start working on a v1.2 now that I'm back from Mittens.

And thank you for the reviews!!
« Last Edit: 29 Jul 2007, 12:22 by Radiant »


  • Future Teller
Re: A Tale Of Two Kingdoms
« Reply #92 on: 29 Jul 2007, 15:33 »
I'm patiently waiting for v1.2.
Seems worth the wait.

Re: A Tale Of Two Kingdoms
« Reply #93 on: 29 Jul 2007, 23:52 »
Okay, now that the euphoric glow of the justifiably high initial reviews has faded, I'm going to put up my suggestion list. I do not do this out of the old delusion of fan-entitlement, but out of the hope that if another version comes out, they might be considered.

Major spoilers ahead.

Spoiler: ShowHide
Potential issue: Hole with lost comb is hard to find and quest-critical.
Possible solution: Make it slightly more visible.

Potential issue: Use of iron rune can shut player out of changeling quest without warning.
Possible solution: Make it harder to lose the rune. New problem: Player may use iron rune as a catch-all solution to many puzzles, rather than think of novel solution. New solution: Using the rune on the princess drains some of its magic, but not all of it. It takes multiple uses to destroy it.

Potential issue: Getting the rope early in the game is critical for major sidequests, but is possibly out-of-character and is certainly counterintuitive.
Possible solution: Justify getting the rope - not sure how. The idea of having Branwyn bet Maeldun that he can't steal it seems... out-of-character. Alternatively, set up another way of getting a rope.

Potential issue: Mystery plot lacks enough clues.
Possible solution: Add clues. Possibility: Give clear hints that the blacksmith forged a fake dagger, or something along those lines. Stress the physical strength of the assassin.

Potential issue: Not enough motivation to begin absolutely critical stable-boy quest.
Possible solution: The game already hints that you should show the note to Taliesin - perhaps Taliesin could drop a clearer hint that it would be wise to show the note to the Sidhe. In addition, it might be wise to make the note stick out of the haystack visibly.

Potential issue: Island is hard to find.
Possible solution: Map can also appear in monastery library? This should give the player a chance to see that critical clue later in the game. Wait, does the map appear in the monastery library? I've forgotten.

Potential issue: Ice orb's use is ambiguous. Description suggests that it might be able to freeze random objects.
Possible solution: Emphasize that its use is tied to a specific location.

Potential issue: Not enough payoff on the apprentice-befriending quest, and the girdle thing seems a little unclued.
Possible solution: If Maeldun lingers too long in the tower after helping the apprentice, she will appear instead of the wizard and warn him to get out if he values his life.

Potential issue: Stealing the blacksmith's shield seems poorly motivated during the brief time-window that it is possible.
Possible solution: Blacksmith visits the docks multiple times during the game, making this quest more forgiving without robbing it of its essential challenge. New problem: Player has less opportunity to get sword sharpened. Solution: The additional trips all come after Maeldun gets his sword sharpened. New problem: More dialogue needed. Solution: Blacksmith meets with

Potential issue: Black cloth clue is extremely odd; tailor gives little info, save that assassin is a local, and the blacksmith denies everything.
Possible solution: Tailor states that he has sold several cloaks made with that material to various local gentlemen. Still an ambiguous clue, because the cloak could have been stolen by a woman.

Potential issue: Message clue is somewhat misleading.
Possible solution: Uncertain.

Potential issue: Introduction text too long and vague.
Possible solution: Edit down introduction text; consider padding intro graphics by using image from book in library - if it wasn't originally intended for the intro.

Potential issue: Villain leaps onstage in a sudden and strange way.
Possible solution: The apprentice speaks of him in more specific terms, and has more screen time.

Potential issue: Branwyn lacks much of interest to say.
Possible solution: More conversation options for Branwyn. Clearer idea of character.

Potential issue: During assassination scene, doing stuff like "looking at the ajar door" doesn't really give atmospheric responses, and the draconian "the assassin jumps out of nowhere and kills you for lingering" stuff probably should be used to punish things like trying the alarm rope a few times, then walking over to the door and looking in, and so on.
Possible solution: Loosen the assassin's trigger a bit, and implement cautious behavior.

Potential issue: Throwing the dagger at the assassin requires a pixel hunt.
Possible solution: Refine this - although, given the speed of the animation, it's probably a major pain.

Potential issue: Why on earth would Maeldun look at a doorway during an assassination?
Possible solution: Find a better way of getting the hair to the player.

Potential issue: It is unclear, at first, why Maeldun lacks his girdle during the assassination scene, causing time to be wasted searching his room.
Note: Mention the loss of the girdle explicitly as soon as Maeldun wakes.

Potential issue: In the final battle, the order of events is highly finicky; why should an attack on the sorcerer by Maeldun distract him just as well as an attack by the guardsman? (Answer: Because then he'd have nothing to do.)

Possible (not entirely satisfactory) solution: If Maeldun attempts to attack the sorcerer, the guardsman will step forward as well, and will get to the sorcerer first. He might even shout something along the lines of "Stay back - you're no fighter."

Possible extra-awesome thing to do: Find a way to work Taliesin, the changeling, or the apprentice into the battle as a distraction that appears if the guard captain manages to get himself transformed. This keeps the battle going and gives us another chance to throw a dagger at the charm. While the teleport animation for the apprentice makes her a viable option, she doesn't seem like the noble sacrifice type...


Secret Fawful

  • A Drunken Maniac Who Screams A Lot
Re: A Tale Of Two Kingdoms
« Reply #94 on: 31 Jul 2007, 17:56 »
You can check out another review of the game HERE btw.

Devise the puzzles. Destroy the hero. Defeat the player.

Al_Ninio is an attention-seeking drama whore.

Re: A Tale Of Two Kingdoms
« Reply #95 on: 02 Aug 2007, 11:21 »
currently working on:

I am in the Brainstorming stage.  Also am trying to gather a team.
I am committing to this game.

Thinking about creating another game, NCIS themed.


  • This City at Night Demo - while stocks last!
    • I can help with play testing
    • I can help with proof reading
    • I can help with scripting
    • I can help with translating
    • paolo worked on a game that was nominated for an AGS Award!
Re: A Tale Of Two Kingdoms
« Reply #96 on: 06 Aug 2007, 14:28 »
It may well be that everything I am about to comment on has already been said, so apologies in advance if this is the case. I finished the game just over a week ago but have been away.

Here are my comments, mainly on the language in the game, and my bug reports.

Spoiler: ShowHide

The language

It's tricky to get archaic English right because most people are not very familiar with it these days. I'm no expert, but a few errors were glaringly obvious to me:

* The inflections of "thou" are very similar to the inflections of "I": you can pretty much change the "m" to "th" to go from the first- to the second-person singular: hence "me", "my", "mine", "myself" in the first person are "thee", "thy", "thine" and "thyself" in the second person. In particular, note "thine". This means "yours", not "your". So, for example, "thine name" is incorrect - this should be "thy name". Similarly, "thine self" is incorrect - this should be "thyself". However, "thine" can be used instead of "thy" before a vowel, so "thine eyes" is correct (as is "to thine own self be true"). Perhaps this usage led to the authors thinking that "thine" can always be used instead of "thy".
* "Regale" does not mean "recount", so you don't regale a tale to someone. It means to entertain (see Hence you regale someone with a tale, you don't regale a tale to someone.
* "Vagabond" comes from the Latin for "wandering", so in "a wandering vagabond", the word "wandering" is redundant.
* There is no such word as "o'threw" - it should be "o'erthrew". ("O'" is a short form of "of", not "over".)
* I take it that the blue cup's misuse of archaic language ("Thou appeareth to be playingeth...") is deliberately incorrect.
* The changeling struggles with his thees and thous, calling them formal, but the formal form is actually "ye" (see
* "Avast" is a nautical term, so, unless he used to be a sailor or pirate, why does the monk use it?
* "Shall" is occasionally used as if it were a formal form of "will" (eg, "We shall crush you"), but it is not. "We shall crush you" means "We are going to crush you"; to say "We are definitely going to crush you", you would need to say "We will crush you". See the usage notes at - while the distinction isn't really made these days, it certainly would have been in the era in which the game appears to be set.
* The use of US English clashes a little - British spellings would have given a truly quaint, olde worlde feel.
* The contractions "'tis", "'twas" and "'twould" should have a capital "t" when used at the beginning of a sentence (compare "'Twas the night before Christmas...")
* "Loathe" is a verb meaning to detest. "Loath" (or "loth") is an adjective meaning "reluctant". Hence "The fox seems loathe..." should be "The fox seems loath..."
* "tidings will turn" - tidings are news; should this be "the tide will turn"?
* There is no such word as "antromorph" - shouldn't this be "anthropomorph" (= humanoid)?
* A common mistake when quoting poetry is to put a comma at the end of each line. Poetry should be punctuated in exactly the same way as the text would be if written as prose. Consider the following lines taken from the game and converted into prose: "Careful, he might be tempted to bite or put up a fight." Note that there is only one comma, and none after the words that come at the ends of the lines in the equivalent poetry. In poetical form (the slashes separating the lines are not needed when the lines are given one at a time) this becomes: "Careful, he might / Be tempted to bite / Or put up a fight." No extra commas should be added. See for example the famous "To be or not to be" soliloquy from Hamlet for a good example of punctuation (or its absence) at the ends of lines of poetry.
* "Have need for" and "in search for" should be "have need of" and "in search of", respectively.
* "Fae" is fuel-air explosive (see - should this be "fay" or "fey" (,
* Does a harp have snares? A snare drum does, certainly, but aren't the strings of a harp just called strings? There is no mention of harps at nor of snares at
* "Rise" is intransitive; "raise" is transitive. Hence "...would make Theylinn rise once more..." (not "raise").

On the plus side:

* Thumbs up for the correct use the archaism "an", meaning "if".
* Double thumbs up for the amusing motto on the shield in the smithery - a nice little joke for those who understand Latin.

Bugs and other errors (some or all of which have or might have already been reported)

* When you pick up the squirrel while it is sitting on the roof, you are told that it climbs down the tree (which is one bug). It then does not move at all until you interact with it again, at which point it instantaneously moves from the roof to the ground.
* If you walk across the bridge in the righthand half of Thierna na Oge, the others follow you and hem you in, meaning that you can't move or do anything else. Presumably there is some sort of character collision detection in the program that gets stuck at this point.
* You can talk to the guard outside the castle while you are a rabbit, ask to see the princess and even tell him who you are, and he doesn't turn a hare... er, a hair. Maybe he saw you being transformed, however.
* It is a hare, isn't it, and not a rabbit? I don't remember which word the game uses.
* If you attempt to cross the bridge northwards whiel you are a hare, you are told that the fox runs off in search of less elusive prey. Two bugs here: no fox is present; and the game repeatedly displays the message, getting stuck in an infinite loop.
* "You feel uncomfortable crossing the river" - I am guessing that there is some scripting here that draws a straight line between your current and intended positions and tests to see whether it crosses water. The problem here is that this message is displayed even if you happen to clip a tiny bit of the river, which is silly as the hare is going to walk along the bank regardless. I think the test should be updated to test whether or not the start and end positions are on opposite banks, which would mean the hare would definitely be crossing the river.
* You need to hop around inside the faery ring, not just around it (I hopped around the stones for ages before I realised this) - perhaps the game can make this clearer.
* Apparently the walls of the city are too smooth for footholds to allow you to climb them, but you are able to scramble down them easily enough when you use the plant to get in. Of course, this is essential for the game, but it's inconsistent.
* The inner wall of the castle is much higher than the outer wall... is the interior of the castle set into the ground?
* There are several places were the name of an object does not appear in messages when you look at the message - these include the following, some of which have already been mentioned: the statue on the stairs in the castle; the plant to the left of the gate in Thierna na Oge; the rope ladder in the cave.
* In Chapter 8, all the doors in the castle are locked but the leftmost. When you try the leftmost door, you walk towards it and the guards spot you when you are halfway down the corridor. Unless you tried opening the other doors by remote control, would the same not happen when you tried, say, the second leftmost door, which is way beyond halfway down the corridor? The character should really walk to each door that is tried, not just to the leftmost one. You'll still get caught, but hey, that's the way the game goes.
* If you play the flute again in the castle after the guards have left, you get disembodied comments from the guards and the game crashes as it attempts to move the non-existent guards out of the room: in Room 90 script (line 486) - Error: MoveCharacter: character not in current room

Apart from that little lot, the game was great. Congratulations on the Herculean effort your team put in. It is a masterpiece and you deserve to be very proud.

PS: In case it seems I'm being overcritical about the language in the game, I should add, as I forgot to when I posted this, that you've done a damn good job on the archaic English. All too often people think you can just scatter a few thous and thees about without any consideration of whether they are used correctly, and just tack "eth" on the end of every verb (when in fact it should only be used as a third-person singular ending). So congratulations on your EXCELLENT WORK on the old-fashioned language in the game!
« Last Edit: 08 Aug 2007, 09:37 by paolo »
url=]This City at Night - Demo[/url]


  • Return once more to the Two Kingdoms!
    • I can help with publishing
    • I can help with story design
    • Radiant worked on a game that won an AGS Award!
    • Radiant worked on a game that was nominated for an AGS Award!
Re: A Tale Of Two Kingdoms
« Reply #97 on: 06 Aug 2007, 22:21 »
Spoiler: ShowHide

Crossing the river - no, the scripting uses regions, hence if you get too close to the water, there's the message. AGS walking doesn't work the way you think it does :)

Unsurprisingly, climbing down a wall is easier than climbing up a wall.

With respect to walking to doors, it is a conscious design decision to not make Maeldun walk to every hotspot or object when clicking on it, because given the sheer amount of such spots per room that would rather increase the amount of time it took a player to look through it. I don't think I want to be inconsistent in this just to add a few places for Maeldun to get caught when clicking on a spot that doesn't really have a game purpose.

Interestingly, in Dutch the things on a harp are indeed called snares.

Please spare me the grammar lessons. I am aware of English grammar, what you point out are simply typoes. Also, Cuppits misspellings of pretty much every second word are very much deliberate (there was at least one game reviewer who thought META was a serious game, go figure... :P )

My encyclopedia shows half a dozen entries for FAE, including "fundamental attribution error" and the "Ecuadorian Air Force", as well as it being a synonym for faerie.

Ironically, in medieval English, "thee" was the common form and "you" was the formal form; however, since nowadays the latter is commonly used and the former deprecated, this has been reversed in fantasy books.


  • This City at Night Demo - while stocks last!
    • I can help with play testing
    • I can help with proof reading
    • I can help with scripting
    • I can help with translating
    • paolo worked on a game that was nominated for an AGS Award!
Re: A Tale Of Two Kingdoms
« Reply #98 on: 08 Aug 2007, 09:41 »
I see. Thank you for the clarifications and explanations. It's obvious that you did your homework when writing the game, so please excuse me if I seemed to be too critical.

Please also see the final paragraph I have added to my posting above.
url=]This City at Night - Demo[/url]


  • Teenage Mutant Ninja Turtle
    • I can help with characters
    • I can help with making music
    • I can help with play testing
    • I can help with story design
    • I can help with translating
    • I can help with voice acting
Re: A Tale Of Two Kingdoms
« Reply #99 on: 08 Aug 2007, 22:56 »
I'm sorry but I can't help saying this wasn't a bt of a disappointment regarding graphics since I've seen a lot of the work before, also I've been working on this game myself spritewise, ones that were unused. But nevertheles, I'll play this game through and see what it makes, as a game, you know. I just thought that I'd make a remark regarding the first impresion it gave me.

I think you did well with your team Radiant. But I can't help thinking you could have done better.