Author Topic: EDITOR PLUGIN: Speech Center - Version 2.1.2 - updated to support AGS 3.4 & 3.5  (Read 54952 times)

Dualnames

  • Local Moderator
  • Rottwheelers
  • Pretty Badass
    • Dualnames worked on one or more games that won an AGS Award!
    •  
    • Dualnames worked on one or more games that was nominated for an AGS Award!
Still the same issue on my new pc, on WIN 10.
No more military army stuff. I'm alive and back.

Dualnames

  • Local Moderator
  • Rottwheelers
  • Pretty Badass
    • Dualnames worked on one or more games that won an AGS Award!
    •  
    • Dualnames worked on one or more games that was nominated for an AGS Award!
I'm using 3.5.0.2 beta,so that might be the issue?
No more military army stuff. I'm alive and back.

I'm using 3.5.0.2 beta,so that might be the issue?

I don't know what is this about, but if remember correctly there was about a year of development between 3.5.0.2 (alpha) and the final release, so alot of changes have been done in between.
« Last Edit: 14 Jan 2021, 18:17 by Crimson Wizard »

Dualnames

  • Local Moderator
  • Rottwheelers
  • Pretty Badass
    • Dualnames worked on one or more games that won an AGS Award!
    •  
    • Dualnames worked on one or more games that was nominated for an AGS Award!
Newest beta works !!!!

EDIT: It's irrelevant to newest beta, it had to do with my installing redistributables from here
https://www.techpowerup.com/download/visual-c-redistributable-runtime-package-all-in-one/
« Last Edit: 16 Jan 2021, 00:24 by Dualnames »
No more military army stuff. I'm alive and back.

eri0o

AGS installer should install any needed redistributable. You are saying that one didn't work or you didn't install AGS and instead ran it from binaries?

Newest beta works !!!!

EDIT: It's irrelevant to newest beta, it had to do with my installing redistributables from here
https://www.techpowerup.com/download/visual-c-redistributable-runtime-package-all-in-one/
Not sure I understand, the latest I see is 3.5.0.29 which is a release 4 days ago. Can you send me a link to the exact version you were using?
It's possible the runtime you installed is needed for the plugin and not AGS, although I've tried to make sure it's aligned. This also explains why I haven't seen that issue.

Dualnames

  • Local Moderator
  • Rottwheelers
  • Pretty Badass
    • Dualnames worked on one or more games that won an AGS Award!
    •  
    • Dualnames worked on one or more games that was nominated for an AGS Award!
Older version i was using also works!! My edit was the solution!
No more military army stuff. I'm alive and back.

What the AGS installer provides was based on the minimum version that AGS itself required to run. There is a specific check for that version or later that skips installation, so potentially there is a gap in the middle where AGS is happy but something related to a plug-in would not be , depending on what the plug-ins requirements are.

https://github.com/adventuregamestudio/ags/blob/faf6ab299d1767391a2aa0cde05d848dc5294c3f/Windows/Installer/ags.iss#L186-L189
Code: Pascal
  1.   // Visual C++ runtime
  2.   // https://download.microsoft.com/download/6/A/A/6AA4EDFF-645B-48C5-81CC-ED5963AEAD48/vc_redist.x86.exe
  3.   VCPP_REDIST_MAJOR_VERSION = 14.0;
  4.   VCPP_REDIST_BUILD_VERSION = 24215;

If that is the issue then potentially the installer could provide newer runtime files to be more compatible with plug-in requirements. It is probably easier that way than saying that all plug-ins supply their own VC++ runtime as that means users without admin rights can't use install plug-ins (and I think there is a scheme afoot to try and get something resembling an AGS plug-in repository working). Possibly statically linking a plug-in with the runtime version might work too, I don't know enough about that to say for sure.