Author Topic: Bug reports & suggestions  (Read 115285 times)

Re: Bug reports
« Reply #180 on: 17 Sep 2013, 01:18 »
On the games page, one of the random screenshots looked interesting (well, at least in the small preview ;)), so I clicked on it. However, the page shows an error:

Quote
Game Not Found
The game you requested could not be found in the database. There are three possible reasons for this:...

http://www.adventuregamestudio.co.uk/site/games/game/746/
Is there something wrong with the page? Or was the game removed from the DB but not completely?
The title is supposed to be Dan Finds His Beard and the image is this:

After seeing this ^ I cannot think straight. Oh, AGS Gods... Please, I need to find out if Dan finds his beard. I don't think I'll be able to sleep otherwise. Someone. ANYONE. If you can shed some light on this situation.

This may be the last you hear from me. Shine on, you crazy diamonds :~(.

I of course am joking. That game has probably been deleted :P.
« Last Edit: 17 Sep 2013, 01:20 by Sunny Penguin »

AGA

  • Adventure Game Aficionado
  • Administrator
  • Mittens Deity
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #181 on: 17 Sep 2013, 01:20 »
On the games page, one of the random screenshots looked interesting (well, at least in the small preview ;)), so I clicked on it. However, the page shows an error:

Quote
Game Not Found
The game you requested could not be found in the database. There are three possible reasons for this:...

http://www.adventuregamestudio.co.uk/site/games/game/746/
Is there something wrong with the page? Or was the game removed from the DB but not completely?
The title is supposed to be Dan Finds His Beard and the image is this: http://www.adventuregamestudio.co.uk/images/games/746.jpg

The random game thing was showing games that had been disabled ('deleted').  Shouldn't do anymore.

As for the calendar thing, I'll take a look at some point.

selmiak

  • ǝsıɔɹǝxǝ ʞɔǝu puɐ uıɐɹq
    • I can help with play testing
    • I can help with proof reading
    • I can help with translating
    • I can help with web design
    • selmiak worked on one or more games that won an AGS Award!
    •  
    • selmiak worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #182 on: 19 Sep 2013, 15:09 »
within the forum: the quickreply still has the bbcode buttons above the message box, but when previewing the quickreply the bbcode buttons are gone.

edit: the edit version of the post also still has the bbcode buttons ;)
« Last Edit: 19 Sep 2013, 15:13 by selmiak »

Re: Bug reports
« Reply #183 on: 22 Sep 2013, 10:37 »
The skill buttons below the avatar still show "I can help with X" instead of the custom text. I'm going to keep bringing this up :D

Adeel

  • Cavefish
    • Adeel worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #184 on: 22 Sep 2013, 12:08 »
I've encountered an interesting bug.

When I put a normal image and use the center aligning, like this, then the image displays as it should:


But when I put a zoomable image and use the center aligning, like this, then the image is displayed more to the right (which it shouldn't) until the mouse is hovered on it. When the mouse is hovered on the image, the image positions itself correctly:


What sorcery is this? (laugh)

The bug was originally discovered here.

EDIT:

I should mention that I'm using Opera 12.15. My resolution is 1280 x 1024 pixels.
« Last Edit: 22 Sep 2013, 12:26 by Adeel S. Ahmed »

selmiak

  • ǝsıɔɹǝxǝ ʞɔǝu puɐ uıɐɹq
    • I can help with play testing
    • I can help with proof reading
    • I can help with translating
    • I can help with web design
    • selmiak worked on one or more games that won an AGS Award!
    •  
    • selmiak worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #185 on: 22 Sep 2013, 13:19 »
I should mention that I'm using Opera 12.15. My resolution is 1280 x 1024 pixels.

Same on FF24.0

Tabata

  • mouse-fetishist & smiley-maniac
    • Tabata worked on one or more games that won an AGS Award!
    •  
    • Tabata worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #186 on: 22 Sep 2013, 14:37 »
I should mention that I'm using Opera 12.15. My resolution is 1280 x 1024 pixels.

Same on FF24.0
same in Chrome  (but I don't mind)  :wink:

Peder 🚀

  • Been nearly 10 years, think it's time for a change
    • Lifetime Achievement Award Winner
    • Peder 🚀 worked on one or more games that won an AGS Award!
    •  
    • Peder 🚀 worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #187 on: 22 Sep 2013, 19:29 »
That's simply because the div containing the image and zoom options have been given a width of 0.
Code: Adventure Game Studio
  1. <div onmouseover="javascript:showZoomControls(this);" onmouseout="javascript:hideZoomControls(this);" style="width:0px"></div>

Adeel

  • Cavefish
    • Adeel worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #188 on: 23 Sep 2013, 13:56 »
That's simply because the div containing the image and zoom options have been given a width of 0.
Code: Adventure Game Studio
  1. <div onmouseover="javascript:showZoomControls(this);" onmouseout="javascript:hideZoomControls(this);" style="width:0px"></div>

Oh, I understand. Why the width is given 0, though?

Peder 🚀

  • Been nearly 10 years, think it's time for a change
    • Lifetime Achievement Award Winner
    • Peder 🚀 worked on one or more games that won an AGS Award!
    •  
    • Peder 🚀 worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #189 on: 23 Sep 2013, 21:34 »
Adeel, I have no idea as I never wrote the code, I just found the fault to the bug ;).

There is another bug that I haven't seen mentioned yet though if it has sorry for reposting:
All new games seems to register 3 screenshots even when there is only 1.
Also if there is no screenshot at all there is no "placement" screenshot to say there is none, all it does is show as a broken image, which looks really ugly imo.
http://www.adventuregamestudio.co.uk/site/games/game/1724/
http://www.adventuregamestudio.co.uk/site/games/game/1727/
http://www.adventuregamestudio.co.uk/site/games/game/1728/
http://www.adventuregamestudio.co.uk/site/games/game/1721/
http://www.adventuregamestudio.co.uk/site/games/game/1722/

Now I have no game to add myself, so I don't know 100% sure if this is a real bug or just the creators of the games doing something wrong when adding the game.
However it seems to have happened to every game since late August. Though the broken images thing is still a "problem".

MiteWiseacreLives!

  • Hold onto your Fossils!
Re: Bug reports
« Reply #190 on: 23 Sep 2013, 23:56 »
Its a little confusing posting the screen shots. it seems as if you can list three separated by a semicolon?? maybe.. but it doesn't seem to work, seemed to be happening to others as well. Is there a way to list multiple shots or was it only ever made for one?

AGA

  • Adventure Game Aficionado
  • Administrator
  • Mittens Deity
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #191 on: 24 Sep 2013, 07:29 »
I was working on the ability to add up to three screenshots, but never got around to finishing it.  I thought I'd removed all references to it, but apparently not!  I'll sort it out when I get the chance.

Re: Bug reports
« Reply #192 on: 24 Sep 2013, 22:56 »
within the forum: the quickreply still has the bbcode buttons above the message box, but when previewing the quickreply the bbcode buttons are gone.

edit: the edit version of the post also still has the bbcode buttons ;)
I've noticed this too.  If I write my reply in 'quickreply' or by clicking the normal 'reply' button, then I will have all the BB Code functions.  But if I am using quickreply and then click on 'preview', all the functions go missing (except the smilies).

abstauber

  • Cavefish
  • Mittens Knight
  • still mowing the lawn
    • abstauber worked on one or more games that won an AGS Award!
    •  
    • abstauber worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #193 on: 26 Nov 2013, 07:48 »
I can't access this site with firefox mobile (android) anymore.
"Your web browser's User-Agent string contained data which is associated with spam or other malicious activity"

AGA

  • Adventure Game Aficionado
  • Administrator
  • Mittens Deity
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #194 on: 26 Nov 2013, 23:09 »
I've upgraded the secret anti spam plugins we use.  Fixed now?

abstauber

  • Cavefish
  • Mittens Knight
  • still mowing the lawn
    • abstauber worked on one or more games that won an AGS Award!
    •  
    • abstauber worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #195 on: 27 Nov 2013, 11:20 »
yay - phone forums are back online. Thanks!

Babar

  • Creator, Mutator and Defecator
    • I can help with proof reading
    • I can help with scripting
    • I can help with story design
    • I can help with translating
    • Babar worked on one or more games that won an AGS Award!
    •  
    • Babar worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #196 on: 21 Dec 2013, 09:18 »
I haven't changed any of my firefox settings, and so far it seems only AGS is like this, but the text in the forum list and topic list seems to have bloated up. The forum names and topic starters seem to be the same size, but the topic names and Replies/Views have increased in size. Is it just me?
The ultimate Professional Amateur

Now, with his very own game: Alien Time Zone

Re: Bug reports
« Reply #197 on: 21 Dec 2013, 10:04 »
No, it seems to be for me as well. My zoom level is zero'd and I've done a full refresh of the CSS, looks to me like AGA did some text size tweaking.

Adeel

  • Cavefish
    • Adeel worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #198 on: 21 Dec 2013, 12:14 »
I haven't changed any of my firefox settings, and so far it seems only AGS is like this, but the text in the forum list and topic list seems to have bloated up. The forum names and topic starters seem to be the same size, but the topic names and Replies/Views have increased in size. Is it just me?

This is the same case with me too and its very annoying.

selmiak

  • ǝsıɔɹǝxǝ ʞɔǝu puɐ uıɐɹq
    • I can help with play testing
    • I can help with proof reading
    • I can help with translating
    • I can help with web design
    • selmiak worked on one or more games that won an AGS Award!
    •  
    • selmiak worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #199 on: 21 Dec 2013, 13:30 »
For the boards overview it's okayish but the huge threadtitles inside the boards is like the boards are screaming at me 8-0