Jibble

A redesign of the AGS site is being planned! Please check out the mockups and give your feedback.


Two factor authentication (via app or email) is now available for the forums. You can enable it on your profile.

Author Topic: Bug reports & suggestions  (Read 113213 times)

AGA

  • Adventure Game Aficionado
  • Administrator
  • Mittens Deity
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #300 on: 19 Mar 2014, 22:26 »
That's my baby you're flinging unproven accusations at >:(

selmiak

  • ǝsıɔɹǝxǝ ʞɔǝu puɐ uıɐɹq
    • I can help with play testing
    • I can help with proof reading
    • I can help with translating
    • I can help with web design
    • selmiak worked on one or more games that won an AGS Award!
    •  
    • selmiak worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #301 on: 19 Mar 2014, 23:43 »
yeah, never change a running system, guess there will be no super extended extensions anyways ;)

Radiant

  • Mittens Knight
  • AGS Baker
  • Return once more to the Two Kingdoms!
    • I can help with story design
    • I can help with publishing
    • Radiant worked on one or more games that won an AGS Award!
    •  
    • Radiant worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #302 on: 20 Mar 2014, 17:26 »
For some reason I cannot edit the games page any more; I get a 403 error that "You do not have permission to access this server. Your technical support key is: 57d2-ef78-b40c-8ddc"

Peder 🚀

  • Been nearly 10 years, think it's time for a change
    • Lifetime Achievement Award Winner
    • Peder 🚀 worked on one or more games that won an AGS Award!
    •  
    • Peder 🚀 worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #303 on: 20 Mar 2014, 17:36 »
I've connected those error messages to the forum connection (SSI.php) but got no idea what is causing it, also it seems to only happen in chrome for me so maybe try a different browser for now?

(It seems I get that error in chrome whenever I use a page to post a form it seems.)

Radiant

  • Mittens Knight
  • AGS Baker
  • Return once more to the Two Kingdoms!
    • I can help with story design
    • I can help with publishing
    • Radiant worked on one or more games that won an AGS Award!
    •  
    • Radiant worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #304 on: 20 Mar 2014, 17:47 »
It worked fine a couple of weeks ago, though. Something must have changed since then.

But I don't think it's a good idea to advice Chrome users to "just use another browser" for this site, because of its huge market share. Every other forum I frequent works fine in Chrome.

Peder 🚀

  • Been nearly 10 years, think it's time for a change
    • Lifetime Achievement Award Winner
    • Peder 🚀 worked on one or more games that won an AGS Award!
    •  
    • Peder 🚀 worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #305 on: 20 Mar 2014, 17:59 »
Off course!
The best thing would be to figure out why it's not working and then get it fixed, all I can tell from it, is that it seems to be generated by the forum integration, because the 403 error is within the part where the forum integration is called via php.
And whenever the forum integration fails, it will stop anything else from showing.. But this issue only happens to me in Chrome, so I purely suggested to use another browser if you really need to update your games RIGHT NOW :).

Hopefully AGA will figure this out and get it fixed.. I might do some searching myself.

AGA

  • Adventure Game Aficionado
  • Administrator
  • Mittens Deity
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #306 on: 20 Mar 2014, 18:26 »
Nothing has changed, except possibly your version of Chrome.  I know that's not very helpful, but there's only so much I can do about core SMF features' bugs!

Adeel

  • Cavefish
    • Adeel worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #307 on: 21 Mar 2014, 12:15 »
But I don't think it's a good idea to advice Chrome users to "just use another browser" for this site, because of its huge market share. Every other forum I frequent works fine in Chrome.

Considering how often IE Fans are advised to change their browser, just because it isn't compatible with the website. I think Peder's advice is fair enough. :=

Peder 🚀

  • Been nearly 10 years, think it's time for a change
    • Lifetime Achievement Award Winner
    • Peder 🚀 worked on one or more games that won an AGS Award!
    •  
    • Peder 🚀 worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #308 on: 21 Mar 2014, 12:37 »
But Adeel, IE fans are just silly! IE sucks!

I have to say though it seems IE is beginning to get a little bit better, but there are still so many computers with older IE versions on them and imo that should be a felony! :P.

Snarky

  • Global Moderator
  • Global Moderator
  • Mittens Lord
  • Private Insultant
    • Best Innovation Award Winner 2018, for his numerous additions to the AGS open source ecosystem including the new Awards Ceremony client and modules
    • Snarky worked on one or more games that won an AGS Award!
    •  
    • Snarky worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #309 on: 21 Mar 2014, 20:06 »
I was also getting a bunch of 403 errors about this time last week, particularly while browsing the Wiki (but which would then extend to any forum page as well). If I just waited half a minute they went away.

And this was with Firefox.

Radiant

  • Mittens Knight
  • AGS Baker
  • Return once more to the Two Kingdoms!
    • I can help with story design
    • I can help with publishing
    • Radiant worked on one or more games that won an AGS Award!
    •  
    • Radiant worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #310 on: 21 Mar 2014, 23:08 »
I've tried changing the game page on my laptop, which also runs Chrome, and this works fine. Also, I'm pretty sure I haven't done an update of Chrome (on my desktop) since the last time it worked. So I doubt it's actually the browser causing this, although I'm not sure what else it would be.

Peder 🚀

  • Been nearly 10 years, think it's time for a change
    • Lifetime Achievement Award Winner
    • Peder 🚀 worked on one or more games that won an AGS Award!
    •  
    • Peder 🚀 worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #311 on: 22 Mar 2014, 11:21 »
I've been trying to search for solutions or just for other people having this issue but I can't seem to find any info about it at all, though I know for sure the error is generated by the forum connection as when commented out it works fine..

Peder 🚀

  • Been nearly 10 years, think it's time for a change
    • Lifetime Achievement Award Winner
    • Peder 🚀 worked on one or more games that won an AGS Award!
    •  
    • Peder 🚀 worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #312 on: 22 Mar 2014, 11:24 »
Ok, so I just moved the SSI.php include to the top of the file, and it now seems to be fine for me, what about you Radiant?

Radiant

  • Mittens Knight
  • AGS Baker
  • Return once more to the Two Kingdoms!
    • I can help with story design
    • I can help with publishing
    • Radiant worked on one or more games that won an AGS Award!
    •  
    • Radiant worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #313 on: 22 Mar 2014, 11:43 »
Yep, it works now. Thanks!

monkey0506

  • SEND PIZZA.
    • Best Innovation Award Winner 2017, for his work to help AGS games reach the widest possible audience - through popular distribution platforms (Steam, Galaxy) as well as other operating systems (Android, Linux)
    • monkey0506 worked on one or more games that won an AGS Award!
    •  
    • monkey0506 worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #314 on: 27 Mar 2014, 19:52 »
I was being silly and thought I'd go and add a page to the wiki today, when suddenly the whole thing exploded.

First (despite being logged in on the forums), it asked me to log in to my account. Again, I was already logged in, so it seemed rather odd bringing me to the forum login page with my avatar and user control panel appearing, but I logged in anyway. It then brought me to the forum homepage. Then I clicked back on the link for the wiki, and I got this:

Code: Text
  1. MediaWiki internal error.
  2.  
  3. Original exception: exception 'MWException' with message 'SkinTemplate::makeTalkUrlDetails given invalid pagename User:' in /var/www/ags/w/includes/SkinTemplate.php:721
  4. Stack trace:
  5. #0 /var/www/ags/w/includes/SkinTemplate.php(648): SkinTemplate->makeTalkUrlDetails('User:')
  6. #1 /var/www/ags/w/includes/SkinTemplate.php(448): SkinTemplate->buildPersonalUrls()
  7. #2 /var/www/ags/w/includes/OutputPage.php(1989): SkinTemplate->outputPage()
  8. #3 /var/www/ags/w/includes/Wiki.php(543): OutputPage->output()
  9. #4 /var/www/ags/w/includes/Wiki.php(446): MediaWiki->main()
  10. #5 /var/www/ags/w/index.php(59): MediaWiki->run()
  11. #6 {main}
  12.  
  13. Exception caught inside exception handler: exception 'MWException' with message 'SkinTemplate::makeTalkUrlDetails given invalid pagename User:' in /var/www/ags/w/includes/SkinTemplate.php:721
  14. Stack trace:
  15. #0 /var/www/ags/w/includes/SkinTemplate.php(648): SkinTemplate->makeTalkUrlDetails('User:')
  16. #1 /var/www/ags/w/includes/SkinTemplate.php(448): SkinTemplate->buildPersonalUrls()
  17. #2 /var/www/ags/w/includes/OutputPage.php(1989): SkinTemplate->outputPage()
  18. #3 /var/www/ags/w/includes/Exception.php(227): OutputPage->output()
  19. #4 /var/www/ags/w/includes/Exception.php(272): MWException->reportHTML()
  20. #5 /var/www/ags/w/includes/Exception.php(620): MWException->report()
  21. #6 /var/www/ags/w/includes/Exception.php(690): MWExceptionHandler::report(Object(MWException))
  22. #7 /var/www/ags/w/includes/Wiki.php(449): MWExceptionHandler::handle(Object(MWException))
  23. #8 /var/www/ags/w/index.php(59): MediaWiki->run()
  24. #9 {main}

Feels bad man. :~(

AGA

  • Adventure Game Aficionado
  • Administrator
  • Mittens Deity
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #315 on: 28 Mar 2014, 10:10 »
Does this happen more than once?  Does it keep happening if you delete cookies / session vars and try again?

monkey0506

  • SEND PIZZA.
    • Best Innovation Award Winner 2017, for his work to help AGS games reach the widest possible audience - through popular distribution platforms (Steam, Galaxy) as well as other operating systems (Android, Linux)
    • monkey0506 worked on one or more games that won an AGS Award!
    •  
    • monkey0506 worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #316 on: 07 Apr 2014, 03:55 »
No. Nothing has changed. Exact same behavior. Multiple days. Multiple attempts clearing everything. Multiple systems. It's not a localized issue.

AGA

  • Adventure Game Aficionado
  • Administrator
  • Mittens Deity
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #317 on: 07 Apr 2014, 10:37 »
I'll try updating various plugins and scripts tonight, see if that helps.

Re: Bug reports
« Reply #318 on: 02 Jun 2014, 01:51 »
Everything was fine a few hours ago, and suddenly every text is centered when I look at threads!
I checked the page with Firebug and I can't find any text-alignment rule. ???

I'd love to know what's causing this.
Fail at Floaty Rog' now!  still having to deal with what games are going through

Re: Bug reports
« Reply #319 on: 02 Jun 2014, 03:18 »
Same issue here.