Author Topic: Bug reports & suggestions  (Read 77780 times)

Re: Bug reports
« Reply #480 on: 24 Dec 2018, 18:28 »
Sorry if this has been brought up already but the bbcode tables have lost their borders.

There will be a fair few minor graphical differences here and there, but unless it's actually causing a problem (or looks horrible!) it's probably not worth 'fixing'.

Idk if that depends on some browser settings or else, but for me it actually it looks pretty bad because it's not only lack of borders but also no distinct cell background; so instead of a table you see a text adjusted in rows and columns, making it not easy to perceive:

cell 11cell 12cell 13
cell 21cell 22cell 23
cell 31cell 32cell 33

AGA

  • Adventure Game Aficionado
  • Administrator
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #481 on: 24 Dec 2018, 22:22 »
Can you provide a screenshot of what you see?  And if you can work out what CSS needs to be adjusted to fix it, by all means let me know!

Re: Bug reports
« Reply #482 on: 24 Dec 2018, 23:51 »
I see this:

AGA

  • Adventure Game Aficionado
  • Administrator
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #483 on: 25 Dec 2018, 10:30 »
I've readded borders, but they look a little ugly.  If anyone has any idea as what properties would make them a bit prettier, please let me know!

cat

  • Mittens Baronet
    • cat worked on one or more games that won an AGS Award!
    •  
    • cat worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #484 on: 29 Dec 2018, 22:14 »
Newly added games don't show up in the forum profile. I added this game: http://www.adventuregamestudio.co.uk/site/games/game/2316/ but it isn't listed. It is, however, shown in the list of games I also worked on when looking at another game's page.

AGA

  • Adventure Game Aficionado
  • Administrator
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #485 on: 30 Dec 2018, 00:06 »
Fixed! slasher also complained about the same issue a few days ago, and I fixed it then. Either I accidentally redeployed an old version of the fixed file, or it was gremlins. I blame the gremlins ¬¬

cat

  • Mittens Baronet
    • cat worked on one or more games that won an AGS Award!
    •  
    • cat worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #486 on: 30 Dec 2018, 16:49 »
It's working, thanks! Stupid gremlins  :P

Adeel

  • Cavefish
    • Adeel worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #487 on: 31 Dec 2018, 20:29 »
Dunno if anyone else has already reported this or not, but previously only the field(s) you'd filled in 'I can help with' would show up on your profile. Now, however, all the fields show up regardless of the ones you've filled. The only difference is that the ones you've filled show a custom text next to them (as they should) whereas the ones you leave out show blank space.

This makes it look awkward, especially if you've not filled any field whatsoever. This implies that the person can help with everything whereas they are probably not willing to help with anything at all. This might confuse a new member.

It's a minor thing, but I thought you'd like to know.
« Last Edit: 31 Dec 2018, 20:30 by Adeel »
-

Haggis

  • Cavefish
  • I've made a huge mistake
    • Haggis worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #488 on: 31 Dec 2018, 22:01 »
It looks like there's a known bug with image links being broken.
Just in case there's two bugs here - my game https://www.adventuregamestudio.co.uk/site/games/game/2044/ has a broken primary image.
I tried to replace the broken image with a new one, however doing so generates multiple image deletion error messages and fails to complete.

[EDIT] Interestingly, it only appears broken on initial game page load - if I cycle between game screenshots and back to the 'primary' image, it will then load.

AGA

  • Adventure Game Aficionado
  • Administrator
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #489 on: 01 Jan 2019, 15:00 »
Dunno if anyone else has already reported this or not, but previously only the field(s) you'd filled in 'I can help with' would show up on your profile. Now, however, all the fields show up regardless of the ones you've filled. The only difference is that the ones you've filled show a custom text next to them (as they should) whereas the ones you leave out show blank space.

This makes it look awkward, especially if you've not filled any field whatsoever. This implies that the person can help with everything whereas they are probably not willing to help with anything at all. This might confuse a new member.

It's a minor thing, but I thought you'd like to know.

I'll have a look, thaks.

It looks like there's a known bug with image links being broken.
Just in case there's two bugs here - my game https://www.adventuregamestudio.co.uk/site/games/game/2044/ has a broken primary image.
I tried to replace the broken image with a new one, however doing so generates multiple image deletion error messages and fails to complete.

[EDIT] Interestingly, it only appears broken on initial game page load - if I cycle between game screenshots and back to the 'primary' image, it will then load.

Fixed!

Re: Bug reports
« Reply #490 on: 01 Jan 2019, 20:41 »
I have the error

00c4c6b7e2e1c777371d79d7] 2019-01-01 20:38:53: Fatal exception of type "InvalidArgumentException" .

When trying to load

https://www.adventuregamestudio.co.uk/wiki/Module_IndexCategory

AGA

  • Adventure Game Aficionado
  • Administrator
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #491 on: 01 Jan 2019, 21:14 »
I have the error

00c4c6b7e2e1c777371d79d7] 2019-01-01 20:38:53: Fatal exception of type "InvalidArgumentException" .

When trying to load

https://www.adventuregamestudio.co.uk/wiki/Module_IndexCategory

Loads fine for me...  Does it work if you do a hard refresh, or view in another browser?

Re: Bug reports
« Reply #492 on: 06 Jan 2019, 13:43 »
https://www.adventuregamestudio.co.uk/wiki/AGS_Engine_Coding_Conventions

I get the error below

Code: Adventure Game Studio
  1.  /wiki/AGS_Engine_Coding_Conventions InvalidArgumentException from line 203 of /home/ags/html/w/includes/session/SessionManager.php: Invalid session ID
  2.  
  3. Backtrace:
  4.  
  5. #0 /home/ags/html/w/includes/session/PHPSessionHandler.php(242): MediaWiki\Session\SessionManager->getSessionById(string, boolean)
  6. #1 [internal function]: MediaWiki\Session\PHPSessionHandler->read(string)
  7. #2 /home/ags/html/w/extensions/Auth_SMF.php(406): session_start()
  8. #3 /home/ags/html/w/extensions/Auth_SMF.php(346): smf_sessionSetup()
  9. #4 /home/ags/html/w/includes/Hooks.php(177): UserLogoutSMF(User)
  10. #5 /home/ags/html/w/includes/Hooks.php(205): Hooks::callHook(string, array, array, NULL)
  11. #6 /home/ags/html/w/includes/user/User.php(4065): Hooks::run(string, array)
  12. #7 /home/ags/html/w/extensions/Auth_SMF.php(275): User->logout()
  13. #8 /home/ags/html/w/includes/Hooks.php(177): AutoAuthenticateSMF(User, User)
  14. #9 /home/ags/html/w/includes/Hooks.php(205): Hooks::callHook(string, array, array, string)
  15. #10 /home/ags/html/w/includes/user/User.php(1343): Hooks::run(string, array, string)
  16. #11 /home/ags/html/w/includes/user/User.php(449): User->loadFromSession()
  17. #12 /home/ags/html/w/includes/user/User.php(2400): User->load()
  18. #13 /home/ags/html/w/includes/MediaWiki.php(563): User->getName()
  19. #14 /home/ags/html/w/includes/MediaWiki.php(522): MediaWiki->setDBProfilingAgent()
  20. #15 /home/ags/html/w/index.php(42): MediaWiki->run()
  21. #16 {main}
  22.  

Re: Bug reports
« Reply #493 on: 06 Jan 2019, 14:19 »
When trying to edit this page:
https://www.adventuregamestudio.co.uk/wiki/Keyword:_attribute

I got this:
Quote from: Internal error
[104536ca1a6d4a8a8ff0c1e6] /w/index.php?title=Keyword:_attribute&action=edit Error from line 489 of /home/ags/html/w/extensions/ConfirmEdit/SimpleCaptcha/Captcha.php: Class 'CaptchaTriggers' not found

Backtrace:

#0 /home/ags/html/w/extensions/ConfirmEdit/SimpleCaptcha/Captcha.php(554): SimpleCaptcha->triggersCaptcha(string, Title)
#1 /home/ags/html/w/extensions/ConfirmEdit/SimpleCaptcha/Captcha.php(214): SimpleCaptcha->shouldCheck(WikiPage, string, string, RequestContext)
#2 /home/ags/html/w/extensions/ConfirmEdit/includes/ConfirmEditHooks.php(62): SimpleCaptcha->editShowCaptcha(EditPage)
#3 /home/ags/html/w/includes/Hooks.php(177): ConfirmEditHooks::confirmEditPage(EditPage, array, integer)
#4 /home/ags/html/w/includes/Hooks.php(205): Hooks::callHook(string, array, array, NULL)
#5 /home/ags/html/w/includes/EditPage.php(4346): Hooks::run(string, array)
#6 /home/ags/html/w/includes/EditPage.php(3633): EditPage->getEditButtons(integer)
#7 /home/ags/html/w/includes/EditPage.php(2881): EditPage->showStandardInputs()
#8 /home/ags/html/w/includes/EditPage.php(674): EditPage->showEditForm()
#9 /home/ags/html/w/includes/actions/EditAction.php(60): EditPage->edit()
#10 /home/ags/html/w/includes/MediaWiki.php(500): EditAction->show()
#11 /home/ags/html/w/includes/MediaWiki.php(294): MediaWiki->performAction(Article, Title)
#12 /home/ags/html/w/includes/MediaWiki.php(861): MediaWiki->performRequest()
#13 /home/ags/html/w/includes/MediaWiki.php(524): MediaWiki->main()
#14 /home/ags/html/w/index.php(42): MediaWiki->run()
#15 {main}

Re: Bug reports
« Reply #494 on: 11 Jan 2019, 22:09 »
https://www.adventuregamestudio.co.uk/site/games/awards/

Quote
Database query F.9.1 error: Unknown column 'multiple_winners' in 'where clause'

AGA

  • Adventure Game Aficionado
  • Administrator
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #495 on: 11 Jan 2019, 23:04 »
https://www.adventuregamestudio.co.uk/site/games/awards/

Quote
Database query F.9.1 error: Unknown column 'multiple_winners' in 'where clause'

Fixed.

Re: Bug reports
« Reply #496 on: 23 Jan 2019, 21:12 »
First of all, I never noticed when this feature appeared, but I'd like to give my big thanks to whoever implemented autocomplete in the game search :)

Now, this is not really a "bug" report, but I was wondering if it's possible to make this autocomplete a little bit different from surrounding text, like draw it on darker background?

AGA

  • Adventure Game Aficionado
  • Administrator
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports
« Reply #497 on: 23 Jan 2019, 21:39 »
First of all, I never noticed when this feature appeared, but I'd like to give my big thanks to whoever implemented autocomplete in the game search :)

Now, this is not really a "bug" report, but I was wondering if it's possible to make this autocomplete a little bit different from surrounding text, like draw it on darker background?

The technical side of the AGS site and forums is all me!  I've darkened the background a bit.  Can't go too dark though, or it'd clash with the rest of the page style.

selmiak

  • ǝsıɔɹǝxǝ ʞɔǝu puɐ uıɐɹq
    • I can help with play testing
    • I can help with proof reading
    • I can help with translating
    • I can help with web design
    • selmiak worked on one or more games that won an AGS Award!
    •  
    • selmiak worked on one or more games that was nominated for an AGS Award!
Re: Bug reports & suggestions
« Reply #498 on: 05 Feb 2019, 13:44 »
when adding a comment on a game in the DB you get redirected to the game page afterwards again. When deleting a comment you are stuck on that "comment deleted" page. I'd prefer to get redirected to the game page again as it is common (for me at least) to delete a comment and just after that add another comments with typos corrected and more info or whatelse I want to edit.


Can we have spoiler tags to hide some text in game comments?

AGA

  • Adventure Game Aficionado
  • Administrator
  • ¡Qué alí­vio!
    • Lifetime Achievement Award Winner
    • AGA worked on one or more games that won an AGS Award!
    •  
    • AGA worked on one or more games that was nominated for an AGS Award!
Re: Bug reports & suggestions
« Reply #499 on: 16 Feb 2019, 17:49 »
when adding a comment on a game in the DB you get redirected to the game page afterwards again. When deleting a comment you are stuck on that "comment deleted" page. I'd prefer to get redirected to the game page again as it is common (for me at least) to delete a comment and just after that add another comments with typos corrected and more info or whatelse I want to edit.


Can we have spoiler tags to hide some text in game comments?

Both should work now.  Use [spoiler]text[/spoiler] to add a spoiler to game descriptions or comments.