AGS Development > Editor Development

AGS crashes when opening scripts

(1/3) > >>

krieghan:
I'm going through one of the tutorials, and am at the point where I'm trying to open a script for a hotspot.  AGS becomes non-responsive for a minute or two, and then gives back an error dialog:

Error: Non-negative number required.
Parameter name: count
Version: AGS 3.2.1.111

System.ArgumentOutOfRangeException: Non-negative number required.
Parameter name: count
   at System.Text.EncodingNLS.GetString(Byte[] bytes, Int32 index, Int32 count)
   at Scintilla.ScintillaControl.SendMessageD irect(UInt32 msg, IntPtr wParam, String& text, Int32 length)
   at Scintilla.ScintillaControl.SendMessageD irect(UInt32 msg, Int32 wParam, String& text)
   at Scintilla.ScintillaControl.GetText()
   at AGS.Editor.ScintillaWrapper.FindLineNum berForText(String text)
   at AGS.Editor.ScriptEditor.GetLineNumberFo rText(String text)
   at AGS.Editor.Components.BaseComponentWith Scripts.ZoomToCorrectPositionInScript(ScriptEditor editor, ZoomToFileEventArgs evArgs)
   at AGS.Editor.Components.RoomsComponent.GU IController_OnZoomToFile(ZoomToFileEventArgs evArgs)
   at AGS.Editor.GUIController.ZoomToFileHand ler.Invoke(ZoomToFileEventArgs evArgs)
   at AGS.Editor.GUIController.timer_Tick(Object sender, EventArgs e)
   at System.Windows.Forms.Timer.OnTick(EventArgs e)
   at System.Windows.Forms.Timer.TimerNativeW indow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callb ack(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I am using 64-bit Windows 7, AGS 3.2.1.  I encounter the same issue when opening scripts in any other context.  Has anyone encountered this before?

Cerno:
I had a "non-negative number" error recently, but for the heck of it I can't remember what I did to fix it.
From memory I think it was something like a missing bracket or closing string quote ("), or another form of incomplete command, but when trying to recreate something like it I get proper "bracket missing" errors and such.

Sorry I can't be of more help. If I remember anything more I'll let you know.
Could you try removing the hotspot code you created to check whether the error is connected to that code?

Crimson Wizard:
krieghan, is it acceptable for you to share either your script (that causes error), or whole project?
If yes, you could upload it to some file hosting website, so we could find out what's going on there.

krieghan:
It is indeed acceptable.  I ll put it up on Monday and post a link.  To be clear, though, I just started this project and haven't added any scripts yet.  AGS crashes for me when I try to edit any script.  I figured it might be related to some odd setup in my OS environment.  Nevertheless, I'll put the project up shortly.  Thanks.

krieghan:
I have uploaded my project to DropBox as a .tar archive.  Let me know if the link doesn't work for you.  Thanks for helping me out:

https://www.dropbox.com/s/maubh0xbjb7w7jg/test_game.tar

Navigation

[0] Message Index

[#] Next page

Go to full version