Jibble

Author Topic: Custom Icon problem  (Read 752 times)

Custom Icon problem
« on: 17 Jul 2015, 14:26 »
I'm totally stumped with adding a custom icon to my games.
I've followed the manual and read previous posts with similar subjects and nothing seems to work.
I've tried creating different icons with many different online icon editors/creators/converters. I've named these icons user.ico, USER.ICO, user and USER and placed them in the game's folder. But when I open the games in the editor and save them absolutely nothing happens. It always remains as a blue cup. I've checked the blue cup in windowed mode and tried compiling the project. There is always still a blue cup.
I've made sure they are 32x32. I'm using AGS 3.3 on windows 7.
Any ideas?

Edit: I've also tried setup.ico that is not doing anything either.
« Last Edit: 17 Jul 2015, 14:35 by Two Tales »

Khris

  • having to deal with what games are going through
    • Lifetime Achievement Award Winner
    • I can help with play testing
    • I can help with scripting
    • I can help with translating
    • Khris worked on a game that was nominated for an AGS Award!
Re: Custom Icon problem
« Reply #1 on: 17 Jul 2015, 14:42 »
I tested it and found that the first compile always resulted in an error
Spoiler: ShowHide
Unable to set EXE name/description: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
but the next one would work.
I tried this icon: https://dl.dropboxusercontent.com/u/995571/user.ico
Capitalization didn't matter.

One thing you should check is whether the file is actually named "user.ico" and not something like "user.ico.ico".
In the Windows folder settings, uncheck "hide extensions for known file names".

Re: Custom Icon problem
« Reply #2 on: 17 Jul 2015, 16:15 »
Khris:

I tried the same icon that you tested, saved and compiled the project and it worked!
I then replaced the icon with the one I was trying to use, saved and compiled again and now mine works.
I'm still confused as to why any icon I tried before that didn't work but at least it is working now.

Confused but grateful, thank you.