Author Topic: Strange problem with regions - SOLVED  (Read 399 times)


  • Posts: 49
Strange problem with regions - SOLVED
« on: 16 Dec 2017, 13:04 »
Hi everyone,

I wonder if you can help me with a major snag I've come across whilst developing my game. This seems a better place to post this than beginner technical, as although I am indeed a beginner I can see no rhyme or reason as to why my problem keeps happening.

Whilst in the third area of my game, the path to the next area is blocked. Once the blockage is cleared by solving the puzzle, a walkable area is enabled that allows you to go to the next area. On this area I have two regions, one below the other. The first region you reach is simply there to darken the player, and the second one is for the room transition to room 4. All works fine initially, path is cleared, walkable area is enabled, player can walk onto the region and into the next area. All good.

The problem arises when you walk back into the room. I have tested this and you can immediately go back to room 4 if you wish by clicking onto the relevant area on the path. The transition happens as expected, fade out player in room 4. The issue is that if you interact with anything in room 3 once you have gone back from room 4, you simply cannot walk onto the region that transitions you to the next room. You can walk onto the one below it, which darkens the player and is also deep onto the enabled walkable area I mentioned above, but you simply cant walk onto the region that enables you to transition to room 4.

There is zero code that would disable that region, it's on constantly, just unreachable until you solve the puzzle and enable the walkable area. I have tested this further by giving the player a colour tint as they walk onto the regions, and as expected the player just can't get onto the region on which the player transitions.

I can't think of any reason why this is happening. Has anyone else experienced anything similar? Any and all help and suggestions greatly appreciated.

(Additional info: You can also interact with any item you wish before you leave Room 3 for the first time, and the regions and walkable areas perform exactly as expected. This problem only arises once you re-enter room 3 from room 4 and do anything at all other that walk straight back into room 4. Is my game maybe corrupted in some way?)
« Last Edit: 16 Dec 2017, 13:57 by LimboJimbo84 »


  • Posts: 10,691
  • having to deal with what games are going through
    • Lifetime Achievement Award Winner
    • I can help with play testing
    • I can help with scripting
    • I can help with translating
    • Khris worked on a game that was nominated for an AGS Award!
Re: Strange problem with regions
« Reply #1 on: 16 Dec 2017, 13:29 »
When you say, "you can't walk onto the region", are you saying the player stops before reaching it? As in, their path is blocked? Because if that's the case I'd wager the issue isn't with the region.

Have you tried pressing Ctrl+A during the game to check the walkable areas? Is it possible something else is blocking the player? Like for instance an invisible character?

(I'm 99% certain this will turn out to be a simple user error, as opposed to bug / corruption, because that's the reason 99% of the time)


  • Posts: 49
Re: Strange problem with regions - SOLVED
« Reply #2 on: 16 Dec 2017, 13:59 »
Thanks for your help Khris, I discovered that the problem was indeed with an invisible character which I was transitioning between rooms with the player. Once I stopped transitioning him back into room 3 from room 4 (which would have been a good idea seeing as he wasnt needed anymore in room 3 anyway), it has solved the problem.