Jibble

Author Topic: Missing Apostrophes  (Read 228 times)

Frodo

  • Welcome down... to my Planet Hell!
    • Frodo worked on one or more games that won an AGS Award!
    •  
    • Frodo worked on one or more games that was nominated for an AGS Award!
Missing Apostrophes
« on: 16 May 2019, 14:12 »
I'm having a problem with the dialogues. 

When I 'build' dialogues in the editor, everything looks fine.
But then, when I Run the game to test it, the apostrphes (') are missing.
See Options 1 and 3 in the screenshot. 



But it's not with every dialogue line.  Just some of them.
Why is this happening?  And how do I fix it? 

Thanks.

Re: Missing Apostrophes
« Reply #1 on: 16 May 2019, 14:40 »
Are you sure the apostrophes are present in the font you are using?

Slasher

  • slasher
    • I can help with AGS tutoring
    • Lifetime Achievement Award Winner
    • I can help with scripting
    • I can help with story design
    • Slasher worked on one or more games that won an AGS Award!
    •  
    • Slasher worked on one or more games that was nominated for an AGS Award!
Re: Missing Apostrophes
« Reply #2 on: 16 May 2019, 14:58 »
Does the font you use actually have the ' symbol?

Have you copied text from elsewhere outside ags?

Re: Missing Apostrophes
« Reply #3 on: 16 May 2019, 15:02 »
Ok, here are the possible symbols for the apostrophes:

Code: Adventure Game Studio
  1. player.Say("1. don`t");
  2. player.Say("2. don´t");
  3. player.Say("3. don't");
  4. player.Say("4. don’t");

My guess is you only have some of those symbols and not the other, and this is why it works sometimes and sometimes not. I have this when I copy paste text from LibreOffice (uses ’ instead of ').

Khris

  • partook in silencing a crtitc despite facts
    • Lifetime Achievement Award Winner
    • I can help with play testing
    • I can help with scripting
    • I can help with translating
    • Khris worked on one or more games that was nominated for an AGS Award!
Re: Missing Apostrophes
« Reply #4 on: 16 May 2019, 15:21 »
1 and 2 are accents, and 4 is the beautified version used by word processors. Only 3 is a proper ASCII apostrophe, or single quote.
The default font supports 1 and 3, and shows a question mark for the other two.
Fail at Floaty Rog' now!  still having to deal with what games are going through

Frodo

  • Welcome down... to my Planet Hell!
    • Frodo worked on one or more games that won an AGS Award!
    •  
    • Frodo worked on one or more games that was nominated for an AGS Award!
Re: Missing Apostrophes
« Reply #5 on: 16 May 2019, 15:50 »
Ahh, I hadn't noticed all the different versions of the ('). 

Yes, I had been writing it in Word, and then copy & pasting into AGS.  Word must be using a funny (')
I went through it all again, and re-did the (') directly into AGS, and it works now!

Who'd have thought a tiny little symbol could cause so much hassle?

Thanks everyone.   :smiley:

Re: Missing Apostrophes
« Reply #6 on: 16 May 2019, 19:12 »
Copying text from editors like "Word" may be tricky, there are other symbols, such as "long dash", which are not found in common ags fonts.