Author Topic: AGS windowed setting broken (on my end)?  (Read 87 times)

Click'd

    • Click'd worked on one or more games that won an AGS Award!
    •  
    • Click'd worked on one or more games that was nominated for an AGS Award!
AGS windowed setting broken (on my end)?
« on: 11 Oct 2019, 09:08 »
Something seems to have happened between me last playing "Sumatra - Fate of Yandi" and "The Terrible Old Man". I check the box for windowed mode, start the game, and a window appears for a fraction of a second, only to change into fullscreen immediately. And not just in these two, but all AGS games I have on Steam. Doesn't matter either if I select Direct3D, DirectDraw, or OpenGL.

I guess it either has to do with my graphics driver settings (which I didn't touch in the meantime) or any one or combinations of programs I have installed (no idea what to look for).

I can run other games based on a multitude of engines just fine windowed, so I don't think my drivers are forcing it.

EDIT: The Charnel House Trilogy refuses outright to start windowed

---------------------------
Adventure Game Studio
---------------------------
There was a problem initializing graphics mode 320 x 200 (32-bit) with game size 320 x 200 and filter 'None'.
(Problem: 'This graphics mode is not supported')
Try to correct the problem, or seek help from the AGS homepage.

Possible causes:
* your graphics card drivers do not support this resolution. Run the game setup program and try the other resolution.
* the graphics driver you have selected does not work. Try switching between Direct3D and DirectDraw.
* the graphics filter you have selected does not work. Try another filter.
---------------------------
OK   
---------------------------
« Last Edit: 11 Oct 2019, 09:24 by Click'd »