Author Topic: Error message at build time when setting game's icon  (Read 264 times)

Monsieur OUXX

  • Mittens Vassal
  • Cavefish
  • Mittens Half Initiate
    • I can help with proof reading
    • I can help with translating
    • I can help with voice acting
    • Monsieur OUXX worked on one or more games that won an AGS Award!
    •  
    • Monsieur OUXX worked on one or more games that was nominated for an AGS Award!
(AGS 3.4.1 Patch 4)

I've tried two icons in the game directory, named USER.ico (links below)
32x32 icon : https://www.dropbox.com/s/tyvn86ywe2g8bs6/USER.ico.old?dl=0
128x128 icon : https://www.dropbox.com/s/447oc7lat9cmlrt/USER.ico?dl=0

the overall building process succeeds but the "icon" step fails with an error message.

At first I thought this was a permission issue, but it fails even with "run as admin".
I've also tried the tool "resource hacker" to replace the icon directly in the EXE but it's not great, it doesn't replace the tiny icon seen in Windows Explorer.

 

Cassiebsg

  • Cavefish
  • Fleeing the Cylon tyrrany...
    • Cassiebsg worked on one or more games that won an AGS Award!
    •  
    • Cassiebsg worked on one or more games that was nominated for an AGS Award!
Re: Error message at build time when setting game's icon
« Reply #1 on: 04 Jan 2020, 02:59 »
This is very odd. I just downloaded your ico files, moved it to the game folder, compiled all files and the compiled game now has the icon.
Sorry I didn't thought of trying this earlier.  :-[

Are you sure you copied it o the project main folder? The one where all the game files are?
There are those who believe that life here began out there...

Re: Error message at build time when setting game's icon
« Reply #2 on: 04 Jan 2020, 08:33 »
There's a known issue that AGS may fail adding resources to exe if you have Compiled folder opened in windows explorer at the same time. May this be the case?