Author Topic: Music does not play but stutters..  (Read 128 times)

Slasher

  • slasher
    • I can help with AGS tutoring
    •  
    • I can help with scripting
    •  
    • I can help with story design
    •  
    • Slasher worked on a game that was nominated for an AGS Award!
Music does not play but stutters..
« on: 17 May 2018, 10:36 »
Hi

I'm not sure why this is suddenly happening...

Music starts for 1 second and then the whole music tracks stutter without actually playing...

Anyone possibilities as to why and a solution?

AGS Editor .NET (Build 3.4.0.14)


Re: Music does not play but stutters..
« Reply #1 on: 17 May 2018, 10:57 »
I think anyone who can help will need more information.

What script commands have you used, and where?

What is the format of the song you are trying to play, and it's filename?

How long is the track? (In case it's so long AGS can't handle it, is that a thing??)

When you say music tracks, how many tracks are you trying to play at the same time?

Slasher

  • slasher
    • I can help with AGS tutoring
    •  
    • I can help with scripting
    •  
    • I can help with story design
    •  
    • Slasher worked on a game that was nominated for an AGS Award!
Re: Music does not play but stutters..
« Reply #2 on: 17 May 2018, 11:15 »
Hi

The script commands are ok seeing as they were working..
Format are .ogg as ever.
The Tracks are no longer that 38 seconds looped.
Only i piece of music at a time.

As I said, they were ok and now they are not..

I even emptied out the audio cache folder and did a rebuild.

Also, I stopped music play at start but it still starts, or tries!

EDIT:
I found these 2 no longer used buttons in game start

 Button13.Animate(15, 0, 4, eRepeat);
 Button15.Animate(15, 0, 4, eRepeat);

Comemented out and all back on track (nod)


« Last Edit: 17 May 2018, 14:51 by Slasher »