Author Topic: Bug: SkipUntilCharacterStops not working correctly (Fixed)  (Read 637 times)

SkipUntilCharacterStops is called with a doubleclick and a sound is played when you do, so this should be working:

When no other character is in the room or he is not moving or animating, EGO jumps to the mouse coordinates immediately, EVERY TIME, as it should be.

But when other characters move or just their idle animation plays, SkipUntilCharacterStops doesn't seem to work SOMETIMES and EGO just walks to the mouse position.

Check out this demo.

Double-click around the room several times.
Then try again after you removed the line from repeatedly_execute and reset GUY's idle animation to 0.
Notice the difference.

The manual for SkipUntilCharacterStops states: "Skips through the game until the specified character stops walking, a blocking script runs, or a message box is displayed."
There aren't any blocking calls in this demo, are there?

EDIT: Fixed since 2.61 Beta 6.
« Last Edit: 03 May 2004, 20:53 by strazer »


  • Creator of AGS
  • Administrator
  • Mittens King
  • I sense danger.
    • Lifetime Achievement Award Winner
    • Pumaman worked on one or more games that won an AGS Award!
    • Pumaman worked on one or more games that was nominated for an AGS Award!
Re:SkipUntilCharacterStops problem
« Reply #1 on: 13 Apr 2004, 19:29 »
Erm oops, it currently behaves like SkipUntilAnyCharacterStops ;)

Thanks for spotting it and making that demo game, it really helped me find the problem.

I'll get it fixed. :)