Author Topic: TRA compile problem in 3.4.1  (Read 1194 times)


  • Guest
TRA compile problem in 3.4.1
« on: 07 Dec 2017, 22:08 »
Hi CW, I'm getting this error trying to run / compile a game, I don't really know what it means, the corresponding TRS translation file is present, and the filename it's suggesting English.tra - well I thought AGS would be writing that file on compile, not seeking it. Maybe the following error says something to you. Not so sure how to proceed so any advice is appreciated, thank you! (btw it compiles fine under 3.3.4, and I think the same thing happens in 3.4.0. I've tried compiling to Windows only and Windows + Linux and it occurs, but as I say, cannot run the game either with the same error being displayed and right clicking on translations in the editor then "compile" (the translation) also presents this error). Thank you for looking!

Error: Could not find a part of the path 'C:\Game Work\Tales_RC1\Tales Linux Steam\Tales\Compiled\Data\English.tra'.
Version: AGS

System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\Game Work\Tales_RC1\Tales Linux Steam\Tales\Compiled\Data\English.tra'.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access)
   at AGS.Editor.Components.TranslationsCompo nent.CompileTranslation(Translation translation, CompileMessages errors)
   at AGS.Editor.Components.TranslationsCompo nent.AGSEditor_PreCompileGame(PreCompileGameEventArgs evArgs)
   at AGS.Editor.AGSEditor.PreCompileGameHand ler.Invoke(PreCompileGameEventArgs evArgs)
   at AGS.Editor.AGSEditor.CompileGame(Boolean forceRebuild, Boolean createMiniExeForDebug)
   at AGS.Editor.Components.BuildCommandsComp onent.TestGame(Boolean withDebugger)
   at AGS.Editor.Components.BuildCommandsComp onent.CommandClick(String controlID)
   at AGS.Editor.ToolBarManager.ToolbarEventH andler(Object sender, EventArgs e)
   at System.Windows.Forms.ToolStripItem.Rais eEvent(Object key, EventArgs e)
   at System.Windows.Forms.ToolStripButton.On Click(EventArgs e)
   at System.Windows.Forms.ToolStripItem.Hand leClick(EventArgs e)
   at System.Windows.Forms.ToolStripItem.Hand leMouseUp(MouseEventArgs e)
   at System.Windows.Forms.ToolStripItem.Fire EventInteractive(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStripItem.Fire Event(EventArgs e, ToolStripItemEventType met)
   at System.Windows.Forms.ToolStrip.OnMouseU p(MouseEventArgs mea)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl. WndProc(Message& m)
   at System.Windows.Forms.ToolStrip.WndProc(Message& m)
   at AGS.Editor.ToolStripExtended.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNat iveWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNat iveWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callb ack(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
« Last Edit: 07 Dec 2017, 22:11 by MJL »

Re: TRA compile problem in 3.4.1
« Reply #1 on: 07 Dec 2017, 22:31 »
Hi, this was reported recently, supposedly fixed with the temp build:

Basically, this is because intermediate output is now stored in the "Compiled/Data" contrary to just "Compiled", but "Data" subfolder was created a bit late.


  • Guest
Re: TRA compile problem in 3.4.1
« Reply #2 on: 07 Dec 2017, 22:33 »
Neato thank you, sounds good to me so I'll give that version a go asap if that is the current fix, thanks for that!

Re: TRA compile problem in 3.4.1
« Reply #3 on: 21 Feb 2018, 16:03 »
Was fixed in 3.4.1.