Author Topic: One of the rooms in my game won't load anymore?!  (Read 485 times)

Hey guys,

I'm freaking out a little right now because I just noticed one of the rooms in my game won't load anymore.
It throws an unhandled error in 4.3.2.1 (as well as 4.3.3)...and completely crashes 4.5.0 alpha 10.

This is the error I'm getting:

Quote
Error: LoadRoom: unexpected end of block 6 in in 'room3.crm'
Version: AGS 3.4.2.1

AGS.Types.AGSEditorException: LoadRoom: unexpected end of block 6 in in 'room3.crm'
   at ThrowManagedException(SByte* message)
   at load_room_file(SByte* )
   at load_crm_file(UnloadedRoom roomToLoad)
   at AGS.Editor.Components.RoomsComponent.Lo adNewRoomIntoMemory(UnloadedRoom newRoom, CompileMessages errors)
   at AGS.Editor.Components.RoomsComponent.Lo adDifferentRoom(UnloadedRoom newRoom)
   at AGS.Editor.Components.RoomsComponent.Lo adRoom(String controlID)
   at AGS.Editor.Components.RoomsComponent.It emCommandClick(String controlID)
   at AGS.Editor.Components.BaseComponentWith Folders`2.CommandClick(String controlID)
   at AGS.Editor.ProjectTree.ProcessClickOnNo de(String nodeID, MouseButtons button)
   at AGS.Editor.ProjectTree.projectTree_Node MouseDoubleClick(Object sender, TreeNodeMouseClickEventArgs e)
   at System.Windows.Forms.TreeView.OnNodeMou seDoubleClick(TreeNodeMouseClickEventArgs e)
   at System.Windows.Forms.TreeView.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNat iveWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNat iveWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callb ack(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


I really hope somebody can help me figure this out...all the other rooms are loading fine.

cheers

Crimson Wizard

  • Local Moderator
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    • Lifetime Achievement Award Winner
    • Crimson Wizard worked on one or more games that won an AGS Award!
    •  
    • Crimson Wizard worked on one or more games that was nominated for an AGS Award!
Re: One of the rooms in my game won't load anymore?!
« Reply #1 on: 11 Feb 2019, 17:34 »
I'm freaking out a little right now because I just noticed one of the rooms in my game won't load anymore.
It throws an unhandled error in 4.3.2.1 (as well as 4.3.3)...and completely crashes 4.5.0 alpha 10.

I assume you mean versions 3.4.2 and 3.5.0? (Don't know what 4.3.3 may mean). Have you ever opened this room in a different editor (not the one you are usually working in)?
For information, "Block 6" stores additional room backgrounds.
Can you send me this room (*.crm) file to see what is wrong there?
« Last Edit: 11 Feb 2019, 17:37 by Crimson Wizard »

Re: One of the rooms in my game won't load anymore?!
« Reply #2 on: 12 Feb 2019, 08:03 »
I assume you mean versions 3.4.2 and 3.5.0? (Don't know what 4.3.3 may mean). Have you ever opened this room in a different editor (not the one you are usually working in)?
For information, "Block 6" stores additional room backgrounds.
Can you send me this room (*.crm) file to see what is wrong there?

Hey,
sorry yeah, I meant 3.4.2(.1?) and 3.5.0 of course...I also tried 3.4.3, the latest stable release. No dice.
I'm pretty careful when switching AGS versions. Pretty sure I didn't open it in any other version directly (I make a backup and open that when I try out a newer AGS). I've been sticking to 3.4.2.1 for quite a while now because the newer alphas I tried didn't play nice with the dialogue designer plugin.
I went back yesterday and replaced the room files with backups until I found one that still worked. Luckily I didn't touch the room much, so there won't be a lot of work to be redone.
I guess the room file(s) must have gotten corrupted "somehow"?...No Idea. Kinda scrary. Guess I'll do my snapshots/backups more frequently from now on.

By the way...if I switch from 3.4.2.1 to the latest stable 3.4.3, would that be likely cause any problems? Since 3.4.2.1 is actually an early alpha which is now called 3.5.0, right? ??? Should I rather stick with the alpha releases?

Thanks again

Crimson Wizard

  • Local Moderator
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    • Lifetime Achievement Award Winner
    • Crimson Wizard worked on one or more games that won an AGS Award!
    •  
    • Crimson Wizard worked on one or more games that was nominated for an AGS Award!
Re: One of the rooms in my game won't load anymore?!
« Reply #3 on: 12 Feb 2019, 10:21 »
I've been sticking to 3.4.2.1 for quite a while now because the newer alphas I tried didn't play nice with the dialogue designer plugin.

What was the problem with dialogue designer plugin? Unless you report problems we may easily miss them.

By the way...if I switch from 3.4.2.1 to the latest stable 3.4.3, would that be likely cause any problems? Since 3.4.2.1 is actually an early alpha which is now called 3.5.0, right? ??? Should I rather stick with the alpha releases?

You should not be able to switch from 3.4.2 to 3.4.3, because they are not compatible. 3.4.2 version was cancelled and is now called 3.5.0, so you may only upgrade to 3.5.0. Sorry for confusion.

I guess the room file(s) must have gotten corrupted "somehow"?...No Idea. Kinda scrary. Guess I'll do my snapshots/backups more frequently from now on.

Do you still have the corrupted file and if so could you still send it to me? Sometimes we may find errors by analysing these.

Re: One of the rooms in my game won't load anymore?!
« Reply #4 on: 14 Feb 2019, 15:06 »
Quote
What was the problem with dialogue designer plugin? Unless you report problems we may easily miss them.

I can't remember which version of the alpha it was, but the dialogue designer plugin would give me some kind of error. Seems to be fine in 3.5.0 though...

Quote
You should not be able to switch from 3.4.2 to 3.4.3, because they are not compatible. 3.4.2 version was cancelled and is now called 3.5.0, so you may only upgrade to 3.5.0. Sorry for confusion.

Good to know...because I could load the game without any apparent problems in 3.4.3...:D Hope I didn't mess anything else up now, but everything seems fine so far.

I PM'd you about the file...

Thanks again:)

Crimson Wizard

  • Local Moderator
    • Best Innovation Award Winner 2013, for spearheading the AGS 3.3.0 project
    • Lifetime Achievement Award Winner
    • Crimson Wizard worked on one or more games that won an AGS Award!
    •  
    • Crimson Wizard worked on one or more games that was nominated for an AGS Award!
Re: One of the rooms in my game won't load anymore?!
« Reply #5 on: 14 Feb 2019, 15:25 »
Quote
You should not be able to switch from 3.4.2 to 3.4.3, because they are not compatible. 3.4.2 version was cancelled and is now called 3.5.0, so you may only upgrade to 3.5.0. Sorry for confusion.

Good to know...because I could load the game without any apparent problems in 3.4.3...:D Hope I didn't mess anything else up now, but everything seems fine so far.

Ummmm.... that sounds weird. Are you sure the game was not originally made in 3.4.1 (not 3.4.2)?
On the other hand, maybe the version you were using did not have any breaking changes to game format yet.
Anyway it's good if that works.

Re: One of the rooms in my game won't load anymore?!
« Reply #6 on: 27 Feb 2019, 09:40 »
Quote
Ummmm.... that sounds weird. Are you sure the game was not originally made in 3.4.1 (not 3.4.2)?
On the other hand, maybe the version you were using did not have any breaking changes to game format yet.
Anyway it's good if that works.

Nope, pretty sure the last version I used before was 3.4.2.1 (beta)...and it loaded up fine in 3.4.3 (not even a warning message). But I switched to 3.5.0 now to be safe...also I remembered that I had to switch to the beta because of the new pathfinding, which fixed a problem in my game, anyway  :-D