Edge of Reality: All Spoilers All the Time

Started by Endocore, Fri 06/04/2012 19:30:41

Previous topic - Next topic


Stuck in the insanely twisted yet ineffably entertaining game Edge of Reality?  Tired of fruitlessly scouring the internet for a walkthrough or walkthru of the AGS game Edge of Reality by Blake Speers?  Sick of posting questions about the game Edge of Reality to internet forums and getting absolutely no response whatsoever despite weeks of waiting?

You've found the solution!

Below is what I consider a full walkthrough for Edge of Reality.  The game is large and complex, so perhaps a few odd matters are left out in what follows.  However, the detailed walkthru below shows how to obtain both major endings for the game.

Before reading on, take a moment to consider whether you really need or want a full walkthrough for the Reality on the Norm (RON or RotN) game Edge of Reality by Blake Speers.  The game offers a lot of content, and is very difficult.  Yet despite several utterly irrational and completely unfair puzzles near the end, ninety-five percent of the game is in my opinion designed with notable attention to fairness and offering the player a sporting chance. 

I didn't have a walkthrough or any help whatsoever in any form from anyone, yet I was able to complete the game-- so maybe you can use me as a role model and try to beat the game yourself since I've proved this can be done.  You'll probably feel much better in the end if tackle the game alone, as you'll attain a considerable achievement that will boost your self-esteem.  If you'd like to conquer the game the honest way, I'm confident anyone can do so if they keep the following principles in mind:

1)  If you have a job, demand a month's paid leave or quit.  If choosing the latter option, take consolation in the fact that unless you are The Man, most jobs working for The Man are so categorically lousy that you should later easily be able to find an equally sucky job working for somebody who is just as big an incorrigible, lying, ignorant, incompetent jerk as your previous master.  Solving Edge of Reality isn't for slackers, though-- you'll need a strong work ethic.  Plan to do absolutely positively nothing else except play the game for twelve to fourteen hours a day every day for at least three or four weeks straight.  Since you'll be busy with this challenging game, go to the grocery store beforehand and stock up on essential items like coffee, cigarettes, and liquor.  Though everyone except nitwitted statist weenies understands a man can not merely survive but positively thrive subsisting solely on these three essential staples for decades, you may also want to buy some food-- but only because the game is mostly about food, getting food, preparing food, eating food, and so forth.  Your appetite will be very stimulated because you'll be thinking about food the whole time you play.

2)  Read the documentation that comes with the game.  The author there provides many clever hints in plain sight.  The three most important things the author has to say are:

Quote from: Blake Speers
3.  Assume the game actually works.  I tested it a lot.  A LOT.
3.  There is one key to winning the game: Figuring out how to solve the puzzles and then solving them.  Also, walking from one place to another.
6.  Adventure-game logic is not the same as regular logic.  Think more oddly.

Though I had my doubts many times, all three of these statements are quite true and are all the hints you really need to solve the game, especially if you keep in mind at all times the famous saying of that uncannily smart fella from Queen Victoria's day:

Quote from: Sherlock Holmes
How often have I said to you that when you have eliminated the impossible, whatever remains, however improbable, must be the truth?

3)  Exercise your index finger daily to gain endurance in preparation for playing Edge of Reality-- in practice, most of your time will be spent feverishly clicking all over the screen as you engage in countless pixel hunts and trying randomly to combine one item with another.

4)  Dr. Emeritus, one of the characters in the game who is a keenly intelligent professor dude, says at one point:

Quote from: Emeritus
I daresay something terrible is happening all about us, something far more dreadful than anyone may have feared.  We must consider breaking fourth walls and opening ourselves to potentialities far removed from the confines of our mundane, narrow perspectives...

He doesn't say it exactly that way, since the game is rife with spelling and grammar errors as well as frequently poor English syntax.  Maybe the author got frustrated after working on the game for nine years and was so eager to release it he forgot to use a spellchecker.  However, I think if Emeritus could have written his own lines his words would have appeared just like I noted.

In any case, the point here is-- the game is very hard.  I suspect this why no other walkthrough exists despite the game being released years ago; everyone else simply gave up instead of fearlessly forging forever forward as I did.  Though most of the puzzles are logical and integral to the story, some of the later situations Mika Huy faces are flat-out unfair and nonsensical.  Therefore, to solve this game I found that I occasionally had to quite literally think outside the box as Dr. Emeritus suggests.  In one case I needed a sound-recording program to study certain sounds in the game.  In two other cases, I had to use a hex-editor to search through all the game's text stored in the exe to find the solution to a puzzle.  Both kinds of programs are very common, but if you don't already have them two freeware programs I frequently use are Audacity (sound editor) and Frhed (hex editor).

5)  If Step Four seems like cheating to you, let's be honest: why are you here searching for a walkthrough for Edge of Reality, anyway?  However, if you'd rather skip Step Four and have only the bare minimum of absolutely required hints to puzzles no one could ever solve on their own except through blind luck, keep these ideas on a sheet of paper taped to your monitor:

--The game is highly prone to frequent CTDs whenever using a telephone or playing the half-dozen minigames.  Save your game frequently.
--Mika has serious trouble guiding a certain turgid pole into a particular gaping orifice.  The whole affair is merely a pixel hunt-- if you keep this in mind from the start, you'll figure it out sooner than later.
--If you're having trouble luring a certain dancing phenomenon somewhere, try not doing anything once; when the game automatically restarts the scene, the enemy will respawn farther away and you'll have more freedom of maneuver.  Furthermore if he turns invisible (a bug), just go back to where you found him the first time and talk to him again to restart the sequence of events.
--To talk to the King, randomly click around the area to left of his feet.  Don't use the Teleporter there, either-- the game will crash in all cases.
--Nope, neither green spot on a wall does anything important-- so don't waste your time.
--Put the stupid mask on BEFORE, PRIOR TO, AND IN ADVANCE OF going there.  This means one particular time when you arrive in a certain area, if you're not already wearing the mask you'll never ever finish the game with the best ending and will likely go bonkers trying to figure out what you missed.  In many cases during gameplay Mika can't even walk around while wearing the mask, so to accomplish this unintuitive result you'll have to set things up where she can wear the mask and then just click on something to leave the screen rather than try walking to an exit.  Since solving this puzzle both intrinsically demands knowledge gained by the player in retrospect which could not possibly be suspected by the player-character at the time it all goes down and breaks sharply with otherwise standard interface conventions the player has previously learned, this puzzle is ONTOLOGICALLY UNFAIR and in violation of the Nelson Act of 1995.  Furthermore if you're able, just leave the mask on until you clearly no longer need it-- you'll know when.
--A certain disembodied head doesn't like eldritch refrigerator magnets.  However outrageous, facts is facts.  Perhaps the issue wouldn't be so piquant if the player had more than a few seconds to react after a lengthy cutscene during which the game cannot be saved, with failure meaning the player-character's doom and a reloaded save to spend another five minutes doing the whole thing over-- twenty or thirty times.
--Coral plus Dove White equals Pink.  Either the author's monitor was not properly calibrated, or in whatever odd locale the author lives "Purple" is apparently referred to in common parlance as "Pink."  Among other things I'm a graphic artist, so I know all kinds of technical info about both colors and keeping my monitor calibrated-- therefore I am eminently qualified to point out that purple is not pink, that fuchsia is quite distinct from heliotrope, and that red-saturated amber plus white does not make any of these.  However, if you want to beat the game you'll have to leave aside quaint conventions like "the color wheel."

I enjoyed this game very much, and am convinced almost everyone who plays beyond the first chapter (namely, the original demo material) will feel likewise.  Just keep at it, and stay sharply focused on one matter at a time.  Though I've previously thought quite poorly of the "surreal" styled RON games (many of which seem to be wantonly hurled crude insults rather than sincere efforts at providing anyone except their authors entertainment) from which Edge of Reality draws at least some inspiration and I have preferred more traditionally styled games such as "Purity of the Surf" or "The Postman Only Dies Once," after extended play I now consider the full version of Edge of Reality among my favorite RON episodes.


If pondering the above notions hasn't helped or you just want the walkthrough already, we'll begin.  Because my comments exceed the maximum character limit for any individual posting, I was forced to split up the remainder into the several replies to myself that follow.

All compass directions are relative to the player-character's current location:

East = right edge of screen
West = left edge of screen
North = top of screen
South = bottom of screen




Get the camera.  Touch the desk to get the scissors.  Touch the trashcan to get a copy of yesterday's paper.  Look at the paper in your inventory, then use the scissors on the paper screen to obtain a bus pass.  Leave the office, and watch the scene with Elandra by Davy's grave.  Next is a scene at the Fortune Teller's, who gives Mika a fridge magnet.


The bridge washed out, so Mika will have to improvise to cross the river and get to town.  Go west.

Execution Site

Touch the red box to get a mask and a nail.  Talk to the executioner to mention the rope looks useful.  Talk to the mime and the executioner about other things if you like.  Go west.

Outside Davy's House

Carefully talk to Elandra, choosing only the options:

--"Why are you standing here?
--"You can't mourn forever."
--"I know I can't help you."

After the conversation ends, click to talk with Elandra again and she'll give you some modeling glue.  Walk behind the house and west to get a power-up.  Leave the area by going east and return to the riverbank.


Walk toward the clump of buildings in the top left hand corner and choose "Go to Downtown Core."

Trite Corp Entrance

Get the broken bottle.  Walk up a bit past where the bottle was and take the sky, which is helpful if you'd like to see the in-game Official Hints provided by the author of the game.  Head south to return to the riverbank ("hicksville").


Use the bottle on the river, and then use the bottle on the mask.  Return to the Trite Corp Entrance and go east to enter the alley.  Talk to whatsisname, then touch the door to enter the laser stairwell.

Laser Stairwell

Take the fire extinguisher.  Use the mask on the laser beams.  Leave by going east.

Trite Corp Alley

Wear the mask by using it on Mika.  Use the glue on the microwave.  Touch Mika with the hand icon and she'll take the mask off.  Return to the Execution Site.

Execution Site

Touch the platform under the executioner to get a loose board.  Use the glue on the part of the platform under the mime, then talk to the executioner.  Take the rope and go east.


Use the rope on the board.  Use the board on the rocks by the fortune teller's tent.  Go south into town.  Keep going south until you get to Main Street.

Main Street

Get the glass from the window of the post office.  Head west into the Bum's alley.

Bum's Alley

Use the nail on the jukebox to get some coins.  Go east and enter the last building on the east side of Main street, which is Mika's apartment building.

Apartment Ground Floor

Talk to Habib about the thermostat and being grounded.  Go up the stairs, and enter the door to the west to enter Mika's home.

Mika's Apartment

Get the scraper, the sparkles, and the underwear.  You'll have to put the underwear on eventually, so there's no reason not to wear them now by using them on Mika so she'll be ready later.  Go back to Main street and enter Scid's bar along the western edge of the screen.


At a somewhat random point around this time, wherever Mika is she'll be visited by Vishnu who gives her a piece of string.  In my experience, this is the only truly helpful visit from Vishnu (several visits may occur later).


Take the spoons from the wall and a knife from the red box.  Use the knife on the yellow spot on the wall to get some mustard.  Leave.

Main Street

Walk all the way east to leave the screen.  Choose to go to the Church and Thakbor's.


Touch the church to pick it up and find a power-up.  After the first power-up, the game will say you get more here and there but only one ever appears in your inventory.  Leave by going east.

Thakbor's House

Read the note by the door.  Get the bottle of oil from the window.  Touch the bush in the southeast to get a power-up.  Go west, then west again to return to Main street.

Main Street

Go east again, this time to the Community Centre.

Community Centre

Get the hat, then go east.  Get the grenade, then talk to whatsisname about a job.  Keep talking about the job, and he'll give you a color chart.  Leave the area and travel back to the alley east of Trite Corp.  The next bit may seem convoluted, but it's the best way to play in order to minimize wandering about.

Trite Corp Alley

Wear the mask again and use the glue on the microwave again.  Take off the mask, and return to the ground floor of Mika's apartment building.

Apartment Ground Floor

Take the map from the toolbox, then return to Main Street and enter the Yahtzeebrand store.


Use your coins on the green paint machine and get a can of cadet blue paint.  Leave the store and return to the Trite Corp Entrance.

Trite Corp Entrance

Go west and enter the abandoned street area.  Take the metal pole between the buildings.  You can enter the alleyway where the metal pole is and go to a small secret area consisting of three rooms, but I think it's just for laughs and didn't find any real purpose to going there.  Travel to the Laser Stairwell.

Laser Stairwell

Use the broken glass on the laser beams.  Use the oil on the vent in the ceiling, then use the knife on the vent.  Touch the vent to enter The Maze.

The Maze

This area can be frustrating, but just follow the in-game instructions and the map you took from Habib's toolbox.  Your first objective is to meet Banana-Pickle man and get him to follow Mika.  After that, you want to walk over top of the "large button" near the red and blue target to dispatch Banana-Pickle man.  Touch his corpse for a banana peel and some cucumber preserves.  Use the banana peel on the metal pole in your inventory, and use your knife on the cucumber preserves to get chopped cucumber preserves.  Head down to the southern area of the maze where you'll see a big blue thing and a hole in the ground with a flashing yellow dot.  The next part is very frustrating, but just keep randomly clicking like a madman on the hole in the ground using your banana-laden metal pole.  Eventually you'll hit the right pixel and get a very ancient key.  From this spot, go east and then northeast to get to an area with a door.  Use the key you just found on the door, and then touch the white stuff blocking the doorway to enter the bathroom.


Take the toilet paper.  Talk to the guard to get a teleporter.  Look at the wall.  Note the telephone number on the toilet.  Technically we're ready to advance from Chapter One now, but to see all the game has to offer use the teleporter (choose setting 2) and return to the Riverbank.  Make your way from there back to Bum's Alley.

Bum's Alley

Use the toilet paper on the red butt to get some film for your camera.  Load the film into the camera.  Return to Mika's apartment.

Mika's Apartment

In the hallway just outside Mika's bachelorette pad is a picture of the Baron.  Use your camera to snap a photo of this picture.  Go inside the apartment.  Use your phone to call the telephone number (from the toilet) for a brief diversion.  Leave and make your way to the Execution Site.

Execution Site

Look at the UFO in the northeastern part of the screen, then try to walk there; agree to beam up.


Look around.  Get the Sword of +4 Dragonslaying and take a picture of the counter.  I found no difference in picture sizes, as none of them are worth much later-- but at Float Art a similar picture in landscape mode is required, so that's likely best here as well.  Return to Earth, then make your way back to the Bathroom inside Trite Corp (go to the Riverbank, use the teleporter, and choose location one).


Use the spraypaint on the wall, then use the grenade on the guard.  Reenter the bathroom.  Turn off the light switch, then take the lightbulb.  The game contains many dialogues where the author expounds his political and philosophical views.  One can usually tell where these rants will occur (for example if you chose "Long-Winded Debate on Capital Punishment" while earlier talking to the Executioner) so they can be avoided if you don't care for the author's opinions.  On the other hand if these dialogues interest you, an unexpected essay about that doofus Jacques Derrida may be viewed by clicking on the electrical wire after you take the light bulb here.  Go through the door to end this section of the game.  You'll play a venerable chicken next.

As the Chicken, go to the riverbank and enter the fortune teller's tent.  Take the red cloth and the crystal ball.  Return to Main Street.  Wear the red cloth by using it on yourself and enter Scid's.  Take the janitor's wallet, then take off the cloth by touching yourself.  Go the the Church.


Talk to the priestess using all conversation options.  When the chat is over, talk to her again and ask about the gift to receive some candles.  Go the the Yahtzeebrand.


Touch the metal ladder to buy it, then leave.

Main Street

Use the ladder on the roof near Scid's.  Use the candles on the ladder.  Touch the ladder to ascend and end Chapter One.



After regaining control of Mika, take the Baron's finger on the chair to the right.  Use the broken bottle in your inventory on one of the ash-filled chairs.  Enter the bathroom, and use your teleporter to return to the riverbank.  Go south, and enter the Hospital after picking up a power-up lodged in the large hole in the sidewalk.


Go west and enter the hallway to the morgue.  Use the Baron's finger on the security scanner, and you'll be scanned.  The next part seems buggy to me.  Since you have the Baron's photo as well, Mika sometimes holds it up automatically and the door unlocks.  Other times, you'll have to use the Baron's photo on the scanner-- which will result in a message saying you failed fingerprint scanning, but after which Mika will hold up the photo and the door will unlock.  Other times, you have to just keep clicking on the scanner with the photo in your inventory.  After the door opens, go inside.


Take the bone.  Barely visible on the left edge of the screen, take the jar of cocktail weenies.  Go to the Yahtzeebrand.


Take the cup and the vacuum cleaner.  Use the bone on the pile of rubble and pick up the lemon.  Use the cup on the paint machine, choosing to paint it brown.  Go outside to Main Street.

Main Street

Pick up the crystal ball, then use the vacuum on the chicken's blood (don't panic afterward).  Either use the fire extinguisher on the fire or just talk to the fire and ask it to move away, revealing a box.  Touch the box twice to get two sets of cinnamon sticks; use your knife on these to get some ground cinnamon.  Talk to Death to find out what would make him comfortable so he'll remain on his coffee and donut break instead of going back to reaping souls.  While Death is standing there, the game seems buggy and you can really get yourself into trouble by clicking with the "talk" icon near but not on him (talking instead to the door for Scid's); Mika will be transported to the location where Chapter Four occurs.  If this happens you'll be stuck, so just restore a saved game and try again (hopefully you at the very least saved the game at the beginning of Chapter Two, right?).  Give Death the brown coffee cup, then enter Mika's apartment building.

Apartment Ground Floor

Use the thermostat several times to turn up the heat.  Once Mika says she can't turn it anymore, use the bone on it and Mika will say the room is hot enough to melt steel.  Enter the door on the left that was previously locked.

Rhoxanna's Apartment

Take the bun from the shelf.  Touch the television to watch it, and write down the phone number from the commercial.  You can eat the apple here or not, but I didn't notice any difference later either way.  Leave and go upstairs to Mika's apartment.

Mika's Apartment

Save the game as I found the next part sometimes buggy.  Dial 1-800-GIMMEGUNS on Mika's phone, and use the keypad to listen to the options in order.  Your objective is to win some shotgun shells by answering EXACTLY four or five questions right in the quiz-- if you answer more than five right you lose just the same as if you answered less than four correctly.  Some valid choices to win the prize are:

1.  Josef Stalin (counts as "correct")
2.  I seek the grail (counts as "incorrect")
3.  Abraham Lincoln carried a shotgun to every speech (incorrect)
4.  No law specifically prohibits guns (incorrect)
5.  If I was attacked by a werewolf (incorrect)
6.  Nine (correct)
7.  Bowling for Columbine (correct)
8,  Liberals hate democracy and spurn freedom (correct)
9.  Australia (incorrect)
10.  There's no toaster under the Lazy Susan (incorrect)

Return to Main Street and pick up your shotgun shells in front of the Post Office.  Try leaving to the east and choose to go to the Woods.  If Woods aren't offered as a destination, try wandering around a bit on a few maps until you can return here and get "Woods" as an option (seems slightly buggy).


Pick up the tire.  Combine the sparkles in your inventory with the tire.  Return to Main street.

Main Street

Give the sparkly-tire-donut to Death, prompting him to go relax.  Go to the Bum's Alley.

Bum's Alley

Pick up the two candles.  Smash the jukebox with the bone, prompting the appearance of Ricky Martin.  Return to Main Street.

Main Street

Light your candles with the fire, and go to Outside Davy's House.  Sometimes Vishnu appears on the way there, for no apparent reason and offering information you already know.

Outside Davy's House

Search the doormat to find a note, then use the note on Mika.  From screen that comes up showing the note, use the "look at" icon and click on each of the several paragraphs of the note to get lots of info (make sure you hear a "scored points" sound effect).  Put your candles on the doormat, then your BOWLer hat.  Put the cinnamon, oil, bottle with ashes, and vacuum full of blood in the hat.  Touch the door and choose "Mika" to enter.

Inside Davy's House

Pick up the sugar and the brown book on the bookshelf.  Inside your inventory, "look at" the book three times to learn three spells.  Use the sugar on your chopped cucumber preserves to make pickle relish.

I couldn't find any way to interact with the green spot on the wall either now or later-- so if this spot does something your game experience will be fuller than my own.

Return to Main Street.

Main Street

Inside the Yahtzeebrand, you should find an onion on the floor.  If not, try back later.  Use your knife on the onion after picking it up.  Head east and go to the School.


Use the "freezerman" spell on Mr. Naymeh and then use the "levitate" spell on Mika to go to the roof.  Take the shotgun from ice-cube Naymeh and load the shotgun with your ammo.  Return to the ground and search the rubble pile twice to get purple doll's head and a power-up.  Return to Bum's Alley.

Bum's Alley

In case your game crashes here, save now.  If you talk to Ricky Martin, you can play a minigame.  Otherwise, or when you're done, shoot him with your shotgun.  When he reforms himself and the game tells you to "RUN!" go east to Main Street.

Main Street

Ricky Martin should follow you here; if not, go back to the alley and talk to him.  Otherwise, your objective is to walk east toward the door to Mika's apartment building while avoiding close proximity to Ricky Martin.  However, you don't want to head straight to the door too quickly; if Martin falls too far behind you he may not follow you to the next area or might turn invisible (buggy).  Go back to the alley and talk to him again to reset the chase scene if that happens.

The point then is for Mika to get Ricky Martin to follow her inside her apartment building, where the thermostat is turned up high enough to melt steel but Mika is safe because of her insulated panties.  Click on the door to enter Mika's building and Martin perishes.  Return to Bum's Alley.

Bum's Alley

Use the levitate spell and go up to the top of the screen.  You should automatically enter Scid's through a hole in the roof.


Pick up the red cloth.  Mika seems like she wants to do something with the beer tap on the bar here, but I couldn't figure out what to do so whatever is supposed to happen was missed by me.  Pick up the cigar.  You'll be transported to Trite Corp.

Trite Corp Offices

Gower gives you a tongue depressor as his contribution to your quest.  Return to Bum's Alley.  As you pass through Main street, stop for a moment to put your cigar in the fire to get some more ashes.

Bum's Alley

Use the levitate spell, but stay low.  Click around with the hand icon until you pick up the wires from the jukebox-- since you're floating instead of grounded, you'll avoid electrocution.  Next is a timing puzzle.  Since the music is stopped, talk to the Bum.  At some point he'll take the gum out of his mouth and put the gum on the butt beside him.  You'll have a few seconds to grab the gum.  You have a minor option here-- the bum will start to whine, so if you like him then return the gum to him and he'll give you some putty.  Otherwise just keep the gum.  Either the gum or the putty will be used for a puzzle in the next chapter, and they are fully interchangeable in that case and disappear when used.

Return to Main street and go east, choosing the Woods as your destination.


Combine the wires from the jukebox with the lemon, then combine the light-bulb from the bathroom with the result-- giving you a lemon-powered lamp.  Use the lamp on the path to light the area.  There's an onion or something in the ground, but I couldn't find a way to interact with it.  Walk east a bit and look at the brown puddle.  Use the tongue depressor on the brown puddle to end Chapter Two.



Click on the red Cosby show sign during the cutscene to get another power-up.

After you regain control of Mika, talk to the Mayor and Cosby's sidekick.  Then combine the fridge magnet in your inventory with the lemon-lamp; the magnet will replace the bulb, giving you an electromagnet.  Use the electromagnet on Cosby's sidekick to get rid of him.  Pick up your teleporter and enter the bathroom.  Use your teleporter to return to the riverbank-- but note that after this, the teleporter won't work properly anymore (try it for a cutscene) so you'll not be able to return to Trite Corp.  From the riverbank, go to Main street and enter the Yahtzeebrand.


Use your paint can on the paint machine.  If the machine doesn't say something like "the can is already full and the machine empties the can," pick any color and try again; otherwise choose to fill the can halfway with "dove white."  Use the half-full can on the machine again and choose "coral."  Though fairly hokey, this mixture supposedly gives you a shade of "pink" you'll need later to solve what I consider one of the game's categorically unfair puzzles.  After going outside to Main Street, leave to the east choosing the Beach as your destination.


First go north toward the Lighthouse.


Talk to the farmer, exploring every possible dialogue option.  Eventually the farmer will give you some cheese.  Repeatedly use your "transform cheese" spell (inside your inventory) on this until you get some cheeze-whiz.  Another thing to note here is that although the photo Mika took in the UFO seems to be identical to something the farmer wants, he won't accept that particular version (before or after resizing, which we'll explore later).  The farmer also offers an optional minigame that is fun but very difficult.  In any case, go south to return to the beach.  In general, much of this chapter can be viewed as a long quest to get the farmer's sheep.


I never found a use for the parasol here; perhaps it's merely a clue, since as a pirate Hooky is also of course a sailor.  Anyway, use your putty (or gum, depending on what you chose to do with the Bum) on the boat, then use your spoons on the boat.  Ahoy, matey!  Head west out to sea.

Edge of Reality

Begin your maritime adventure by sailing all the way to the eastern edge of the map and then south; you should sail "over the edge" represented by the curled corner of the map.  Click on the ladder to debark, and go east.  Click once on the red valve and once on the blue valve, then return to your boat and sail north to the red dot labelled "Serpent Trench."

Serpent Trench

The sign on the right side of the screen mentions turning something-- namely, the valves we adjusted earlier that lower water levels and reveal the coral you should now see.  Click on the coral to debark Mika's boat.  Grab the blue sponge, the pink piece of coral, and the power-up, then get back in the boat and go to the area labelled "There might be Dragons here."

Dragons and More

Use the blue sponge on the "dragon," which is actually an oil spill, to get an oil-filled sponge.  Leave and go to the red dot representing "An Evil Castle."  Talk to the giant, using all dialogue options; he has trouble hearing.  Leave and go to the area called "A part of the ocean."

Float Art

Click on the dock to leave the boat, then on the door to enter the art gallery.  Look at the pink statue, then talk to the attendant and ask about it-- it's worth some money.  Tell him you'd like to buy the statue, and when he leaves to get the paperwork use the pink coral from your inventory on the statue to swap the two items.  When the attendant returns, just tell him you changed your mind and don't want to buy anything.


I discovered two partially overlapping paths through the remainder of the game, leading to different endings.  The initial play divergence is at this point, so save your game here to try both ways.  In general, "Option Path 1" is quicker but also less rewarding to play.  Option Path 1 offers less to do, with a lower score and fewer "bonus options" in the end-- but Option Path 1 is also much easier if you're playing the game for the first time and are trying to minimize your use of this walkthru and instead figure things out yourself.

Leave Float Art and sail to the area labelled "An Island."


Yahtzee is frustrating; there are only a few pixels to the left of his foot that can be used to talk to him, and the exact hotspot seems to change every time this screen loads.  On this first visit, talking to him is optional; just give him the lead-lined mask in your inventory and he'll give you a bag of marijuana, after which Mika leaves.  Return here a second time and get a tomato from the red bush.  In this case, you'll need to talk to Yahtzee before Mika can leave.  He has several dialogue options, some of which prompt Mika to leave right away, so if you'd like to explore all his conversation options you'll need to return here three or four more times.  After leaving this screen, return to the art gallery.

Float Art

After entering, go northwest until you get to the room with the bystander looking at a picture of flying hot dogs.  Use your sugar on the tomato in your inventory to get catsup.  If you haven't already done so, put a cocktail weenie from your inventory onto the bun in your inventory.  Otherwise, use the cheeze-whiz in your inventory on the bun and weenie.  In either case, watch a movie as Mika prepares a hot dog.

Give the hot dog to the bystander to get him to go away.  Look at the hot dog picture on the wall and talk to the attendant, telling him you want to buy the painting.  When he leaves to get the paperwork, use Mika's camera to snap a photo (in "landscape" mode) of the painting.  Leave the art gallery and return to the beach on the mainland.  From the beach, go to RON Main street and then to the Realiser.


Use the photo of the authentic hot dog painting on the copier machine to enlarge the photo.  Make your way back to the Lighthouse.


The farmer wants exactly $1,001,350.25 for his sheep (he'll accept neither more nor less).  The value of the hot dog painting is $1 million, the value of the pink sculpture is $1340, and Mika has $10.25 in spare change.  Give all these items to the farmer then talk to him again (ask about "credit") to buy his sheep, which appear in your inventory.  Combine the sheep with the metal pole in your inventory to get a giant-sized cotton swab.  Return to your boat and head out to sea, paying another visit to the sea-giant who earlier blocked your progress.

At this point, Option Path 1 and Option Path 2 merge and play is identical for some time into Chapter 4.  Next is the description for Option Path 2, starting at the point of divergence noted above.  If playing Option Path 1, skip down to the next section after the *****.


Float Art

Using "overhead view mode," click on the blue door to enter the Control Room.  Pixel hunt (perhaps for some time, as I did) using the talk icon until you can talk to the staff in the control room; they each want an item.  Use the "transform cheese" spell in your inventory on the cheeze-whiz in your inventory until you change the cheese into a block of Swiss cheese.  Give the bone club to one man, the poster of the Baron to another, and the Swiss cheese to the third and they'll all leave.  Touch the southernmost control panel to begin a minigame.

The objective of the power control panel minigame is to simultaneously have all three lights turned on while also supplying maximum power to the entire electrical grid.  The larger purpose is to fully illuminate the two paintings (of the cutlery and the mountains) in the southeastern part of the gallery so Mika can photograph in that area.  Manipulate the three yellow levers; when the left display shows all three lights on and the green display on the right has all four segments on/bright green, you've got it.  When I finished, the left lever was in the uppermost position, the middle lever was in the middle position, and the right lever was in the lowest/bottom position.

To leave the control room, head between the brown corners to the north.  Go to the gallery room with the picture of cutlery and the picture of the mountain-- if you correctly solved the power puzzle, you won't see any shadows at all on the wall around the pictures.  Tell the attendant you want to make a purchase, and when he goes away use Mika's camera to photograph the mountain picture (with camera mode 2, "landscape mode").  Leave Float Art, and return to the beach.


The next bit is fairly hokey and caused me endless frustration.  Have Mika wear the lead mask in her inventory, and then click on the boat return to the ocean.  Sail to the area labelled "An island."

The lead mask is by far the single most bug-prone item in a game generally prone to random errors.  I'll stop rather short of saying that due to the erratic behavior of the mask Option Path 2 is genuinely unplayable; I will say, however, I encountered shockingly frequent problems with the item that would likely lead many players to simply (and sensibly) stop playing and never return to the game.  Before sailing to the island, I suggest you save your game with a distinctive moniker so this particular save won't be lost amidst the crowd or overwritten later.  In Chapter Four, the behavior of the mask seems unstable-- sometimes, for no apparent reason at all, Mika is simply unable to wear the item.  I noted one particular such irregularity below involving a can of catsup, but many others remain unknown to me and are perhaps unknowable to anyone.  If possible, the best solution appears simply to:

a)  Have Mika keep the mask on at all times starting right now and until she no longer needs to return to the radiation zone in Chapter Four, and
b)  Play the game continuously (without reloading any savegame) from right now until Mika no longer needs to wear the mask.

Unfortunately (b) is difficult because the game randomly CTDs with some frequency.  Unfortunately (a) is difficult because in many rooms, Mika is unable to deliberately walk (walk ui disabled) while she is wearing the mask.  Nonetheless, you should strive for the goals I've suggested.  If you later lose the ability to wear the mask before entering the radiation zone at the appropriate time to kick rocks, reloading a later savegame may result in Mika still unable to wear the mask-- but if you save right now before Chapter Four starts, you should always (in my experience, at least) be able to trudge onward from this point.


Mika arrives and meets Yahtzee as she leaves her boat.  Take a tomato from the red bush.  Talk to Yahtzee by clicking around to the left of his feet and ask about Bill Cosby to leave the area.  If you'd like to speak to Yahtzee regarding other topics, you'll have to return to the island several times.  The VERY IMPORTANT thing to remember is to always have the mask on when you arrive here; under no circumstances give the mask to Yahtzee, or you'll be stuck later and have to restart from this point.

Make your way back to RON Main street in order to then go to the Realiser.


Use the photo of the painting "Landscape in D" on the photocopier to enlarge it.  Go to the Lighthouse.


The farmer wants exactly $1,001,350.25 for his sheep (he'll accept neither more nor less).  The value of the "Landscape in D" painting is $1 million, the value of the pink sculpture is $1340, and Mika has $10.25 in spare change.  Give all these items to the farmer then talk to him again (ask about "credit") to buy his sheep, which appear in your inventory.  Combine the sheep with the metal pole in your inventory to get a giant-sized cotton swab.  Return to your boat and head out to sea in order to pay a visit to the sea-giant who earlier blocked your progress.

At this point, Option Path 1 and Option Path 2 merge and play is identical for some time.   Therefore until otherwise noted the following section describes what to do next regardless of which path you want to play.


All Option Paths:

Sea Giant

Give your giant-sized cotton swab to the giant.  He'll give you his giant-sized earwax for your efforts.  Leave the map by going south and make your way to Main street.

Main Street

Combine the giant's earwax with your string from Vishnu to make a set of candles.  Light the candles in the fire.

Return to the ocean and visit the giant again.  Talk to him and tell him you have a q-tip to get a second piece of earwax.  This may be a bug, but the extra earwax may come in handy later as an item to give to Habib-- though this current action is more convenient than required.  Go north toward the island to end Chapter Three.



As this chapter begins you play Rhoxanna Zhu, a superhero.

Rhoxanna's Apartment

Get the soup from the shelf.  Open the cabinet to meet Yoda's cousin, who will be your sidekick.  Leave the apartment and go up the stairs.  In the hallway outside Mika's apartment, you can now go north and west after picking up the matches.  Go north first to return to the area seen in the game's opening cinematic.

Security Hall

Look at the security panel by the door.  The puzzle here is sound-based, and you can figure out which buttons to press based on the tones.  Go south, and from the hallway outside Mika's apartment go west.  You'll start in a minigame you can play if you like; after losing once a button appears to skip the minigame if your prefer.  Rhoxanna will be in a hallway outside the security office.  Sometimes one of the diminutive red beasties from the minigame "follows" Rhoxanna back to the "regular" world, which seems to increase the odds the game will suddenly crash for no apparent reason-- so be aware and save frequently.  I couldn't find any purpose to interacting with the grate or the pipes.  Talk to the panel next to the door to gain entry.

Security Office

Watch all the video surveillance records on the machine.  One of them shows (with audio) Professor Emeritus entering the security code to lock the door to his office.  You can listen to the tones repeatedly until you memorize them.  The way I solved the puzzle was by alt-tabbing out of the game and using a sound recording program to record the tones as they played in the video.  Return to the hallway outside Emeritus' office.


If you didn't get the tone sequence on your own yet, use the security panel and press:

Bip Beep Boop Borp Borp Bip Beep DONE

Go inside.

Emeritus' Office

Open the middle drawer of the cabinet on the left to get scissors.  Talk to Logi and ask him about the ceiling fan.  Give him the cans from your inventory he'll ride the fan to shake them up.  Put the cans under the cabinet drawer on the left (where Emeritus put The Book of Secrets during the opening cinematic).  Leave and return to the hallway outside Rhoxanna's apartment.

Outside Rhoxanna's Apartment

Touch the thermostat-- Rhoxanna doesn't want to do this.  Give the scissors to Logi and ask him to do the job, creating some wires.  Take the wires and return to Emeritus' Office.

Emeritus' Office

Use the wires on the cans under the drawer, then touch the wires a second time; Rhoxanna and Logi will move outside the door.  Light the end of the wire with the matches to end this interlude.


Mika wakes up on an Island of Evil.  Use your vacuum on the little vampire dude in the corner to get some blood.  Pick up the nearby board.  Use the path between the rocks to go west.

Switch Door

If you'd like put the board in the water for some dialogue, but I found no other effect.  Use the Levitate spell on Mika to cross over the water-- or use the Freezerman spell on the narrow part of the water to freeze the stream (either way is equally valid).  The white machine here toggles the destination of the door between someplace inside yet another evil lair and RON Main Street whenever you touch the machine and press the "Prev" button.  As for the "Set!" button, I couldn't determine its purpose.  If you didn't previously light your candles, go through the door back to Main Street.  Light your candles in the fire.  If you didn't previously mix a can of "coral" plus "dove white" paint, do that now in the Yahtzeebrand.  Return to the island through the door inside the Yahtzeebrand.  If you did both of these things earlier when I suggested, you really have no reason to go back to town.  In either case, when everything I just mentioned is done go back (east) to the island Beach and then go up the northern path.


Use your crystal ball on the eye of either guardian statue to disable them both.  Head north.


Touch the door-- this situation should seem familiar.  Put your candles on the doormat, then your bowler hat.  Add cinnamon, your vacuum filled with blood, ashes (from the cigar), and the oil-filled sponge.  If you accidentally combined the oil-filled sponge with anything else in your inventory, causing it to disappear (bug?), you should be able to use the Switch Door to go to Storage Room near the elevators (see below).  If you enter the Storage Room for the first time without a sponge, a tin can will be on the shelf; use the tin can on the bucket of oil to get an alternate supply of oil.  In any case once your reagents are assembled in the hat, Mika will cast her spell.  Touch the door again-- this time, the password is "Fishy Fishy."  Go inside.

Entry Area

Look at the smoke alarm.  Use your bag of marijuana on the pot of ashes.  On the left side of the screen, take the "Tigers" sign.  Go west.


Mika encounters a Borgnine-bot, who chases her throughout the fortress during a cutscene.  Once you regain control of Mika, quickly use the fridge magnet on Borgnine to dispatch him (the second of what I felt were categorically unfair puzzles in the game).  I believe the "guy" Ernie here refers to is meant to be Thakbor.  Recall at the start of the game Mika was told by the fortune teller that her "quest" was to give the fridge magnet to Thakbor-- who isn't otherwise in the actual game, and thus never "got" the item he was "supposed" to get.  Mika will return to the Entry Area.  Go east to the Pit Entrance.

Pit Entrance

Put your toilet paper over the entrance to the Tiger Pit.  Put your fire extinguisher on the metal thingie poised over the pit.  Use your paint can on the toilet paper so the pit is "hidden."


If you still have the purple teletubby-weeble-wobble thingie, use your knife on it to obtain a purple triangle thingie.  Put the purple triangle in the big triangle on the eastern wall to allegedly stop the machine from making any more Borgnines.  Go through the door to the north.

Cosby Map Area

Mika meets Cosby here, and during a poignant cutscene he knocks her out.  Mika wakes up in a jail cell.


A mouse darts into a mousehole, and some matches are on the ground nearby.  Pick up the matches.  In a minor pixel hunt, use the knife on the mousehole to get some cheese.  In another minor pixel hunt, click using the talk icon around the bottom portion of the door; when dialogue starts, Mika will ask the guard to open the flap so she can get some air.  Talk through the door again and ask the guard to let Mika out-- and then badger him about it until you get the dialogue option to tease him several times about being scared and he'll open the door.  Use your electromagnet on him once, and then leave the cell.

An alternative method of getting past the guard would be to use an onion from Mika's inventory either before or after the door is open (if the door is closed, use it on his leg visible through the slot in the door); this will cause him to cry and rust away.  He will drop a key that unlocks the cell door if the door has not yet been opened (the key vanishes after unlocking the door, or otherwise is merely yet another item to lug about).  An oddity is that if pursuing Option Path 2 below, one must do this before constructing a hot dog since that consumes Mika's only onion.  Yet when Mika uses her onion on Cosby's sidekick to make him rust away, the item likewise disappears from her inventory as if all used up-- but apparently Mika keeps an extra secret onion in her pants at all times (no wonder she can't get a boyfriend) so the hot dog can still be made even if she appears to lack an onion.  In any case, if you talk your way out of the cell the whole onion debacle is an unnecessary distraction, so perhaps you should just ignore the whole thing and get on with other business.


If due to your previous actions you're on Option Path 1, the game is nearly over.  Do the following:

Entry Area

Go through the Factory and return to Cosby's Map Area-- luckily, Cos' is busy elsewhere.  Notice the two signs in the upper left corner-- take both signs, then return to the Entry Area.

In Mika's inventory, combine the "Tigers" sign with the "Extinguish" sign to get a sign that reads "Extinguishers."  Put this sign onto the spot on the wall where Mika got the "Tigers" sign.  Go west into the Pit Room, and put the "Reality" sign over top of the "Caution" sign.  What a devious trap Mika has set!  Return to the Entry Area.

Light the ash and marijuana filled urn (using the matches) to make some smoke, then fan the flames with the red cloth in Mika's inventory.  Cosby will show up to investigate and then run to get a fire extinguisher.  Adios, Cosby!  Sit back and watch the ending.

Using "Option Path 1" as outlined here, I ended the game with:

--126139 of 333332 points
--6 of 11 power-ups
--Bonus Items Found:  Magic Sword, Picture from Space
--Bonus Modes unlocked:  World's Worst Maze, Random View Replay, and Make the News.

Note that many power-ups can be obtained from winning the various minigames.  Though I enjoyed playing these, for various reasons I wasn't able to finish most of them-- therefore I likely missed out on several power-ups for that reason.


If due to your actions in Chapter Three you're on Option Path 2, you've still got a lot of playing to do.  By retaining the hot dog components rather than giving food to the fellow in Float Art, a large section of the game is opened that would otherwise be unsolvable.  Use the sugar in your inventory on the tomato in your inventory to get catsup.  Use the "transform cheese" spell on the cheese from the mousehole repeatedly until you have cheeze-whiz.  If you haven't yet done so combine the jar of cocktail weenies in your inventory with the hot dog bun; otherwise, combine the cheese-whiz with the weenie in a bun.  In either case, enjoy the movie as Mika prepares a hot dog.

The game seems to have some sort of serious error in Option Path 2 regarding Cosby.  Though the author's failure to plan for this potentiality seems forgivable later, at the moment you may end up rather frustrated.  A bit later you'll find some marijuana you could bring back here and use to light the ash pot as in Option Path 1.  However, I found that if in Option Path 2 I lit the ash pot prompting Cosby to search for a fire extinguisher, shortly after his demise in the Tiger Pit the game consistently crashes with the message:

"An error has occurred.  Please contact the game author for support, as this problem is caused by the game rather than the interpreter.  (ACI version 2.20.154)

(Room 147 script line 94)
Error:  MoveCharacter:  character not in current room"

One would have to pursue this series of events before freeing Habib and Emeritus, since after that action occurs the door in the Storage Room is locked and Mika would be unable to return to Cosby Island.

In any case, the point here is-- don't light the ashes, and leave Cosby alone.  In this path, we've bigger fish to fry.

Leave Cosby Castle and return to the island beach where Mika crashed her boat.  From there, go west to the Switch Door.  Press the "prev" button on the machine so the door's target is the Storage Room on some other island run by some other supervillain, and enter the door.

Storage Room

Warning!  A can of catsup is on the shelf.  Leave the can of catsup alone.  You don't need it, since you had catsup you made from tomatoes and your hot dog is already prepared.  However, the matter is more complex than this-- if you pick up the can of catsup, apparently due to some bug in the game Mika is immediately and forever-after unable to don the lead mask.  Since wearing the mask again will be required to resolve the game in this path, if you pick up the can of catsup here YOU'RE SCREWED.  Trust me, just don't do it.  Instead, go west.

Elevator Room

There are two elevators here.  The left elevator has three possible destinations throughout the island complex, while the right elevator goes to a radioactive jungle zone.  To use either elevator, press the yellow button beside it and then walk into the elevator when you hear a "ding."  The display is buggy-- sometimes the door opening animation doesn't play, but the door is open anyway; just listen for the "ding."  In any case, before fiddling with the elevators go west.

Rock Hall

You can play an optional minigame here by pressing the slot/button on the left.  During the minigame, I found if Mika lets herself get hit once and then stands all the way to the left 49 rocks in a row will usually miss her but she'll have to move out of the way for rock #50 to win the minigame and get a power-up.  In any case, touch the console halfway down the hall on the left.  When the computer display comes up, touch the leftmost panel to move it out of the way and reveal some wires.  Touch these wires if you like for an inexplicably odd cutscene (perhaps indicating Mika is dazed from mild electrocution).  Touch the edges of the display to go back to normal game view, and go back to the Elevators.

Elevator Room

Call the elevator on the left and walk inside when the door opens.  Pick the middle destination.


For now, don't worry about other things going on in this area.  Walk east into the next room and then up into the blurry brownish tube thingie.  Mika will appear in the Detention Area.

Detention Area

Talk to the Sombrero repeatedly until he doesn't offer any new information.  He wants a hot dog.

If you haven't already, combine the sugar in your inventory with the tomato from the other island to get some catsup.  Use the "transform cheese" spell on the cheese from the mouse hole repeatedly until you have some cheeze-whiz.  If you haven't already done so, combine the jar of cocktail weenies in Mika's inventory with the bun; otherwise combine the cheeze-whiz with the weenie in a bun.  In either case, a movie plays as Mika prepares a hot dog.

Each time Mika talks to the Sombrero he floats down toward the floor, so talk to him a few more times until he's almost resting on the floor and then give him the hot dog.  Mika will chat with Habib and Emeritus.  Touch the computer on the left side of the game screen, and when the display comes up "minimize" the security logon to reveal a virtual desktop.  Click on the recycle/trash bin and look at the right file to see a password list.  The password for this particular terminal, according to what's shown on the other screen, is fortunamajor.  Touch somewhere off the screen, and then use the computer again and click on the "entry code" box to enter the password and open the cell door.

You may now switch between playing Mika and Habib.  Switch to Habib.  In Habib's inventory is his toolbox; use this item on Habib and several tools will appear in his inventory.  Select the screwdriver and use this on Habib; several different tips for the screwdriver will appear in Habib's inventory.

Before either character leaves, have Mika give the giant earwax in her inventory to Habib (use the wax on him).  If Mika has no spare earwax because you didn't do as I suggested earlier in the final moments of Chapter Three, then you'll have to do an extra step here.  Otherwise, switch characters to Habib.  Have Habib leave using the western exit from the room.  He'll be in the Window Room.

Extra Step If You Previously Thought You Were More Clever Than the Writer of this Walkthrough

Have Mika leave the cell area by going west.  Light the candles on the shelf with the matches in Mika's inventory.  Return to the cell area.  Switch characters to Habib.  Have Habib leave using the western exit from the room to enter the Window Room.  Take the lit candles from the shelf.

End of Extra Step for Wiseguys

Go east.  Habib will end up on the roof.  Get close to the guard and switch without getting too close, or else the guard will arrest Habib and send him back to the cell.  In that case, though, since the door is left wide open Habib can just walk out of the cell and try again.  Once Habib is on the roof, a good spot for him to wait is in the middle-northern corridor near the door/energy barrier.  Switch characters to Mika.

Detention Area

Have Mika leave by the western exit to the room.  Walk east to access the roof.  Have Mika walk south and then east a bit to use the elevator door along the southern wall of the roof.

Elevator Room

Hopefully you were able to follow my earlier advice regarding the lead mask, and Mika has been wearing the mask all along during Chapter Four.  If not, you've reached the moment of truth-- try to have Mika wear the mask.  If this doesn't work, you're screwed so reload your save game from Chapter Three and try again.  If Mika is able to wear the mask or is already wearing the mask, press the yellow call button for the rightmost elevator and enter the elevator when you hear a "ding."

Radiation Jungle

If you like, gather a batch of wild marijuana from trees on either side of the elevator structure.  The general objective here is to kick rocks from the rock pile near the southern edge of the screen into the holes near the southern edge of the screen.  This will distract the guard near the switch on the roof, allowing Habib an opportunity to work his engineering magic on the switch.  An important practical consideration here, given all the difficulties associated with the mask, is to keep in mind that if you touch Mika herself with the hand icon she'll take off the mask and be forced to flee the radiation in this area.  If that happens, you very likely won't be able to put the mask back on and return here-- so you'll have to reload from a previous save.

Click using the hand icon on the pile of rocks.  Mika says she doesn't want to touch them.  Click on the rocks again and Mika offers to kick the rocks.  There are three large holes in the ground-- kick one rock into the very southernmost ("middle") hole.  Mika wonders if Habib heard the rock fall; return to playing Mika.  Then kick one rock into the westernmost hole; "something happens."  Finally, kick one rock into the easternmost hole; Mika again wonders if Habib heard the rock fall.

The guard on the roof should be distracted by this last falling rock and wander away from his post-- allowing Habib time to approach and fiddle with the switch on the roof.  With Habib as the active character, use the hand icon on the switch; after Habib comments that he did something or other, have him walk away before the guard returns.

The energy barrier blocking the middle-northern path on the roof is now down, but in theory no one should yet be ready to proceed to this newly available area.  Have Habib travel to the Rock Hall.

Rock Hall

Touch the computer security panel to bring up the display.  Touch the exposed wires earlier revealed by Mika.  In Habib's inventory, put the philips head on his screwdriver and use the screwdriver on the handle in the lower right corner.  At first this will seem not to have accomplished much, but be patient.  Touch the handle, then touch the red "key" that appears.  Touch the wires on the left again to hot-wire the security station, then exit the display.  The door at the north end of the hall is now unlocked, so enter it.


If you like, read the sign on the far left side of the bedframe.  However, this isn't necessary since you're following my groovy walkthrough; the sign merely says the forcefields may be deactivated with an Orb of Kaltos.  Use Habib's Orb of Kaltos on the yellow circle to the left of the grate.  Touch the orb to bring up an interface screen.  Touch the purple plug on the right, and then on the green/white area of buttons on the left:

1) Touch the leftmost white button, then the middle white button, then the rightmost white button;
2) Touch the top and then the bottom button in the leftmost column of buttons;
3) Touch the top and then the bottom button in the middle column of buttons.

This will lower the forcefields around everything.  Put the flathead tip onto Habib's screwdriver and use the screwdriver on the dice atop the table on the right.  Use the wax (or candles, if you instead have those) on the dice.

Habib has some mercury in his multimeter.  Sadly, I could find no way to break the multimeter.  In theory, doing so and applying the mercury to the dice would make the next section easier.

In any case, switch characters to Mika.  Touch Mika with the hand icon and she'll take off the mask, prompting her to leave the jungle (walking into the elevator doesn't work).

Elevator Room

Use the left elevator to travel to the roof.  Approach the brown thingie in the now-unlocked passageway created when Habib fiddled with the roof switch.  You may want to save the game here.  In any case, your epic journey beyond the edge of reality is almost over.  Touch the brown thingie/portal.

Throne Room

At last, the ultimate source of evil is revealed.  After the cutscene, if you'd like to look around the Throne Room move quickly to left and stand next to the vending machine-- all the fireballs will miss you.  You can also get a final power-up here by touching the wall next to the vending machine.  When you're ready to fight the final battle, walk toward the throne dodging fireballs as necessary.

Fight it out!

Mika battles the King in a turn-based fight whose central mechanic is dice rolls.  Read the on-screen instructions, and then just fiddle around with things until you figure out how to beat your opponent.  I think you should choose "item" repeatedly until you've consumed all your power-ups, as this boosts your speed and attack value.  After that, try different strategies of magic and physical attacks until you win.  Habib enters the room briefly.  When you're ready to leave, walk south to return to the roof and then make your way to the Bedroom.  Once there, enter the hole in the floor previously covered by the grating.


After this... er, things get weird.  However, don't panic.  Wander about to find the exit for each room, which is generally opposite from your entry point.  In other words if Mika appears on the left, walk right.  If Mika appears down low, walk toward the top of the screen.  When you see Habib and Emeritus, you're about halfway through these areas.  Along the way is a locked door, but I after all the time I spent playing this game I was too excited to approach resolution to care much about it beyond trying the green gem as a key (which didn't work).  Eventually you'll make a startling discovery; after that you'll want to walk into various black-hole sorts of portals and encounter a familiar face.  Talk to this person to start the end-game cutscene.

Though I'm certain I've not played remotely as many adventure games as most others here, I have played my fair share-- and Edge of Reality is in my opinion one of the very most difficult games I've experienced that was at the same time plausibly solvable.  Let's be honest, many of the "classic" "hard" AGS games simply cannot be won by even better than average players without a walkthrough because they are both inherently and pervasively both unfair and irrational.  Though I'm very fond of games such as Infinity String and Emily Enough, in my view these fall squarely into that category.  Edge of Reality, with only a few exceptions, is a different breed.  Congratulations to the author on making such a fine game!

Using "Option Path 2" as outlined here, I ended the game with:

--333333 of 333332 points
--8 of 11 power-ups
--Bonus Items Found:  Magic Sword, Picture from Space
--Bonus Modes unlocked:  World's Worst Maze, Random View Replay, and Make the News.

Note that many powerups can be obtained from winning the various minigames.  Though I enjoyed playing these, for various reasons I wasn't able to finish most of them-- therefore I likely missed out on several power-ups for that reason.

The "Bonus Modes Unlocked" are worth a look if you enjoyed the game.  Random View Replay is rather strange, as the game itself remains the same but the animation used for the player-character changes (to Michael Gower, to a Blue Cup, to whatever other sprites are present in the game) whenever moving to a new area or sometimes merely when walking.

One inventory item I never found a use for was the Green Gem, described as:

This beautiful gem is quite possibly the most powerful relic in the universe.

If anyone knows whether this item has any function or what that function may be, please comment below.  Perhaps this item is similar to Mika's fireproof panties-- having it prevents something from happening rather than actuating anything, and I never noticed because I was always carrying the gem after I obtained it.  I probably missed a few other items and/or interactions here or there (for example, Habib's multimeter) as well-- but since I've outlined above how to resolve both endings in the game, anything I overlooked must surely be in the "bonus" category.

**End of walkthrough by Endocore for Edge of Reality by Blake Speers**


I don't know if you get notifications, but thank you for this, I made this game years ago, and your review and walkthrough brought back a lot of memories. I also laughed so hard I literally fell out of my chair. Sorry for all the spelling mistakes and bugs back then! I don't know why the mask was such a problem, but I guess it never worked!

SMF spam blocked by CleanTalk