Adventure Game Studio Official

User reported issues for officially released versions of AGS

Bug Issue: AGS Editor does not start: "System.BadImageFormatException: File is Corrupt"

Pages: [1]

Ocean

  • AGSer
  • Posts: 0
« on: 01 Sep 2017, 13:01 »
Open attempting to start the game the editor from the windows start menu, two error pop-ups occur and the editor does not start.

Please see linked image for full error details.

I did a clean re-install, and I am not actively attempting to load any projects, just start the editor itself.
Operating system is Windows 7, 64 bit.


Crimson Wizard

  • AGSer
  • Posts: 7,594
« Reply #1 on: 01 Sep 2017, 13:36 »
UPD. Information from Microsoft on this error:
https://msdn.microsoft.com/en-us/library/k7137bfe.aspx
https://msdn.microsoft.com/en-us/library/system.badimageformatexception.aspx
I guess what this means is that one of the program component failed to load up because of 32-bit/64-bit mismatch or required .NET version mismatch. However that's very strange, if that were the case, how does it work for other users?
Aside from that, some discussions I found in the web indicate this may be an issue with certain versions/updates of .NET framework.

Could you tell which .NET Framework versions are installed on your system? Also, do you install AGS Editor in Program Files or Program Files (x86) folder?


« Last Edit: 01 Sep 2017, 14:39 by Crimson Wizard »

Ocean

  • AGSer
  • Posts: 0
« Reply #2 on: 02 Sep 2017, 00:36 »
Microsoft .NET Framework 4.6.1 is installed on my system. I'm not sure how to check for other details regarding that. I'm fairly certain I would have installed the x64 bit version if that was applicable.

AGS Editor was installed into the "Program Files (x86)" folder by default. As I write this post, I uninstalled it, and re-installed it in the "Program Files" folder instead. It did not change the error messages occurring.


Crimson Wizard

  • AGSer
  • Posts: 7,594
« Reply #3 on: 02 Sep 2017, 00:43 »
Microsoft .NET Framework 4.6.1 is installed on my system.
Do you also have .NET Framework 2.0, which is required for AGS? It is a separate installation that is not included in higher versions.
« Last Edit: 02 Sep 2017, 00:44 by Crimson Wizard »

Pages: [1]

Issue Details

  • Reported
    01 Sep 2017, 13:01
  • Updated
    02 Sep 2017, 00:43
  • View Status
    Public
  • Type
    Bug
  • Status
    New
  • Priority
    Normal
  • Version
    Adventure Game Studio 3.4, AGS 3.4.0
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    (none)

Tags



Powered by: SMF Project Tools 0.5.4 © Niko Pahajoki 2007-2011