AGS Engine

Further development of AGS engine

Bug Issue: Mouse laggy movement

Pages: [1]

Crimson Wizard

  • AGSer
  • Posts: 7,508
« on: 11 Nov 2017, 16:34 »
User report:

It's like mouse cursor (in a game) doesn't move properly like Windows cursor. It's slower and laggy. This exists since v. 2.72.
It isn't a speed issue. The issue is the mouse cursor is laggy all the time regardless what FPS the game has (windowed or full screen). It looks like the mouse cursor is fixed to 15-20 FPS. I even tried incredible game speeds like 250 FPS. The game was fluent but the mouse cursor was still the same. I last tried it with AGS 3.4.0. I always use 32-bit colors and alpha blending in my games

I also tried UpdateCursor() function and it didn't help.


Similar symptoms, but not known if related:
https://github.com/adventuregamestudio/ags/issues/416
http://www.adventuregamestudio.co.uk/forums/index.php?issue=459.0



UPD: The solution could possibly be to update mouse cursor at higher frequences regardless of GameSpeed.
(Why is it even bound to game speed in the first place? Need to find that out)
« Last Edit: 12 Nov 2017, 19:20 by Crimson Wizard »

Pages: [1]

Issue Details

  • Reported
    11 Nov 2017, 16:34
  • Updated
    11 Nov 2017, 16:34
  • View Status
    Public
  • Type
    Bug
  • Status
    New
  • Priority
    Normal
  • Version
    Adventure Game Studio 3.4
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Mouse

Tags



Powered by: SMF Project Tools 0.5.4 © Niko Pahajoki 2007-2011